Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: comdlg32.dll

09 Feb 2011   #1

Windows 7 Ultimate x64

I have had a problem with a few programs crashing on file opens. Checking the windows logs show that all have the following in common

"Faulting module name: comdlg32.dll, version: 6.1.7600.16385, time stamp: 0x4a5bdf76"
  1. Running sfc /scannow results in a cannot fix error and identifies comdlg32.dll as corrupt. probably ran about 10 to 15 times with no success (plus a few other non fixables)
  2. I took ownership of the comdlg32.dll file and renamed it to corruptcomdlg32.dll just in case I needed it later
  3. reran sfc with the same results and no fix
  4. then ran a install repair from the Win7 DVD again with the same result - did not install a new comdlg32.dll
  5. did a search of my C drive looking for comdlg32.dll which found about 20 copies of "...longstring..comdlg32.dll.mui" one for each time I had run sfc /scannow from the date:timestamps.
  6. picked one of these copied it into C:\windows\system32 and renamed it to comdlg32.dll. Ran a selection of the previously crashing applications and all worked as required.
I have wasted a couple of days on this and was getting close to going back to LINUX. My question really is "Why would neither the repair install nor sfc /scannow actually do the repair but leave the required files in place"
I could only come to the conclusion that even using an elevated cmd shell it could not handle files that were identified as belonging to "trusted installer"

This is not just an academic question as while the other files thast cannot be repaired appear to mainly truetypefont files one is winresume.exe

My System SpecsSystem Spec
10 Feb 2011   #2

Microsoft Community Contributor Award Recipient


My System SpecsSystem Spec
10 Feb 2011   #3

Windows 7 Ultimate x64

Thanks for the tip. Even though its a win 95 solution I get the general idea. I guess the real question to me out of this is why would neither sfc nor install/repair apply a fix even in the case where there was no comdlg32.dll (because I had renamed it) in windows/system32 ?
My System SpecsSystem Spec



Thread Tools

Similar help and support threads
Thread Forum
COMDLG32.OCX Error Help? I've Tried Everything...
While working on some video game stuff, I was hit with multiple different COMDLG32.OCX error messages when opening different programs. I've spent the day trying to find a solution. I've followed every instruction to a tee and I'm still getting error messages. So far, I've downloaded the...
heyy Im have problems loading up the utility programme I have to run it as administrator for it to connect with the game im playing but it keeps coming up "Componet comdlg32.ocx or one of its dependecies not correct registered: a file is missing or invalid I have looked at threads and...
BSOD Help and Support
Component "COMDLG32.OCX" or one of its dependancies
Component "COMDLG32.OCX" or one of its dependencies not correctly registered: a file is missing or invalid. This is the error message I got when trying to open a program used at my place of work. Is there either a way around this or a way to fix this so that this error message no longer pops up...
General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 13:41.
Twitter Facebook Google+