Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: New Build - Drive Recognition Problems

06 May 2011   #1
jiroband

Windows 7 Professional 64-bit
 
 
New Build - Drive Recognition Problems

I just finished my first desktop build and installed Windows 7 Professional 64-bit. I've got 2 drives: Drive #1 (OCZ Vertex 3 SSD - 120G) and Drive #2 (WD Caviar Black - 1TB). I'm using Drive #1 as the Boot Disk where "programs only" will be installed, and Drive #2 will be used for storage. Everything seemed to go fine, except after installation, Explorer did not recognize Drive #2; but, the Device Manager did see it. It is calling Drive #1, "Disk 1." It is calling Drive #2, "Disk 0."

Under Device Properties/ Volumes Tab, this is what my Disk #2 (the WD Caviar Black) is showing:

Disk: Disk 0
Type: Unknown
Status: Not Initialized
Partition Type: Not applicable
Capacity: 953870 MB
Unallocated Space: 0 MB
Reserved Space: 0 MB

After searching various forums for information, this is what I did:
1. I accessed the disk this way: Control Panel>Administrative Tools>Computer Management>Storage>Disk Management
2. I located the disk under Disk Management, then right-clicked and chose Initialize Disk

This seemed to work, however, it was now recognized as Drive E, since Drive D was the name already given to my DVD drive. I should have stopped there, but since I am very picky and want everything to be just so, I temporarily renamed my DVD drive to Drive F, so that I could rename the newly recognized Drive E to Drive D. Then, after renaming Drive E to Drive D, I noticed something strange --my newly renamed Drive D (the WD Caviar Black - 1TB), showed a total capacity of 99.9 MB! As it turned out, what happened is that 99.9 MB of my Drive C got partitioned into a Drive D. I have no idea how this happened -- I have been extremely careful. Now I'm stuck. My WD Caviar Black - 1TB, is back to being unrecognized by Explorer, but is recognized by the Device Manager. . . and my OCZ Vertex 3 has been partitioned into Drives C and D, which I don't want.

Can anyone help me figure out how to remove the partition on the OCZ drive, and help me to get Explorer to recognize my WD drive?


My System SpecsSystem Spec
.
07 May 2011   #3
jiroband

Windows 7 Professional 64-bit
 
 

Theog,

I just tried to boot up my new build so that I could do the screen capture, but the boot failed. It says that BOOTMGR is missing. I had previously tried to remove the "D" partition myself, but it must have contained some data. I did check on this first before deleting, but it said the partition was empty -- it must have lied to me.

This is a new build -- the only thing installed was Windows 7 -- I had not yet gotten to the point of registration or checking for updates. If it is best to wipe everything out and start over from scratch, I have no hesitation in doing that. If that is recommended, I just need to know the best way to do this. Obviously, I have much to learn -- I know just enough to be dangerous!

If I do a reinstall, is there something I should do in BIOS first to get the system to recognize my second drive? Do I need to initialize my second drive somehow before installing Windows 7?
My System SpecsSystem Spec
.

07 May 2011   #4
pbcopter

Windows 7 Ultimate x64 SP1, Windows 8.1 Pro x64, Windows 10 Pro x64
 
 

What happened is since you had both drives installed when you installed Windows 7, it saw the 1TB drive as drive 0 and installed the 100MB reserved boot partition there. (It always installs this on the first drive it sees, in this case drive 0)
Then it installed the operating system on the SSD.
I would disconnect the TB drive and reinstall Windows 7 on the SSD.
Then reinstall the 1TB drive.
Then make sure that the SSD is the first drive in the boot priority in the BIOS.

Edit: Where are you connecting the SSD?
My System SpecsSystem Spec
07 May 2011   #5
jiroband

Windows 7 Professional 64-bit
 
 

pbcopter,

Both the SSD and the HDD are SATA3. I have two SATA3 ports on my motherboard – so that’s where they are connected. I made sure to get a motherboard with the new Marvell 88SE9182 chip so that my Vertex 3 would be able to operate at its full potential. The SSD is set to boot first under BIOS, followed by the DVD drive. I thought that would prevent any problems.

So, you are saying that all I need to do is disconnect the HDD, put in the Windows 7 disk and reinstall Windows 7? Will this create any duplicate files that will clutter my SSD? Do I need to run FDISK on the SDD, or do something else to wipe it clean first? Do I need to do something to remove the partition first, or will reinstalling Windows 7 remove the partition?
My System SpecsSystem Spec
07 May 2011   #6
pbcopter

Windows 7 Ultimate x64 SP1, Windows 8.1 Pro x64, Windows 10 Pro x64
 
 

I would use the secure erase function from the OCZ toolbox and then reinstall Windows 7 to the unallocated drive drive. No other drive connected.

If you have been to the OCZ forum yet, I would take a look. Lots of good info.

SandForce - Vertex2/LE/Pro, Agility2, Vertex2/Agility2 EX Drives, REVO and HSDL drives
My System SpecsSystem Spec
07 May 2011   #7
jiroband

Windows 7 Professional 64-bit
 
 

pbcopter,

Thanks for the tip! I downloaded and did the Secure Erase on the Vertex 3 SSD. Then I shut down, unhooked the WD HDD, rebooted and installed Windows 7. I then restarted and did all 74 windows updates. Then I shut down, plugged the WD HDD back in, restarted, and checked Explorer for the WD HDD – but it was not there. As before, I can find it under the Device Manager.

What do I do now to get Explorer to recognize this WD HDD?

By the way, in case you are wondering why my Vertex 3 SSD is nearly half full, I've also installed Office Professional 2010 and Adobe CS5 Design Premium Suite.


Attached Thumbnails
New Build - Drive Recognition Problems-dm.jpg  
My System SpecsSystem Spec
07 May 2011   #8
pbcopter

Windows 7 Ultimate x64 SP1, Windows 8.1 Pro x64, Windows 10 Pro x64
 
 

Is there anything on the 1TB drive?
If there is nothing on the 1TB drive, just right click on it in disk management and create a simple volume and quick format it.
My System SpecsSystem Spec
08 May 2011   #9
Bare Foot Kid
Microsoft MVP

W 7 64-bit Ultimate
 
 

Hello jiroband, welcome to Seven Forums!



This tutorial at the link below shows how to create Primary partitions from the unallocated space.

Partition or Volume - Create New


Also Method One of this tutorial shows another partition structure that is very useful.

Partition / Extended : Logical Drives
My System SpecsSystem Spec
08 May 2011   #10
jiroband

Windows 7 Professional 64-bit
 
 

pbcopter,

Thanks - the right-click, Create Simple Volume, then Quick Format worked
! (By the way, I did the Secure Erase on that drive first -- to make sure it was clean.)
My System SpecsSystem Spec
Reply

 New Build - Drive Recognition Problems




Thread Tools




Similar help and support threads
Thread Forum
Question about recognition of a USB floppy drive
I've been going through all of my hardware from the XP days today (remember XP?) and stumbled across a brand new NEC USB floppy drive. I thought I'd try it so when I plug it into a USB port, I get the characteristic wave sound and same for unplugging but it doesn't show up in my file manager...
Hardware & Devices
Flash drive recognition delay
Every time I plug my flash drive in to my windows 7 x64 PC there's a delay of about a minute before it gets recognized by the operating system (where it seems to be doing nothing - the light on the drive is just on not flashing). The drive's fine as it gets instantly recognized on Linux and OSX. ...
Hardware & Devices
automatic recognition of D drive
windows 7 is not automatically recognizing a data disc when i place it in the D drive. How do I click on the automatic recognition?? I know it can be found somewhere, but where??
General Discussion
flash drive recognition by different computers is not the same
I may know how to resolve this issue, but would like to have confirmation before making any changes. This represents a learning experience for me. I use two flash drives on a regular basis. One is reserved for school files and assignments. The other is used at home. I have given both flash...
Hardware & Devices
non recognition of external drive partition
I have an Iomega edternal 1tb drive attached to my laptop.NOW WINDOWS 7 does not show the main partition. It does show the second partition on which there is ther w7 backup. All partitions appesar under Vista ultimate on the same machine. How can I get windows7 to show the missing poartition? Any...
General Discussion
No recognition of DVD drive
with Nero or convertxtodvd my system does everything required until it comes to burning disc and then asks to put one in, when there already is. Actually if I put in any DVD it is not recognized at all and just sits there. Help!
Software


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 03:32.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App