Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Recouver MBR

28 May 2011   #1

Windows 7 Proffessional x64
Recouver MBR


I have the following Problem:

I installed windows 7 then vista then Ubuntu. I had grub as primary boot-loader which chain-loaded the windows 7 boot-loader. Now I tried to install Linux Mint which overwrote the Windows 7 boot-loader. I tried to recover it but it didn't work (I tried bootrec and bootsec) because of the recovery attempt grub also doesn't boot any longer.

the Hard drive is partitioned as follows:
D:, dev/sdc1 System Reserved, 105MB, HPFS/NTFS, bootable
F:, dev/sdc2 Windows 7, 524 GB, HPFS/NTFS
G:, dev/sdc3 Vista, 105 GB, HPFS/NTFS
dev/sdc4 extended Partition (0x05), 105 GB containing:
-dev/sdc5 Linux swap, 4,1 GB
-dev/sdc6 Linux, 101 GB, ext4,
-dev/sdc7 Linux, 164 GB, ext4,
-some free space

bootrec finds my two Windows Partitions F and G but when i try to run Fixboot it fails saying "element not found"

What can i do to recover my partitions?

Can i somehow make a totally new Boatloader and MBR if so how?

*title should be recover sry for my bad english I'm not a native speaker.

My System SpecsSystem Spec
28 May 2011   #2

Windows 7 Proffessional x64

I ran Startup Repair 3 times it says:
Root cause found:
The partition table does not have a valid System Partition
Repair action: partition table repair
Result: Completed successfully

But still nothing happens after boot.
My System SpecsSystem Spec
28 May 2011   #3


Did you mark Win7 partition Active first before running up to 3 Startup Repairs with reboots between each?

You may need to wipe GRUB off the HD entirely as it can corrupt Win7 boot beyond repair, and may already have.
My System SpecsSystem Spec

28 May 2011   #4

Windows 7 Professional x64 SP1 ; Windows Server 2012 R2 Standard

Follow Method 2

Partition - Mark as Active
My System SpecsSystem Spec
09 Jun 2011   #5

Windows 7 Proffessional x64

Finally some progress:
I unplugged all other hard drives and started the PC. I finally got an error message from the boot-loader instead of Grub starting up.

File: \Boot\BCD
Status: 0xc000000f
An Error occurred while attempting to read the boot configuration data
After that the System Recovery was finally searching for startup options instead of showing me no operating system to fix. I got the message:

Windows found problems with your computer's startup options.
Do you want to apply repairs and restart your computer?

under "view details" it showed me my lost windows vista and 7.

I restarted and BAM! My windows is back!

So what did I learn: Before doing all kind of stupid repair attempts with bootrec, bootsec, bcdedit, copying bootmgr to my operating system partition and what not just try following directions and UNPLUGG YOUR F***ING OTHER HARDDRIVES.

Now i should be able to reconfigurer grub as startup manager and everything is good.
My System SpecsSystem Spec
09 Jun 2011   #6

Windows 10 Home Premium 64bit sp1

Samy345 ,I have learned Windows 7 is kinda sensitive .

I went to reinstall 7x64 and couldnt figure out why it wouldnt take .after hours and hours of trying to install i finally got messages pertaining to why it wouldn't install .

After all the bs and half day being spent My remote bluetooth was the reason windows failed so yes unplugging all the hdd and other little devices you use is a must or win 7 will have you pulling your hair out
My System SpecsSystem Spec

 Recouver MBR

Thread Tools

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 20:37.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App