Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: MBR to raid drive (which requires drivers)

28 May 2011   #1

Windows 7 Enterprise
MBR to raid drive (which requires drivers)

Hey all.

I just done a really nice install, so didnt want to brick this drive so wanted to find out the best solution to my issue.

I have windows 7(enterprise), installed over 2 harddrives in raid0 (using sil controller), which during instillation requires drivers to see the hard drive.

Which is why i am uncertain if the bootsec.exe on the install will be able to point to the hard drive to install the boot loader into the MBR (which I believe is blank at the moment).

Would it be useful to install it to the 8mb partition windows makes on the same drive for the recovery process?.
I was thinking of installing grub2 on it instead, but saw a few recommendations not to because it requires nix filesystem or something.

I will be installing ubuntu on another drive at a later time, but would rather use my motherboards change boot device instead of a single boot loader on a single device. which is where I got this issue from in the first place (My boot loader is on a broken drive, which is slow to load. but lucky the boot sector has still been working).

What are your tips/advice ?
I think a while back I tried the fix tools on the windows install, but it never fixed the bootloader onto the mbr. So I believe it will be a manual process e.g. using the bootsec application.


My System SpecsSystem Spec
29 May 2011   #2

Windows 7 Enterprise

ok heres an update.

I found out I need to load my raid drivers first, and select the operating system from the "system recovery options" menu on the windows 7 install repair process.

However when I try loading the drivers.
and select either of the 2 (same name) drivers, it waits a second then says "The instillation has failed".

Without this I cannot see the windows drive to repair the mbr.

I am sure they are the right drivers, cause I did the install using the same drivers not 2 days ago.

I have tried both the "system information" files in the driver folder. one for my sil5 chipset. and the incorrect pesudo type one.

So again when i select the correct system info, it shows me the driver (twice. which is "Silicon Image SiI 3114 SoftRaid 5 Controller").

When selecting either of them, and clicking add driver, after 7 seconds of "add driver, adding driver", it returns.
"Add Driver - The instillation has failed".

This is different to everywhere else I have been seeing of "certificate errors" , or another type of load fail.
but this isnt a load fail, its an instillation fail.. which makes me thing its this recovery tools cannot load it, but the fresh install can.

Would it be worth trying the grub loader now ?
My System SpecsSystem Spec
29 May 2011   #3

Microsoft Community Contributor Award Recipient


As you are using Company software have a word with the Company IT Administrator.
My System SpecsSystem Spec

30 May 2011   #4

Windows 7 Enterprise

alright update and all fixed.

I had loads of issues reinstalling windows.

After reading around on loads of forums.
I found out I had to pull out all other hard drives i wasnt using (even though I didnt need to do this on the install the other day).

I was installing off a usb stick.
but it wouldnt let me write windows to the drive today.
so I had to write windows to a cd, then boot off that.

after that and loading the drivers it all worked fine
(although its a shame windows 7 doesnt come with the nforce4 drivers, as ubuntu does.).

either way the reinstalled fixed the boot issue.

Thanks anyway
My System SpecsSystem Spec

 MBR to raid drive (which requires drivers)

Thread Tools

Similar help and support threads
Thread Forum
New SSD detected in bios but not by install, requires drivers
I have a HP and I am trying to do a clean install of Windows 7. My SSD is detected in the Bios. But during the Windows 7 installation, the part where I supposed to select which hd/partitioned to install Windows 7 on, my hdd is not listed. It ask for drivers but I think I have the wrong ones or am...
RAID drivers but disks are NOT RAID - do I need them?
Hi - "Autoruns" tells me that several drivers labelled "RAID" are getting loaded on boot/login (marked yellow in the image), but my disks are NOT RAID, just regular SATA and NTFS. Similar question for the multiple USB drivers...? (Win7, 32 bit) Do I need them, or can I remove them from the...
Win 7 setup & requires drivers
Alright, so here I am, enjoying some new PC parts I bought (hey, an upgrade is an upgrade) and now I am trying to install Windows 7 Ultimate 32bit (maybe the whole problem for me?). Anyway, my Motherboard is ECS GF8100VM-M5, AMD Athlon II X2 at 2,8 GHz is my CPU, ATI Radeon HD 3450 GPU (old I know,...
Installation & Setup
RAID 5 switched from single storage to raid 5, lost drive letter
I am running 7 pro 64bit on a ASUS p8p67 deluxe mobo and I copied all data from my 1tb storage D: drive to a backup external and proceded to install raid 5 with 3 single 1tb drives and the raid is up an running. However using Intel Rapid Storage Technology to setup the raid inside windows I had to...
General Discussion
Seagate says 3TB drive requires 64-bit OS
Read More: Seagate says 3TB drive requires 64-bit OS | TG Daily
Hardware & Devices
Drivers folder requires authentication!?
Hi all, I'm trying to add a driver to windows>system32>drivers but every time I drag the .sys file in it tells me I need to authorise the folder for this to work. I have only one user on the lap top and have ensured that this is the admin account and it has full permissions yet it still...

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 22:04.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App