Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: When I click "install now", it's saying "No device drivers were found"

10 Jul 2011   #21
Xylonez

Windows 7 home premium x64
 
 

the problem is that i need my laptop to do my assignment be4 next week...
Ive just been thinking about it, but is it because of the fingerprint and cam that is built-in in my laptop?


My System SpecsSystem Spec
.
10 Jul 2011   #22
gregrocker

 

Where did you download the ISO from? Use the official Win7 downloads from My Digital Life, then write to stick or burn to DVD using the MS tool: Windows 7 USB-DVD Download Tool

If this still fails, wipe the HD using tutorial posted by Theog above.

If that fails, reset the CMOS: Clear CMOS - 3 Ways to Clear the CMOS - Reset BIOS While in BIOS setup set SATA controller to AHCI to try install first, then IDE if necessary.

If that fails, try removing all but 2gb of RAM to try install.

If these all fail, test your RAM and HD using extended diagnostics CD test:
RAM - Test with Memtest86+
HD Diagnostic
My System SpecsSystem Spec
11 Jul 2011   #23
Xylonez

Windows 7 home premium x64
 
 

Quote   Quote: Originally Posted by gregrocker View Post
Where did you download the ISO from? Use the official Win7 downloads from My Digital Life, then write to stick or burn to DVD using the MS tool: Windows 7 USB-DVD Download Tool

If this still fails, wipe the HD using tutorial posted by Theog above.

If that fails, reset the CMOS: Clear CMOS - 3 Ways to Clear the CMOS - Reset BIOS While in BIOS setup set SATA controller to AHCI to try install first, then IDE if necessary.

If that fails, try removing all but 2gb of RAM to try install.

If these all fail, test your RAM and HD using extended diagnostics CD test:
RAM - Test with Memtest86+
HD Diagnostic
I think that I found the problem.. I tried burning the iso image from digital life to another USB.. When it finished burning the iso it says sth about bootsect, and I was unable to create a bootable USB.. Any solution?
My System SpecsSystem Spec
.

11 Jul 2011   #24
Xylonez

Windows 7 home premium x64
 
 

I think it's because I'm creating thE bootable USB from my friend's 32 bit computer.. Any solution?
My System SpecsSystem Spec
11 Jul 2011   #25
gregrocker

 

Did you format the USB stick first?

Try using this tool with Win7 in the dropdown menu: Universal USB Installer – Easy as 1 2 3 | USB Pen Drive Linux

If this fails install UltraISO trial, on File tab Open ISO, on Bootable tab choose Write Disk Image, Format, Write.

One of these methods has got to work if you have an intact ISO. Boot stick under USB or HD's.
My System SpecsSystem Spec
11 Jul 2011   #26
Xylonez

Windows 7 home premium x64
 
 

Quote   Quote: Originally Posted by gregrocker View Post
Did you format the USB stick first?

Try using this tool with Win7 in the dropdown menu: Universal USB Installer Easy as 1 2 3 | USB Pen Drive Linux

If this fails install UltraISO trial, on File tab Open ISO, on Bootable tab choose Write Disk Image, Format, Write.

One of these methods has got to work if you have an intact ISO. Boot stick under USB or HD's.
Ya, I have already format it... I even cleaned it using diskpart, and create the new partition again.. Anyway I will try to create the bootable USB in another 64 bit OS, and will give the news ASAP..

And, no the easy pen drive Linux failed for me... Maybe that's because I create the bootable USB in 32 bit OS too..
My System SpecsSystem Spec
12 Jul 2011   #27
theog

Microsoft Community Contributor Award Recipient

ME/XP/Vista/Win7
 
 

Quote   Quote: Originally Posted by theog View Post
If you wont to reuse the USB Pendrive, use this Method two in this tutorial:
USB Windows 7 Installation Key Drive - Create
Put USB Pendrive in the bin, & got a new one.
Use Method two above.
My System SpecsSystem Spec
21 May 2014   #28
kiemrong08

Windows 7 Ultimate x64
 
 

With my laptop Dell Vostro 3560. When I install windows 7 using USB. I go to BIOS and set USB debug to Enable. It's work like a charm !
My System SpecsSystem Spec
21 May 2014   #29
gregrocker

 

With the new UEFI Bios use Option One in http://www.eightforums.com/tutorials...e-windows.html or set Bios to Legacy or CSM with MBR boot first. Delete all partitions during install to clear old disk format.
My System SpecsSystem Spec
Reply

 When I click "install now", it's saying "No device drivers were found"




Thread Tools




Similar help and support threads
Thread Forum
HDD shows in "Device Manager" but not in "DiskPart"or" Disk Management
Hi Guys, any ideas how to access my external hard drive device manager can see it but it does not appear in disc management. I use this HDD perfectly in my car HDD player. But when I try to connect it to my Laptop, it does not show up in disk management. Please check the attached screen...
Hardware & Devices
"install now" on windows 7 home premium provides me with "no device.."
Hello, i have read up on this error, but i can't seem to find the solution :(. I know this post is common, but i feel i really do need assistance. The message comes up as "no device drivers were found. Make sure that the installation media contains the correct drivers, and then click OK". I have...
Installation & Setup
Need to add "TASKBARS" (MSese for "Launchpads", "Docks" NOT "Toolbars"
My office just upgraded, and I can no longer use Windows XP. On this system, I was able to add a separate taskbar to facilitate quick access to commonly-browsed folder locations on our vast network, and another one expedited the launching of useful programs and lists. Each task on each taskbar...
General Discussion
installing windows 7 "No device drivers were found"
I have a HP ML110g5 server which I have disconnected the smart array and connected a HDD via sata directly to the motherboard. when installing windows 7 "No device drivers were found etc." does anyone know where I can get the drivers (I assume for the HDD) so windows will recognise where to...
Drivers
Windows 7/Vista Install "No Device Driver found"
Hello. I recently bought a new Sata 3 Hard Drive (500gb Sata 3 Barccuda) for my PC. I've downloaded countless Windows 7 ISO's. I have a LEGIT key. After burning it on ImgBurn, Nero and Poweriso at 4x and 3.5 (Can't go lower than 3.5) It gets to the Language setup after 30minutes or so, Than a...
Drivers
"No device drivers were found ..." when trying a clean Win7 install
Hi, I've a samsung with some extra samsung features (samsung update plus, speed up manager, recovery system etc.) and they bug me. Therefore I wanna do a clean installation on my laptop but when I boot up on my USB (works fine) I get the following message "No device drivers were found ..."...
Installation & Setup


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 02:59.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App