Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Taken Ownership over drive with Win7

18 Jul 2011   #1

Windows 7 Ultimate 64 bit SP1
Taken Ownership over drive with Win7

Hi, i have 2 copies installed on different partitions, I usually use this (32 bit) version (not because it is better lol.) and a few days ago I was trying to save a word file trough the software to the HD, but i got the error 'a required privilege is not held by the client' message.
I downloaded and installed the Take Ownership right-click menu item from this site, and I used it on the partition with no success (it did what it said, but the software were still unable to save to the drive)
A day later I wanted to fire up my other windows 7 (64 bit), but right after I have highlighted and pressed enter in the boot menu, it restarted itself, so it could load nothing of the OS.
Questions are:
1. Can i get back that copy to life? Shall i change the owner again?
2. The error 'a required privilege is not held by the client' is still a problem.

Any help would b greatly appreciated

My System SpecsSystem Spec
18 Jul 2011   #2


Did you set up a Administrative-level account when you installed the second Win7, and did you install correctly from the booted installer and not by running the installer from the other Win7? You will know this because the drive letter of the second-installed Win7 will not be C when you are booted into it.

Unless you don't trust yourself, I would run an Administrative-level account with UAC turned on - or try running the Program in question as Adminstrator by right-clicking on it's .exe.
My System SpecsSystem Spec
18 Jul 2011   #3

Windows 7 x64 Ultimate

Well, if you ran the change owner on the root of another drive with another copy of windows on it it's pretty well toast. You can probably boot off the install disk and do a repair install, it may reset the permissions. There isn't a single permission for the entire OS, there are dozens and they are set on individual files and folders all differently so you won;t be able to just hand set them back to a single user using take ownership.

As for getting that error when saving a file, where are you saving it? The root of the drive? Or in a windows folder or something? Try creating a temp folder on the other drive like D:\Temp then save it there.

Unless you cloned your user account, your user on the 32bit windows can't write to the user folder on the 64 bit one, windows will by default think you are two different users and block you from writing to most any windows folder on the other drive. Make a new folder and use that as a common folder between the two windows. Set it's permissions so that "EVERYONE" has full access to it.

Take ownership only transfers the permissions from an old user to your own, it doesn't allow multi user access to a single folder. But you can set that yourself in the permissions for the folder. If you need a step by step for that, let me know.
My System SpecsSystem Spec

19 Jul 2011   #4

Windows 7 Ultimate 64 bit SP1

I have given up the second system and installed a new one on the same drive where it was, so now the problematic system is in the windows.old folder, which i will delete later..
Yes, I have an admin account and in the past I could save any files from apps to the root directly.
All in all I have 4 partitions (3+1) and which I have never installed OS on (1 of them) is still able to accept files and save them to the root.
(from my main system) I have C: D: E: and G:, C,D,E are on a single disk and G is a data disk
I am using os on C and D, and I have had one on G in the past, which I have deleted by now, but i am still unable to save directly on it (I dont mind the other 3).
On G: everyone has full access, and the owner is 'Administrators' just like on E:, which I can use with no problems.
My System SpecsSystem Spec
23 Jul 2011   #5


Please post back a screenshot of your full DIsk Mgmt drive map with listings, using the Snipping Tool in Start Menu.

Are you booting the WIn7 DVD to install, following these steps? Clean Install Windows 7

Since you have a separate data HD, would you consider wiping the HD (of possible boot sector corruption) to clean reinstall from booted DVD following the steps above? This would give you a clean baseline.
SSD - HDD Optimize for Windows Reinstallation

In addition to the illustrated steps in the tutorial there are tips here which will help you to get a perfect reinstall based on hundreds done here: Reinstalling Windows 7

Unplug all other HD's and peripherals during wipe and reinstall.
My System SpecsSystem Spec
23 Jul 2011   #6

Windows 7 Ultimate 64 bit SP1

Good ideas thanks,BTW im only interested in the 'a required privilege is not held by the client' problem.
My System SpecsSystem Spec
23 Jul 2011   #7


I've never seen this arise on an install where the quasi-Admin account which is offered during install is set up, and then no further tweaking to the OS or permissions is done.

This is why I suggested getting a baseline wiped clean reinstall.

Save an image shortly after it's setup and running great in case you accidentally get tweaky.
My System SpecsSystem Spec
25 Jul 2011   #8

Windows 7 x64 Ultimate

If you are not logging in as an account that is on the computer that you are trying to save to, then enable the "Guest" account on that machine and give it permission to write to that folder.

This is where domains come into play. So you have a single account that can log into any machine and you can assign permissions to network accounts rather than just the local machine accounts.

Something you may play with is the ability to transfer accounts from one machine to the next. I.e. put your main account (With it's unique user ID) on all machines, then you can traverse your network with impunity I've not personally done this, but I have transferred my account from an old to a new machine. Best way to keep all your file permissions in tact and not have to use the take ownership on the new machine.
My System SpecsSystem Spec

 Taken Ownership over drive with Win7

Thread Tools

Similar help and support threads
Thread Forum
Cannot Take Ownership or Delete Certain Registry Keys Win7 64
I have several monitors and one of them had had a corrupted digital EDID. I have succesfully re-written the EDID to the monitors eprom however windows still will not store this corrected key. It continues to use the original VGA keys or corrupted digital keys. The monitor is a Viewsonic and the...
General Discussion
Ownership of C Drive (System Drive)
Hello everyone. I had some problems with my C drive a few days ago. Scanning the disk revealed multiple bad sectors, and the laptop took a full night to fix itself (it literally scanned the whole night long again and again until the bad sectors were no more). Anyway, it came right in the end,...
General Discussion
I DID take ownership of the Win7 Drive, yesterday. Now?
I DID take ownership of the Win7 Drive, yesterday, after re-installing Win7 Ultimate. What sturm un drang should I expect for doing so? Haven't noticed any difficulties yet. I tried to give myself more permissions for c:\windows but got too many access denied so I removed myself from the...
General Discussion
Took Ownership of the C: (Windows 7) drive
I have a folder which has no owner and allows no access. Attempting to do any security related operation causes a denial of access, of that folder (a problem in itself). So, I thought changing ownership of the c: drive would help. With the hope that some recursive operation would allow me to...
General Discussion
Changing Ownership of failing drive
I pulled my failing hard drive (win7) out of my old computer and installed it in my brand new HP desktop (win7 home 64). I can see all of my data on the old drive but can't access it. I am trying to take ownership including subcontainers and objects and it is taking FOREVER. It's been running for...
Backup and Restore
After reinstall of pro, my D drive lost ownership?
I just reinstalled and it seems my D drive that has all my data, and i use for my docs. Has lost ownership i guess. First noticed because FF wouldnt download to it, to my downloads folder. Next tried to extract something and it wouldnt work. I can delete but have to hit continue, on the...
Installation & Setup

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 23:39.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App