Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: You don't currently have permission to access this fold

08 Jun 2011   #51

Windows 7 Ultimate x64

Yea I know this thread is old, but I got to say thank you!

This just helped me when changing permissions from a HDD configured in Windows XP Professional to work on Windows 7 Ultimate. Thank you so much!

My System SpecsSystem Spec
15 Jul 2012   #52

win7 Ultimate 32bit
Found Solution to this problem

I was having the similar security issue as well and went thru step by step as I read this thread. I did a fresh Win7 install and was not able to access my Music folder like I could before. With no solution found, I went back to the help files from Windows 7 and found step by step on how to take ownership of a file or folder. I search under "Take Ownership of a File or Folder" I listed step by step similar to how it was discussed earlier in this thread. This steps worked for me in my current setup.

When I right clicked on properties and security tab, then advanced and made my username (setup as admin) i told Win7 that i was now the new owner, it did not work. So i thought, why restrict this folder to just me. So, i clicked on Onwer tab, then click edit, then other users or groups and typed "EVERYONE" so after i applied it, it worked.

By doing this it removed the previous owner from the old system that Win7 did not recognize. Here are the steps from windows:

The owner of the object controls how permissions are set on the object and to whom permissions are granted.
The Take Ownership permission on an object or the Restore files and directories user right are the minimum requirements to complete this procedure. Review the details in "Additional considerations" in this topic.

To take ownership of a file or folder
Open Windows Explorer, and then locate the file or folder you want to take ownership of.
Right-click the file or folder, click Properties, and then click the Security tab.
Click Advanced, and then click the Owner tab.
Click Edit, and then do one of the following:
To change the owner to a user or group that is not listed, click Other users and groups and, in Enter the object name to select (examples), type the name of the user or group, and then click OK.

To change the owner to a user or group that is listed, in the Change owner to box, click the new owner.

(Optional) To change the owner of all subcontainers and objects within the tree, select the Replace owner on subcontainers and objects check box.
Additional considerations
An administrator can take ownership of any file on the computer.

Assigning ownership of a file or a folder might require you to elevate your permissions by using User Access Control.

To open Windows Explorer, click Start, point to All Programs, click Accessories, and then click Windows Explorer.

You can transfer ownership in two ways:

The current owner can grant the Take Ownership permission to others, allowing those users to take ownership at any time. A user granted the Take Ownership permission can take ownership of the object or assign ownership to any group that the user is a member of.

A user who has the Restore files and directories privilege can double-click Other users and groups and choose any user or group to assign ownership to.

The Everyone group no longer includes the Anonymous Logon group.
My System SpecsSystem Spec
18 May 2014   #53

windows 7 64

I kn ow its been a while sice anyone post on this thread , but bless you making a new folder worked for me
My System SpecsSystem Spec

06 Aug 2014   #54

windiw 7 64
Problem on my folder

Hi Squon,

i have a same problem here. my problem is on flight simulator being lock and not able to see the file. when i try to on my flight sim and because this particular airport in this file is being lock and not able to fly on this airport. so the file is been lock.

here i let u see the sc shot.

i hope you can help me with step by step.


Attached Thumbnails
You don't currently have permission to access this fold-1.3.jpg   You don't currently have permission to access this fold-untitled.png  
Attached Images
You don't currently have permission to access this fold-1.1.jpg You don't currently have permission to access this fold-1.2.jpg You don't currently have permission to access this fold-1.4.jpg 
My System SpecsSystem Spec
17 May 2018   #55

Win7 professional 64
You don't currently have permission to access this folder

I also had this problem on Windows 10 and the suggestion to create a new folder on the drive and then CUT and PASTE the contents of the folder with the permissions problem into the newly created folder worked for me.

My System SpecsSystem Spec
13 Feb 2019   #56

Windows 7 Ultimate x64

The process mentioned here can be quite tedious if you have multiple folders and subfolders to apply these security settings to.

To make the process easier I have developed a PowerShell script which uses the takeown and icacls commands to automate this for you, find out more and download my script from
My System SpecsSystem Spec

 You don't currently have permission to access this fold

Thread Tools

Similar help and support threads
Thread Forum
You don't currently have permission to access this folder
Hello Everyone, because I didn't want people to access my files and I needed to leave my PC turned on in the office, I went to my drive E properties, then security tab then edit and switched my controls from Full control "Allow" to "Deny" locked with a password. I checked it wasn't opening. There...
General Discussion
You don't currently have permission to access this folder
Hi, Im having trouble accessing an external hard drive. It says this when i try to access C:\Users i can view the rest of the hard drive though. When i go to change ownership it goes through the files and gets stuck on one particular file 3/4 times now and wont get past the one folder. Any...
General Discussion
appropriate permission to access
In the attempt to run the setup of a program I get this: “Windows cannot access the specified device, path, or file. You may not have the appropriate permission to access the item.” I am the administrator. Usually, by right clicking the mouse, and selecting run as administrator, this...
Installation & Setup
Windows can't access file. May not have permission to access.
Hello, I am attempting to access an application.exe file on my desktop. Each time that I click on it the Windows message, "Windows cannot access the specified device, path, or file. You may not have the appropriate permissions to access the item." pops up. I am the system administrator so this...
General Discussion
Can't access printer/ no permission
I have tried to follow the steps to take ownership of the printer but when I right click on properties the only tabs are 'General' and 'Hardware'-- no 'Security' tab. So, I can't follow the rest of the steps. How do I find the printer through Windows Explorer? I am the only user on my computer...
Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 01:02.
Twitter Facebook