Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: USB installation of Win7 fails to create boot sector

18 Sep 2011   #1

Win7 (7100)
USB installation of Win7 fails to create boot sector

Long story short, I ran the Win8 (64bit) dev install on top of my Win7 (64bit). I thought it would prompt me where to install it (I have 2HDDs in my laptop and no ODD).

All was well, but I didn't really like the UI. No big deal, right? Just re-run the Win7 install and wipe out 8... Wroooong!

I used a linux pen drive boot-iso making program (grub bootloader), gave it the Win7SP1 64 bit ISO and went off on my merry way. The installer is running, just as expected. I delete the existing partitions on the OS drive and it finishes the install with no problem... until it goes to reboot the first time. It just sits at a black screen with the blinking cursor. First thing I do is power down, take out the usb stick and boot back up... same thing.

So I go and download a new iso, thinking the first one may have been bad (despite having used it half a dozen times already). Same issue. Install completes, system reboots and nothing.

I download the MS version of the Win7/USB boot key installer maker thingy. Format the usb stick and let it copy over the iso again. Installed win7 without issue. Reboot. Black screen w/ blinking cursor.


I ran the installation repair. Windows finds the installation and says... oh, nothing to repair! *bangs head on desk* Ok, so let's try all of these fancy bootsect and diskpart commands. 30 minutes of repairing, deleting, repartitioning, full formatting, reinstalling... same issue installing to both HDs.

Now, the laptop I have is a Dell XPS15 (L502X). There's only one USB2 port and Windows can't install from USB3 ports (no native driver). I'm screwed.

I take out the primary HD and swap it with another HD. Go through all of this crap over again and it has the same issue.

I can't actually remove the second HD (ODD bay with an HD caddy) because the f'ing screw was in there SO tight from the factory and the screw is way too soft... so it's pretty stripped. I mean, it's smooth as a baby's bottom in there by now.

I run up to Fry's thinking there might be some issue installing from USB as I couldn't even get a linux distro to install from the damn thing. It was doing the *exact* same thing as the Windows install, with a few minor differences. The bootloader would almost act like it was going to work, but then it would just say "file not found" and die.

I get to Fry's and they have some cheapo Memorex usb2 DVDRAM drives on sale for 30$. Great! I take it to the counter and it rings up 60$. WTF? So we go back there and I show the guy the whole rack of them and the sign. The descriptions match perfeclty but the guy says the sku numbers are different. How exactly is that my fault? You don't sticker your products and we have to rely on these signs everywhere and you won't honor the price, even with these other 7 drives all right here?? Ok, so Fry's isn't getting any more business. I head to Microcenter and they have Toshiba equivalents on sale or 25$... I pick one up and home I go...

I get home and take the drive apart to find it only has a USB-Y connector for power. The USB ports on my laptop are not at all close together to begin with and the usb2 connector is on the opposite side from the other two. *sigh* I go dig through my closet and find an ancient usb1 hub... good enough for power, yippee!

I burned the original Win7 iso to a disc... lo and behold, it freaking works! It was kinda slow to install off the external dvd drive... but yaaay I have a working laptop again!

Now that your eyes are bleeding, you can share some of my pain.

What I really want to know is... why would the Windows installer not create a proper boot sector? I couldn't do the bdc repair because there had been no initial boot. I tried copying over the bootmgr file and other system files from the dvd to the c: drive and that didn't work either. Neither did installing to the second HD in the system. I wasn't quite sure that would work anyway because Dell's BIOS is hardcoded to call the second connection an ODD, regardless of what is connected.

Also, anybody have any ideas for something I could use to cut a slit into a stripped laptop screw so I can use a flathead to back it out? I already tried binding epoxy to a throw-away screwdriver, thinking I could glue them together and then use that to back it out.

I was looking at some dremels, but I haven't been able to find a cutting blade small enough to cut the screw and not split the laptop in half. This is the first laptop I've ever had with such soft, crappy screws and such a freaking retarded placement for the only screw that holds the ODD in place.

My System SpecsSystem Spec
18 Sep 2011   #2
Darryl Licht

Windows 7 Ultimate 64 bit Steve Ballmer Signature Edition

Try to delete all partitions with the win7 install usb on the drive before you try installing Win7 again!
My System SpecsSystem Spec
18 Sep 2011   #3

Win7 (7100)

I had done that about 10 times hehe... I was wiping everything out and I had a second memory stick that I was using for the knoppix attempt
My System SpecsSystem Spec

18 Sep 2011   #4
Darryl Licht

Windows 7 Ultimate 64 bit Steve Ballmer Signature Edition

Quote   Quote: Originally Posted by phazed View Post
I had done that about 10 times hehe... I was wiping everything out and I had a second memory stick that I was using for the knoppix attempt
So, trying the same with knoppix didnt do it either? Try GParted...GParted -- About
My System SpecsSystem Spec
18 Sep 2011   #5

Win7 (7100)

Yep, 3-4 times maybe from the smaller 2GB thumb drive (the one with Windows was 16)... made sure to apply the settings before closing it out and rebooting... nothing at all would write properly to that dang bootsector.
My System SpecsSystem Spec
19 Sep 2011   #6

Microsoft Community Contributor Award Recipient


Do a full clean & full format in command prompt.
1) Boot DVD & Press Shift+F10 (for command prompt)
DISKPART : At PC Startup
2) Boot DVD, & Command Prompt at Startup
(for command prompt)

Type in command line

USB installation of Win7 fails to create boot sector-list-disk.png

SSD / HDD : Optimize for Windows Reinstallation

Dual Boot Windows 7 and Windows 8 - Delete Windows 8 Developer Preview

My System SpecsSystem Spec
19 Sep 2011   #7

Win7 (7100)

Yep, did that stuff too... I really spent 2 full days on this. The fact that it worked absolutely perfectly from an actual CD is kinda the catch here... I didn't go and re-do all of the partitioning procedures before attempting it, either... it just worked. That is what is so baffling...
My System SpecsSystem Spec
19 Sep 2011   #8


Did you use this tool to write the ISO to stick? Universal USB Installer – Easy as 1 2 3

Have linked it hundreds of times here without a single complaint so far.

The other method which always works and can lift the ISO from DVD at the same time is Ultra ISO trial version: on File tab Open ISO or DVD, on Bootable tab Write Disk Image, Format, Write. Done.

Follow the steps in the Perfect Reinstall link in my signature picture below to get the best possible install.
My System SpecsSystem Spec
19 Sep 2011   #9

Win7 (7100)

I used YUMI (which is also on and the MS provided usb tools.
My System SpecsSystem Spec
19 Sep 2011   #10


What happens when you try the others?
My System SpecsSystem Spec

 USB installation of Win7 fails to create boot sector

Thread Tools

Similar help and support threads
Thread Forum
hp envy 6 1020sv fails win7 installation
hi I can't install win7 ultimate 64 bit on this laptop, the dvd is original and working good...after le last boot of installation procedure appears the follow message: windows could not complete the installation. To install windows of this computer restart the installation. any idea? thanks in...
Installation & Setup
create or repair boot sector on an already installed windows disk
Hello, This is my problem - I added a SSD to my computer. - Windows 7 Home was installed at my C-drive (harddisk) - I succesfully installed Windows Home at my new A-drive (SSD) - When I startup I can choose between two Windows 7 installation The first is the new installation, the second...
Hardware & Devices
Error 9C59 : Installation of IE10 fails on Win7 Pro x64
Hi, installation of IE10 on Win7 pro x64 always fails with error code 9C59. "Help on this error" shows error code: "WindowsUpdate_00009C59" "WindowsUpdate_dt000" I have IE9 installed. What I tried by now: Installation of IE10 using Windows update.
Windows Updates & Activation
HELP How to create HP Win7 Home Premium installation or Boot Disc??
Hi all, Roughly almost 2 months ago I purchased this HP laptop (HP Pavilion g7 Notebook) for my wife. It comes with Windows 7 Home Premium (pre-installed) on the laptop, but there is no disc. I need to know how to create or make a "bootable or installation" disc of this Win 7 Home Premium...
Installation & Setup
No boot sector on internal hard drive while AHCI enabled installation
hi everybody! I have a dell studio 1536 my hard disk got corrupted a month ago and tried different software could not make it to work so, decided to buy another HD . my new hard drive is (used) bought in ebay and SMART shows 100% health also tested on dell diagnosetic utility and all tests passed...
Installation & Setup
Create Win7 installation on new disc and remove old Win7 install
Scenario is I have a new sata3 SSD drive on which I want to install Win7. The PC has an existing build of Win7 on a different disc which i want to reformat & use for data. I tried this previously and ended up with a dual booting system. Trying to remove the old Win7 installation and format that...
General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 16:49.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App