Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: W7 installer doesn't detect SATA after Linux, Linux works smoothly

24 Sep 2011   #1

Windows 7 64 Bit
W7 installer doesn't detect SATA after Linux, Linux works smoothly

My config is HP G6 1075 SA with W7 Home Premium 64 bit pre-installed. It was working well until last week when I decided to install Debian Linux. I am no N00B to Linux and have installed it probably 100s of times. Debian installed and booted well but Windows BSODed with an error 0x0000225 cannot access drive. I formatted C and attempted to reinstall Windows 7 but it is unable to detect the HDD. I accept terms of license and move on to the point of choosing disks but nothing shows up. (There is an option to choose drivers. Where do I locate them? The HP website isn't helpful and I can't even find my product let aside the drivers)

I have already tried :
1. Partitioning an NTFS file system in Debian. Doesnt show.
2. Deleting a partition in Debian and attempt to see the free space in W7 Installer. Didn't work.
3. Try to do the BIOS setting thing (Change SATA option from AHCI to compatible or something). I could find no such setting in BIOS. The BIOS was severely limited with only option of switching on fan.

What do I do ?
The chipset is Intel HM55 if that helps and harddrive is SATA 5400 rpm 500GB.

My System SpecsSystem Spec
25 Sep 2011   #2

Microsoft Community Contributor Award Recipient


All Linux code must be deleted using the CLEAN ALL command.As you have had linux on the HD you need do a Clean all & full format.

Do a full clean & full format in command prompt.
1) Boot DVD & Press Shift+F10 (for command prompt)
DISKPART : At PC Startup
2) Boot DVD, & Command Prompt at Startup
(for command prompt)

Type in command line

W7 installer doesn't detect SATA after Linux, Linux works smoothly-list-disk.png

SSD / HDD : Optimize for Windows Reinstallation

My System SpecsSystem Spec
30 May 2012   #3


I have a similar problem, so I'd rather continue here than open a new thread.

I have two hard drives, one SSD and one SATA. Win was working fine with its NTFS partitions on both drives. After installing Debian, it still works fine except that it doesn't see the partition on SATA. It does see D: drive but no partitions on it and says that it is all corrupted.

Where is the problem exactly? XP always worked along other operating systems.
My System SpecsSystem Spec

30 May 2012   #4
Microsoft MVP


If you have separate HD's its best to unplug one while installing to the other, then after install set preferred HD to boot first, boot other HD using one-time BIOS Boot Menu key given on first boot screen.

If you used GRUB boot manager it may have corrupted Win7 beyond repair as we see often here.

Try unplugging Debian HD, make sure Win7 HD is set first to boot, Mark Win7 Partition Active , then run Startup Repair - Run 3 Separate Times to see if Win7 can be started.

If not then boot into System Recovery Options Command Line to run bootrec /fixmbr, bootrec /fixboot, and bootrec /rebuildbcd hitting Enter after each.

If Win7 starts, plug back in Debian to boot only using BIOS Boot Menu key at boot.
My System SpecsSystem Spec
31 May 2012   #5


Thanks for the answer.
No, both systems are on the same drive, the other is meant to be "storage".
I think I'll skip the Windows all together. It's not worth the trouble.

Thanks again.
My System SpecsSystem Spec
31 May 2012   #6
Microsoft MVP


John - If both OS's are on SSD, then check that Win7 has a drive letter assigned to the storage partition in Disk Mgmt.

If you'll post back a screenshot of your maximized Disk Mgmt drive map and listings, we can look it over for you.
My System SpecsSystem Spec

 W7 installer doesn't detect SATA after Linux, Linux works smoothly

Thread Tools

Similar help and support threads
Thread Forum
win 7 does not open a fat32 partition that works in linux
I have an hdd where I put only data, I have several partitions (all FAT32) One partition works in linux but not in windows In ubuntu I can open the partition and see the videos in it In windows 7 the partition has no name (only local disk) and i can't open it Thank you I apologize for my...
Hardware & Devices
Dual Boot Windows 7 Linux: Partitioning with Linux disk tools problem
Goal: Dual boot Windows 7 and Linux and have an NTFS partition for both OS. Problem: When creating Logical Partitions with any Linux partition tool(Gparted, cfdisk) the Linux swap and ext 4 partitions shows up on Windows 7 as primary partitions outside of the Extended partition while the NTFS...
Performance & Maintenance
It just works: Dell XPS 13 Developer Edition Linux Ultrabook review
It just works: Dell XPS 13 Developer Edition Linux Ultrabook review | Ars Technica
Universal Linux USB Installer
I just found this really cool tool: Universal USB Installer – Easy as 1 2 3 | USB Pen Drive Linux It is a small exe file that will download and install just about any Linux distro that you have or want. ~Lordbob
Chillout Room
New memory works great in memtest/linux, crashes windows 7
Hello, I have Windows 7 Professional 64bit. I got a new stick of 4GB DDR3 1333 memory. Whether I use it by itself or with another stick, the computer blue screens with random errors instantly when trying to boot Windows 7. A 2GB stick of the same speed from the same manufacturer works great in...
BSOD Help and Support

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 15:24.
Twitter Facebook