Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Windows 7 Pro Installs Fine on 32bit but Fails on 64Bit

28 Sep 2011   #1

OSX 10.7. Windows 7 Ultimate x64
Windows 7 Pro Installs Fine on 32bit but Fails on 64Bit

Im trying to install Windows 7 Pro on a HP DC7800 Convertible Minitower with a Q9300 Core 2 Quad and 4GB RAM. It has two 1TB Hard Disks Configured as RAID 1 and I cannot for the life of me get Windows 7 64bit to Install, I thought id give the 32bit version a shot, installed fine without an issue but as the install is nearing completion on 64bit am given the "Windows Setup could not configure Windows to Run on this computers hardware.

Its slightly confudling me a bit, any help would be appreciated. Cheers Guys

My System SpecsSystem Spec
28 Sep 2011   #2

Windows 7 Ultimate SP1 64-Bit

Please upload a screenshot of your expanded disk management layout to enable us to advise you further.

Screenshots and Files - Upload and Post in Seven Forums
My System SpecsSystem Spec
28 Sep 2011   #3

OSX 10.7. Windows 7 Ultimate x64

Id have to reinstall 32bit and send the screenshot if you think that it would help?. Its literally, Remote the RAID Array, Recreate it, shows as normal. Put 64bit disk in and start the installer. Installer asks where to install I hit new, and then apply it makes all the drives as it normally does, hit next. Installer goes fine, restarts and gets to Completing Installation and then chucks the error message up. Its only on 64bit that this happens.
My System SpecsSystem Spec

28 Sep 2011   #4
Layback Bear

Windows 7 Pro. 64/SP-1

Have you run this? Windows 7 Upgrade Advisor - Download - Microsoft Windows
Windows 7 Upgrade Advisor - Download - Microsoft Windows
Are you trying to install 32 and 64 on same drive/partition?
Do you have a product key for both systems?
My System SpecsSystem Spec
28 Sep 2011   #5

Windows 7 Ultimate 64Bit

This is so like you can lead a horse to water but can't make it drink.

32bit works but not 64? Not like you have an under spec machine lol.
My System SpecsSystem Spec
28 Sep 2011   #6

OSX 10.7. Windows 7 Ultimate x64

No Every time ive tried installing on this machine I delete all the partitions and reformat. We have Volume License Keys so thats not a problem the upgrade advisor gives it the all go. I know windows 7 64bit used to run fine on this machine but it was formatted when the old IT manager left and we now have another Tech coming in but this is one of those silly things driving me up the wall :P
My System SpecsSystem Spec
28 Sep 2011   #7

Windows 7 x64 pro/ Windows 7 x86 Pro/ XP SP3 x86

Try updating the bios or loading default bios settings or toggling IDE/AHCI settings for the hard disk or install after removing anything you don't need like usb peripherals.

BTW, is this a readymade disk or a homemade one?
My System SpecsSystem Spec
28 Sep 2011   #8

OSX 10.7. Windows 7 Ultimate x64

I'll give it a go now, these are burnt to disc downloaded straight from Microsoft VLSC burnt using 2x Speed. Ive tried burning on different types of discs and using other machines still no luck.

Can't really toggle the IDE/AHCI settings as its going to be using RAID

Will Give it a go as standalone without the RAID configured though.

My System SpecsSystem Spec
28 Sep 2011   #9

OSX 10.7. Windows 7 Ultimate x64

Ok, that worked. Without RAID i managed to get it to install and work. So I cloned it to an external drive, nuked the Hard Drive and re-created the RAID array. Cloned the disc back and it just worked Odd but thanks for the help!!!
My System SpecsSystem Spec
28 Sep 2011   #10


Why RAID? Win7 doesn't much care for it.
My System SpecsSystem Spec

 Windows 7 Pro Installs Fine on 32bit but Fails on 64Bit

Thread Tools

Similar help and support threads
Thread Forum
Windows fails to restart itself but manual shut down works fine
So for the past couple of days windows has done this. It happened after re installing my wifi card witch has been giving me problems. After reinstalling it and restarting windows fails to boot. It freezes when it says "starting windows" but when I manually shut the computer down and start it...
General Discussion
IE9 32bit context menu fails on W7 Pro 64bit
Forgive me if this has been answered before - I searched a lot before posting. The context menu in question is shown in the attached file named "context menu.JPG". That image was taken from IE9 64bit on the same W7 Pro 64bit computer. I originally thought that I had a bad profile or that I...
Browsers & Mail
BSOD on 64Bit while 32Bit runs fine
Hello, (Sorry for my bad english) I really need help on this one. 3-4 Month's ago a friend of mine made me an custom build computer. now from the beginning the computer looked fine to me after a couple of hours playing games it started acting wierd shows programs suddenly stopped...
BSOD Help and Support
Cant install 64bit but 32bit works fine
Hello, i am a newbie to this forum, so if i leave any relevant info out apologies in advance. I have recently built a new htpc (i listed all specs) all the hardware i purchased was brand new. i had win xp and tried to upgrade to win 7 64bit but kept getting blue screened, so then i tried win 7...
Installation & Setup
Installs fine, reboots and hangs
Okay so I bought the W7 Pro Upgrade 64bit using the Student download via Digitalriver.. I downloaded it on Windows 7 RC2 32bit and I followed the steps that was posted in the error thread to make an ISO file and I booted the disc and installed 64bit. Everything runs fine except when I get to the...
Installation & Setup
installs fine, runs fine, reboots..not fine
hey guys so i finally decided to install win7 x86 - everything went well - put all the standard stuff on there etc - i rebooted many times because of installations and updates on my last reboot it just got stock in the bios screen (verifying dmi pool data..success! etc) so i rebooted, same...
Installation & Setup

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 12:33.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App