Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: In-place upgrade windows 7 64 bit ultimate sp1

11 Oct 2011   #11

Windows 7 Ultimate 32 bit

It is working here...

Look carefully.. rapidshare interface changed.

Anyway mirror link: One click file hosting:

My System SpecsSystem Spec
11 Oct 2011   #12
Microsoft MVP


It's failing to restore the registry files, possibly because they are too corrupt.

You should proceed with a clean reinstall which is a vastly superior install that will get you beyond the corruption which has built up: Reinstalling Windows 7

As a last resort you can try to replace your registry files with the backup as given here: Startup Repair Infinite Loop Recovery. You may be able to do it from the desktop since you are not locked out. However be aware this is experimental and not a sure thing at all.
My System SpecsSystem Spec
11 Oct 2011   #13

Windows 7 Ultimate 32 bit

Hello Greg,

I will try the method you posted. But since you say it's the registry, couldn't you tell me where the error occurs? Maybe I can fix it myself by changing or deleting the value/keys.

Yes clean install fixes the OS, but like I said my main priority is containing my games.. I can always make a dualboot with a clean version but here is my result of clean install:

So I made a clean install windows 7 64 bit ultimate sp1

+ I installed some extra stuff like
UE3Redist (unreal redistributable)
Vcredist x86 (Visual ++ 2005 redist)
Vcredist x86 (Visual ++ 2008 redist)
Vcredist x86 (Visual ++ 2008 sp1 redist)
Vcredist x86 (Visual ++ 2010 redist)
Games for windows live redist
Microsoft XNA framework redist 3.1
MSXML 4.0 SP parser
Netframework 1.1 + sp1
Netframework 4.0 Client+ extended
Latest Java
Visual Basic 6 SP6 Runtime library (vb6 dlls)
Windows Media Encoder 9 32bit edition
Direct x 9.0 c june 2010 redist
Not sure if I got all requirment software, these were all I could think of.

I have started every game to see if they boot, and from the 200 these 9 give trouble, but to my suprise the other 191 would boot.. (and another 9 needed reg fixes which I made myself, mostly needing directing to the game installation folder.)

Can I sort of assume with a decent certainty that if the games boot that they are OK to play like this?

I mean most games just make new config registry if they see it's not there, though there seem to be some games which require deeper registry. It's probably not like halfway through the game it will error out on me right?
However these games give trouble:
Age of empires online
Black and white CreatureIsle
Halo 2
The Witcher
command and conquer generals zero hour
Combat arms EU
Prince of Persia Warrior Within
Prince of Persia The Sands of Time
My System SpecsSystem Spec

11 Oct 2011   #14

Windows 7 Ultimate 32 bit

I have tried what you said and put back the regback folder,
I get a bluescreen with BAD_SYSTEM_CONFIG_INFO
STOP 0x00000074

And last known config didn't work either..


I think the regback files were renewed since my last recovery, so I looked into my image file and took the regback folder from there and replaced it on the current system.

It seems it worked. straight boot loads the correct CONTROLSET again, and no user login screen! (i had trouble with it eventhough I did everthing the guide said I should do for this)

It seems this is a registry file from BEFORE i pressed the sysprep button. Not sure if it's going to help my upgrade but im going to try again!
My System SpecsSystem Spec
11 Oct 2011   #15
Microsoft MVP


Keep us posted.

Those games seem to have made a lot of tweaks to the registry which are likely causing the logjam. You can see the actual Reg Keys which are failing to copy in the failure log you posted.

You have any old System Images? Have you tried reimaging to check performance?

You can always install the 9 games which balk on your reinstall, and any others that suffer from running uninstalled. After playing them all over time you can eventually move the Program files to the new install partition and delete the old install. Post up a screenshot of your Disk Mgmt so we can see if the System boot files need moving first.
My System SpecsSystem Spec
11 Oct 2011   #16

Windows 7 Ultimate 32 bit

Which "attempt" did you look at? Which log exactly, since there are mutiple logfiles, and they are quite long...
Because I want to know which keys are keep f king me over.

I just tried again after restoring the regback folder, and got blue screen 0x0000007E (0xFFFFF etc etc long code..

Hmm i was just thinking I do have one older image with less about 100 games on it(I accidently deleted a drive with 100 games there; so won't keep my hopes too high) , maybe I can look at the regback folder in there to see if it's of an earlier date, I'll keep you posted.

Yes I can re-install those 9 games again, that is not such a big deal when talking about a Master-Image.

I would gladly do that, but the facts nags me that im not sure if those other 191 games will keep working without crashes eventhough they boot fine like normal, without their registry counterparts.(eventhough alot is autocreated)

Like I wouldn't want to find out that i have created an image which is even more troublesome where lets say a quarter of the games keep crashing infrequently.. this is not so easy to test with 200 games as they could occur from 5 min to an hour if it would contain errors. Though my experience generally is that they don't need the game registry. The only game that gave me trouble in my history was c&c generals were buildings would explode if you run it without really installing it.

I go to sleep now.. I try tommorow again. Thanks for your help again.
My System SpecsSystem Spec
11 Oct 2011   #17
Microsoft MVP


setup.err only logs the failures

The key failures are the last ones logged, although much of the end of the log is rollback logging.
My System SpecsSystem Spec
12 Oct 2011   #18

Windows 7 Ultimate 32 bit


I deleted some BTHport registry (though not all as it seemed to many to do manually)
I deleted users\acronisaccount
Ran cleanup utility for Acronis
Moved out the t/m files mentioned to my dekstop which were mentioned in the errors.

disabled/removed Remote Differential Compression

Which should be done according to this link

He talks about 2 other components that should be removed from windows features but they weren't on my list at all.

Almost there!

New problems arise:

Each time I reboot it says netframework 4.0 is repairing. I tried to manually repair but it failed and gave errors.

My coretemp program isn't working anymore, I updated it, but it also crashes on startup.

Games for windows live crash on start..

Other then that.. Security issue seems to be ok so far?? =)

Thanks for your help on upgrading appreciate it, don't know if you can do anything with my new problems?
My System SpecsSystem Spec
12 Oct 2011   #19
Microsoft MVP


I'd uninstall Net framework 4., Windows Live and Coretemp before upgrading then reinstall them afterwards.
My System SpecsSystem Spec
12 Oct 2011   #20

Windows 7 Ultimate 32 bit

Hmm good one I keep that in mind!

Currently got Coretemp running again by messing around with re-installing some visual/net frame packages.

Now looking at games for windows live which said a required windows component is disabled on your machine. (but no info on which..)

Your idea is a good one.. though i'd have to do the image and upgrade AGAIN lol.. but i'll do that if I can't seem to get it working like this.
My System SpecsSystem Spec

 In-place upgrade windows 7 64 bit ultimate sp1

Thread Tools

Similar help and support threads
Thread Forum
cannot do an in-place upgrade on my. Windows seven PC
Hey friends, I have been trying to do an in-place upgrade on my PC because of continual windows explorer crashes, however, when the installer tries to check for compatibility, I get a message that the install cannot continue due to Lenovo ADP composite device. I think it was installed when I...
Installation & Setup
Windows 7 in-place upgrade install fails
I discovered that my previously working scheduled back-up was no longer working and could not be reset. The task scheduler was reporting errors. I tried restoring to an earlier version but no luck. I run system file checker to discover several file problems that were not fixed by the system. So I...
Installation & Setup
Icon problem after Windows 7 in-place upgrade
Ever after having done an in-place upgrade of my Windows 7 x64 installation, I've been having some strange icon issues... This does not impact all of my icons, but it impacted some of my desktop short cuts and some of the items in the Start menu. These aren't too difficult to fix either by...
General Discussion
Windows 7 Anytime Upgrade with non-upgrade Ultimate license?
I'm about to buy a new laptop from Costco with Win 7 Home Premium. On my old (now smashed) laptop I have a Win 7 Ultimate install. Can I just use the Ultimate serial key to do the Anytime Upgrade on the new machine? I keep reading that I need to buy an "upgrade key." Thanks
Installation & Setup
Upgrade from Vista to Windows 7 with iTunes in place?
Running Vista HP 64. DL'd the Windows 7 upgrade for Vista 64. The problem is that the instillation wants me to uninstall iTunes because of compatability problems. I have the lastest version of iTunes running on my laptop's W7 HP 64-bit without a problem. I really don't want to uninstall iTunes...
Installation & Setup

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 14:26.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App