Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Windows 7 installation: Missing operating system after using imagex.

11 Oct 2011   #1

Windows 7
Windows 7 installation: Missing operating system after using imagex.

Hello all,

First of, I like to introduce myself as I am new on this forum.

I'm an IT proffesional, currently going learning for my Configuring Windows 7.

I used windows 7 since the first beta came out, and I must say, I never was dissapointed by it.
But because I am learning I am trying to get all the computers here running windows 7, and I have a computer in my office wich I am trying to install it on.

There are a few problems thoug:

The computer only has a CDrom player, and cannot boot from a usb device.
When I first got it, windows XP was installed, and it only had 750 mb of memory. Stupid as I was, I decided to give it a try anyway installing windows 7 from inside Windows XP using an external DVD player connected with USB.

This failed, and gave me lots of error so I tried the next step.

As It cannot find a network share I had to instal windows PE on a CDrom and from there I could acces my extrernal HDD where I had a clean copy of windows 7 on as INSTALL.wim. I cleaned everything, and created everything from scratch with succes. Image X worked, and BCDboot worked. So it seemed to go great.

After restarting my system, it still will only give me, Missing operating system.

I tried to search on the internet but couldn't really find something related to my problem.

In the bios it says I can start from IDE CD-rom device, Diskette drive, Hard-Disk Drive c:, Integrated NIC (Disabled)

I bought some different memory and I am now at 1.5 mb DDR
It is an Intel Pentium 4 processor 2.4 Ghz Level Cachge 512 Integrated.

It's a DELL Optiplex Gx260 Series.

The boot menu gives me:
1. Normal
2. Hard-Disk Drive C: (Wich I used for my 100mb) (And I used D for my big partition and with BCDboot I used D:\Windows\System32\bcdboot d:\windows /s D: ) Wich worked because he did copy the files.
3. IDE CD-rom Device
4. System Setup
5. IDE Drive Diagnostics
6. Boot to Utility Partition

Whatever I choose, I can either go to the WindowsPE cd-rom or get the error.

I hope someone can help me out a bit. As I put much time in to this.

Sorry for my language but I am Dutch lol

Many Thx!

My System SpecsSystem Spec
11 Oct 2011   #2
Microsoft MVP


First try writing the ISO to flash stick using this tool with Win7 in the dropdown: Universal USB Installer – Easy as 1 2 3 then boot it under USB, Removable or HD's - however it shows up once it's bootable and plugged in and you access the BIOS setup Boot Menu or one-time BIOS Boot Selection menu.

If it truly can't boot USB (very rare) then boot the Win7 Repair CD, mark SysREserved partition Active if it isn't already: Partition - Mark as Active (Method Two)

Then run Startup Repair - Run 3 Separate Times to correctly write the System boot files to the SysReserved (preferred) partition.

If this fails, change the Active flag to Win7 partition itself, try repairs again to see if it will start on its own.

You can also mark Active and see a picture of which is currently System Drive using free Partition Wizard bootable CD - the most valuable tool we use here to help thousands of users. After marking Active, click on the HD to highlight it, then from Disk tab select Rebuild MBR which may preclude the need to run Startup Repair.
My System SpecsSystem Spec
21 Oct 2011   #3

Windows 7

Thank you for your help! I bought a USB flashdisk, but that didn't work. Then I made a repair disk and from there I ran the dos prompt after starting it on the computer.

From there I ran diskpart, did select volume and gave the active command. Then I booted my pc and it worked!! So for some reason it didn't work using the WINPE cd, but it did work with the repair disk!

Thank you very much!!
My System SpecsSystem Spec

21 Oct 2011   #4
Microsoft MVP


Are you saying it couldn't boot the USB stick? Saying "it didn't work" rather than telling us exactly what did or didn't happen doesn't allow us to help you get it right.

Were you able to find the stick to select it to boot under USB, Removable or HD's using the one-time BIOS boot menu key, or in BIOS setup under Boot order? If so did it prompt to "Press any key?"
My System SpecsSystem Spec

 Windows 7 installation: Missing operating system after using imagex.

Thread Tools

Similar help and support threads
Thread Forum
Missing Operating System 'Windows 7 Boot USB'
Hi guys, So normally I'm quite good at this stuff but this ones got my stumped. So I created a Windows 7 Bootable USB on Ubuntu using 'YUMI' The USB was formatted to NTFS and ISO loaded on using Yumi. I am able to see all the files on there on the Ubuntu Explorer however when trying to boot...
Installation & Setup
Missing Operating System Windows 7/Blinking cursor
At first the computer would not load Windows, it would stay frozen on the black screen with a blinking cursor/underscore. Then I burned a "recovery disc" to access the system restore/start up repair but to no avail either. The start up repair shows no errors. System restore fails to replace...
General Discussion
Missing Operating System - Booting from installation disc doesn't work
Hiya, Firstly I should say that I am primarily a mac user, and it is not my laptop I am posting about. Although I am reasonably knowledgable about Windows, I haven't used it since XP, about four years ago, and so am pretty rusty. Basically, my girlfriends computer randomly turned off about...
Installation & Setup
Missing operating system windows 7
Well I decided to build a computer because it was on my bucket list. I probably got a little deeper than my talent. Someone at the store said I could get some more performance using an SSD for the operationg system. I put the computer together and everything booted the first time. Imagine that. So...
BSOD Help and Support
Missing Operating System Windows 7
I am getting the "Missing Operating System" message on boot. Here is the strange thing...if I change the boot order in the BIOS and have CDROM first and choose not to boot off of it Windows 7 loads fine. If I put HARDDISK first then I get the missing operating system message. I have tried running...
Installation & Setup

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 05:34.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App