Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: USB Installation of Win7 Ultimate x64

29 Oct 2011   #1

Windows 7 Ultimate x64
USB Installation of Win7 Ultimate x64

Hello all, I'm new here. Found this forum via google, of all places ;)

I'm having a serious problem. I'll start with the specs first, and then get to the problem though.

Seagate 500GB HDD
Gigabyte M68MT-S2P mobo w/ BIOS Award Modular BIOS v6.00PG
USB installation of Windows 7 Ultimate x64

And now, the problem... the installation starts, and I get to the "Where do you want to install Windows?" screen, I choose my drive, which is "Disk 0 Partition 1", which displays Total Size 465.8 Free Space 465.8 Type Primary, but Windows 7 installer says: "Setup was unable to create a new system partition or locate an existing system partition. See the Setup log files for more information."

Now, as you can see from what I said the issue it, it loads into the installation just fine. I've used a 32bit version of this and installed Win7 on several netbooks with the same issue, and in all cases, removing the USB at this point and re-inserting it was what fixed it.

The things that I have tried already are:
1. Removing the USB so that the only drive in is the HDD, but then I get the "Windows is unable to install to the selected location. Error: 0x80300001.
a. A google search, and human logic, tell me that this is because the USB drive is no longer present, so I re-insert, and choose the drive again, and get the same original error in the issue above.

2. I have installed ubuntu on the hard drive from a USB, which of course, installed fine, and ran fine. I've again reformatted the drive, since the installer was saying it was not NTFS when it had Ubuntu on it.

3. I've changed the boot order in the BIOS to various different setups, including HDD first & USB devices second; USB devices first and HDD second. The BIOS lists the USB flash drive under Hard Drives, of which I've set it to #2, and also tried it as #1.

4. I've even tried installing Win7 from another PC and would try to move the drive to the new PC if it had worked, but this gave me the same error(and this likely wouldn't have worked, anyway).

I'm at my wits end here! I don't have a DVDrom, and it's been a couple of years since I've needed one. I've ordered one from newegg, but it won't be here for a couple of days, so any help would be appreciated.

The only thing that I can say that I know that I haven't tried is another USB flash drive, but the one I'm using is the same one I used on the above mentioned netbooks, and I don't have another USB flash drive that's large enough to try to use.

Please help me if you can! and thank you in advance for even reading this, I honestly appreciate someone even looking at this.

:edit: Also, thought I should mention, the ONLY things connected right now are the HDD, the USB flash drive, a USB mouse & USB keyboard.:end edit:

My System SpecsSystem Spec
29 Oct 2011   #2
Prof Kerfuffle

Windows 7 Professional (x64/SP1) /Linux Mint 16

I am just going to try a guess. Try with another usb memory stick. Installing off memory sticks can be problematic.

How do you create do the boot files for you memory stick? Manually or with software (wintoflash)
Did you format it as fat32 or NTFS?

*Sorry if these have been listed but its quite hard to find key info*
My System SpecsSystem Spec
29 Oct 2011   #3

Windows 7 Ultimate x64

Quote   Quote: Originally Posted by Prof Kerfuffle View Post
How do you create do the boot files for you memory stick? Manually or with software (wintoflash)
Did you format it as fat32 or NTFS?
First of all, thank you for the swift reply, Prof. I used the "Windows 7 USB DVD Download Tool" from MS to create the USB, which starts off by formatting the media(as NTFS I believe).

I've also tried with several different programs to make the USB boot device with the same results. I will try your suggestion and try another USB flash drive, since that's the one thing I haven't tried yet.

Since posting the original problem, I've also been reading a lot more various different posts about what the issue likely is, that being, any other drive that's on the system can cause this issue, which sucks if you're trying to install from said drive. If only I could make the flash drive read-only :|
My System SpecsSystem Spec

29 Oct 2011   #4

Windows 8.1 Pro RTM x64

The problem is that you already have a partition which encompasses the full capacity of the drive. The system partition, which you are getting the error message about, is a separate partition to the main OS partition. Since the existing partition is filling the drive, there is no room for this partition to be created.

To overcome this, you need to delete the partition (you should always allow the OS to automatically create the required partitions and format them when installing the OS).

Firstly, check your BIOS boot order. The HDD should be listed first, and you should use the one-time boot method (usually by pressing F12, but check your user manual) to boot into the USB install flash drive. Since you have already managed to install Ubuntu with this method it eliminates possible hardware issues, and I shall assume that you know how to do this part. It is important that the USB drive is not set as the default boot device, as this will lead to endless boot looping.

Now start your computer, and boot up from the USB flash drive. Follow the instructions here (they refer to a conventional DVD install, but are exactly the same for a USB-based one) Clean Install Windows 7 up to Step 8. With reference to the information in the Tip box, select the partition and then click Delete to remove it. Now restart your computer and again boot up from the USB flash drive. You should now be able to install as normal, and the required partitions should be created automatically for you.
My System SpecsSystem Spec
29 Oct 2011   #5

Windows 7 Ultimate x64

Thanks for the reply, Dwarf. I will try as you said after I get the other USB with the files setup.

Question though: Shouldn't the Win7 installer do that for me if I deleted the partition and clicked 'Next'? or do I have to reboot after deleting the partition?
My System SpecsSystem Spec
29 Oct 2011   #6

Windows 8.1 Pro RTM x64

It should work either way, it's just my personal preference to reboot at this stage.
My System SpecsSystem Spec
29 Oct 2011   #7

Windows 7 Ultimate x64

Tried both suggestions, same problem with the new flash drive, and also same problem with steps 1-8 from the link Dwarf posted.

One thing I did notice before I "Deleted from Drive options(advanced)" and rebooted was the "Type: System", but it encompassed the entire drive.

It is my understanding that I shouldn't have to create the system & primary partition manually; the installer should do all of that for me.

So, same error with "Type: System" on the full drive, as well as same error with "Type: {blank}" on the full drive.

Going to reboot again.

No change, still same issue.

One thing that I just noticed, since I deleted the partition (Type: {blank}), and try to view drives via "Load Driver" & "Browse", is that my USB flash drive shows as "Removable Disk (C: )". I'm going to try to split the drive into 2 equal sized partitions, and make 1 the Primary and leave the other half blank.

Formatting the drive from diskpart now

  • shift+f10–>diskpart[Enter]
    list disk (USB flash drive showing as disk 1 )
    sel disk 0
    create par primary
    sel par 1
    format fs=ntfs
Going to reboot again when it is complete and try again.
My System SpecsSystem Spec
29 Oct 2011   #8
Prof Kerfuffle

Windows 7 Professional (x64/SP1) /Linux Mint 16

I had issues with wintoflash and other software. Try doing it manually

How To Boot And Install Windows 7 From USB Flash Drive

That is how I got it to work.
It may work for you.
My System SpecsSystem Spec
29 Oct 2011   #9
Microsoft MVP


An easier method to write the ISO to flash stick which always works is using Universal USB Installer with Win7 in dropdown menu. Confirm the ISO first or download another.

The other most likely prob is code in boot sector needs cleaning with Diskpart Clean command as you're doing.

Unplug all other HD's and peripherals.

Keep us posted.
My System SpecsSystem Spec
29 Oct 2011   #10

Windows 7 Ultimate x64

After doing the diskpart bit that I mentioned above and rebooting, I still have the same error. Disk 0 Partition 1 is the only thing showing, has "Total Size = 465.8 GB", "Free Space = 465.7", "Type = System".

I'll try using the Universal USB Installer next, taking a short break. I don't really think its how I'm making the flash drive thats the problem, unless maybe i need to make it fat32 for some reason(I'm making it ntfs when I manually do it, unsure completely what the MS program formats it as though).
My System SpecsSystem Spec

 USB Installation of Win7 Ultimate x64

Thread Tools

Similar help and support threads
Thread Forum
New Win7 Ultimate installation on a new (Tiny) SSD, how2optimize?
Hey guys, Got my 120GB SSD (First time), Win 7 ultimate is now installed, up and running! What are the things I can/should do to save up/optimize space? I know 120 isn't alot but that's what I could afford right now. So far I've disabled/deleted the hibernate file (I never use hibernate on...
Performance & Maintenance
Itunes installation errors on Win7 Ultimate.
Hi, when I tried to install Itunes, I get these 2 error messages, are these related to Registry or is purely an Itunes issue? Thanks for your time. Jack
New Win7 x64 Ultimate Installation Issues
So, I'm building a new computer and have had nothing but issues since last night's Win7 x64 Ultimate installation. Numerous BSOD's, boot failures, etc. I've restored several times to earlier points, but can't seem to really pin down where the issue is arising. I've also seen the computer...
BSOD Help and Support
Re-installing Win7 Ultimate x64, but freezes on installation.
Had a virus that caused me to have to reinstall win7, so I made room on my C partition and booted from my win7 CD. All was fine until it came to the final stage "Completing installation"; at which point it froze. For over an hour. Eventually, I decided to reboot my computer as it was clear...
Installation & Setup
Singularity Installation Error @ Win7 Ultimate x86
everytime i try to install the game "Singularity" i get this error: i attached my Services if anyone wanna see if there is something wrong here, no matter if Windows Installer is Running or not i get the error...

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 19:23.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App