Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: UEFI Booting of GPT partition doesn't work after 2nd HDD was added

10 Nov 2011   #1

Windows 7 Professional 64bit
UEFI Booting of GPT partition doesn't work after 2nd HDD was added

Good day,

I have an Asus Z68 mainboard with UEFI-BIOS. Windows 7 Professional 64bit is installed in UEFI mode on a GPT partitioned drive (SSD). It worked flawlessly.

Now I added my second, old harddrive, that is still MBR formatted.
Windows won't start anymore, instead I am seeing "Windows is loading files", then a blinking cursor, and that's all.

I have two options in BIOS regarding boot priority:
1) I can boot from the SSD as primary priority
2) I can select an option called "Windows Boot loader", I think this refers to the UEFI boot code that Windows wrote to the UEFI.

If I select the first option, I get the "Windows is loading files screen" and then the "Windows has detected a startup error, do you want to repair the system startup" screen. If I select "Start Windows normally", I get a blinking cursor and then nothing. If I select "Repair startup", I see "Windows is loading files", and then again the "Startup repair screen". It is an endless loop.

If I select the second option, I get "Windows is loading files", then a blinking cursor, and nothing more.

Is there any way to get my Windows to boot again without disconnecting or re-partitioning the old harddrive?

Note that the old harddrive is NOT for booting, as it is just a datastore.


My System SpecsSystem Spec
10 Nov 2011   #2

Windows Home Premium x64


Have you checked that the BIOS is not trying to RAID your 2 devices, your should find that in Integrated Peripherals (or something similar) in the BIOS
My System SpecsSystem Spec
11 Nov 2011   #3

Microsoft Community Contributor Award Recipient


Make sure the Hd Drive is showing in BIOS, also the boot order of the drives.
My System SpecsSystem Spec


 UEFI Booting of GPT partition doesn't work after 2nd HDD was added

Thread Tools

Similar help and support threads
Thread Forum
Help, I deleted partition needed for booting? Added a new drive
I put in a new sata drive, went to disk management. I made a mistake and deleted a small partition from the first drive that apparently windows needed to boot? I have an install disk, what can I run to fix it? fixmbr? something else?
General Discussion
lan doesn't work after booting via usb multiboot
Hi it's not an hardware issue i have all my hardware drivers updated well i created with yumi an usbstick bootable with active boot disk 7.5.2 (i bought) terabyte image for linux (i bought) terabyte BootIt Bare Metal (too) Parted Magic an iso full for great utility
Network & Sharing
Wireless Internet Doesn't Work When Booting Up Computer
Okay, so here's the deal. Whenever I connect to my wireless internet, be it when booting up the computer or changing to it via the modem cables, it refuses to work. The only way it works is if I click on the network computer in the bottom right corner and then troubleshoot for a couple mins, until...
Network & Sharing
BSOD While Booting, Safe mode doesn't work, new build
Hello everyone, I just built a desktop with brand new hardware, all except the hard drive, which is taken from my old system. The hard drive has the OS from my old system (which was working fine) plus all of the data. Now, the hardware on the system seem to be working fine, but it goes to...
BSOD Help and Support
Dual booting XP and Windows 7 doesn't work after using XP
I have 3 drives, C:, D:, and E:. E: is just a storage drive. XP was originally installed on the D: drive. I installed Win7 on the C: drive following the instructions at After installing Win7, I didn't get an option...
Installation & Setup

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 22:36.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App