Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Error's (0x8007045D and 0x80070002) while installing Win7 Ult 64bit

14 Nov 2011   #1

Windows 7 64bit
Error's (0x8007045D and 0x80070002) while installing Win7 Ult 64bit

Hello, and first of all I'm not sure if this is the correct section to post this but... I've recently decided to reinstall win7 64bit because my computer started freezing up occasionally while browsing, playing games or even watching youtube videos... the freezes would pass after a few minutes and the computer would recover and start up/shut down would take a long time as well. So I thought that reinstalling windows might help as I havent done it in a long while. But I ecountered a problem while installing win7 64bit, I receive these errors (0x8007045D and later after trying a few things it changed to 0x80070002 both times it stated something about files missing or being corrupt) while on the "extracting windows files" section of the setup. I've done a clean install every single time and formated my HDD (seagate barracuda 7200.10 320GB) but got an error every single time but at various %'s (once it went up to 70% other times it would get stuck as soon as 5%). I'm really out of ideas now, I've tried switching RAM's, switching DVD Drives, Disconnecting my GPU but nothing seems to help... has my HDD died? Or prehaps my Mobo or CPU is acting up? Help please!

Oh, and I burned my win7 ISO's myself via imgburn - I've used the slowest possible burn speed (x2) and did it multiple times but every single DVD gave same error. Also I've tried multiple ISO's and downloaded them multiple times as well to confirm they didnt get corrupted while downloading.

My Specs:

OS: Formated HDD right now but previously I used Win7 64bit
Motherboard: Intel Bearlake G31 (I think, not sure... its such an old mobo)
CPU: Intel Core 2 Duo 3.3GHz
GPU: GeForce 9600GT - Tried removing but didnt help
RAM: OCZ 2x2GB 800MHz DDR2 - Tried switcing to an exact same pair from another computer but it didnt help
HDD: Seagate Barracuda 7200.10 320GB
DVD-ROM: Not sure but I tried two different ones, both producing errors

My System SpecsSystem Spec
14 Nov 2011   #2
Microsoft MVP


Where did you get Win7? Did you burn the ISO to DVD yourself? If so, confirm ISO or download another, burn to DVD using ImgBurn at 4x speed.

Next try writing ISO flash stick using Universal USB Installer with Win7 in the dropdown menu.

Test your HD using Seagate SeaTools extended CD scan, which can also wipe the HD afterwards before trying install again.

Next try install after removing all but 2gb of RAM. Then swap RAM sticks. TEst your RAM: RAM - Test with Memtest86+ CD for 5-6 passes or overnight.

Unplug all other HD's and peripherals. REset BIOS to optimal defaults in BIOS Setup. Report back all results.
My System SpecsSystem Spec
15 Nov 2011   #3

Windows 7 64bit

Hello, thanks to you all for replies. I've just tried running seagate DOS bootable disc and I got an error while trying to run the "long test" on the system thats having problems installing. The error said that the HDD was not responding to commands and that it could be caused by corrupt sectors OR disconnected/broken wires. So I decided to plug the HDD into my other system to run the test there and what do you know, the test is running right now at 15% and going further... I'll post the resulsts once its complete. But I guess my problem is faulty wires hmm?
Oh, and regarding the RAM, I've tried other RAM sticks from the other system and I got the same error so I'm asuming the RAM is ok, but I'll also run memtest later to make sure.
My System SpecsSystem Spec

15 Nov 2011   #4

Microsoft Community Contributor Award Recipient


Try replacing the Power & data cables.
My System SpecsSystem Spec
15 Nov 2011   #5
Microsoft MVP


Make sure you have the exact RAM specs for that hardware. They are not interchangeable between mobos if that is what you were saying you did.

You didn't answer my questions or reply to all steps yet. The installer is suspect until it is verified/re-burned if necessary, or cross-checked by trying install from USB stick.
My System SpecsSystem Spec

 Error's (0x8007045D and 0x80070002) while installing Win7 Ult 64bit

Thread Tools

Similar help and support threads
Thread Forum
installing win7 error 0x8007045D
hello there , i will try to explain it fast so pls read all thread before advising. well the title tells the story. when installing i get this error 0x8007045D and i believe its due to me power off while installing windows (win7 wiki tells that) i tried searching through the forum but none of them...
Installation & Setup
Error code 0x8007045D when re-installing Windows 7
Hi, I'm trying to fix my brother's Dell Inspiron N5030 because he couldn't get windows to boot after running startup repair several times. So I made a WIN 7 bootable USB using Wintoflash, booted the usb, and ran the startup repair utility 2-3 times with no luck. Then I tried to re-install...
Installation & Setup
0x8007045D error when re-installing windows 7.
Hello guys, I have a Dell inspiron 15r special edition and lately I've been getting problems. My laptop today decided to crash today and encounter an infinite start up repair loop. I've decided to use the dell DataSafe restore and emergency backup to format and re-install the OS but I keep...
General Discussion
Installing Windows 7 error 0x8007045D
Hi there, Yesterday I got the last part (1TB HDD) for my computer and installed windows 7 without any problems. Throughout the day it worked perfectly but today there came an windows update. It shut down all my programs and went into the configuration of the update and then all of a sudden I got...
Installation & Setup
ERROR 0X8007045D while installing win7
Hi, yesterday I had a major crashdown on my Win7, I tried startup repair and custom install, but it was useless Today I decided to format the disk and make a clean install of Windows. Boot from DVD and try to install ... when goes to 10 - 20% give me this error: 0x8007045D Telling me...
Installation & Setup

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 01:38.
Twitter Facebook Google+