Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: can't recover the MBR after starting factory restore and erasing linux

03 Dec 2011   #1

Windows 7 Starter 32bit
can't recover the MBR after starting factory restore and erasing linux

Hello there

I have a net book accer with Windows 7 starter which I bought in Italy while I was there.
Since I'm not a windows user, I instaled ubuntu on it but kept windows because this netbook isn't stay with me.

So once I came back I start the recovery proccess. But, surprisingly for me, the recovery didn't rewrote the MBR and now I'm unable to continue it.

Since it is a netbook, it doesn't had a opctical drive neither I had any instalation disk.
I've tried to recovery it with a pen drive with recover console for win xp, to no results.
fixmbr and fixboot didn't work. It say the proccess was successful but at the restart the grub recover continue to show.

So, I'm without option but to try and put a Lilo just to make it boot to windows, but I don't want such 'by-pass' solution.

Any clues?

My System SpecsSystem Spec
03 Dec 2011   #2

Microsoft Community Contributor Award Recipient


information   Information
We always assume you have made your Recovery Disks using the OEM manufacturer's Recovery Media Creator app the first day you had your new PC.
& made the Startup Repair CD.
startup repair disc-create

Did you make the OEM manufacturer's Recovery Disks?

can't recover the MBR after starting factory restore and erasing linux-capture-usb.png

My System SpecsSystem Spec
03 Dec 2011   #3

Windows 7 Starter 32bit

Nops, never did any recovery disk. Besides, the only media I had was a 1gb pen drive I used to install linux later. So even if I had it would be erased.
My System SpecsSystem Spec

03 Dec 2011   #4

Microsoft Community Contributor Award Recipient


All Linux code must be deleted using the CLEAN ALL command.As you have had linux on the HD you need do a Clean all & full format.

Type in command line
SSD / HDD : Optimize for Windows Reinstallation
My System SpecsSystem Spec
03 Dec 2011   #5
Microsoft MVP


First try tapping F8 key at boot to see if you have System Recovery Options on the Advanced Boot Options menu. If so boot into Command Prompt to mark Win7 partition Active using Diskpart: Partition - Mark as Active (Method Two)

Next run Startup Repair repeatedly up to 3 separate times to write the System Boot files to Win7.

If no Repair console on F8 menu, you'll need to find a Win7 Repair CD ISO to try writing to flash stick using WinToFlash, order your Acer Recovery Disks from Tech Support with help to write to flash stick, or locate Win7 starter version ISO to write to 4gb flash stick to use for Repairs or possible reinstall using Universal USB Installer .

Before booting Recovery or Installation stick to reinstall, use Theog's link to wipe the HD of GRUB corruption as this may block all repair attempts anyway.
My System SpecsSystem Spec
05 Dec 2011   #6

Windows 7 Starter 32bit

After contacting (without any good) Acer support I finally managed to solve the problem, using RescaTux (here if anyone would need it in the future Rescatux - Super Grub Disk) plus TestDisk (sudo apt-get update && sudo apt-get install testdisk).

But this problem was really awkward. I had a notebook with Windows Vista which once had dual boot with Ubuntu, when I did factory restore on it, it resized the partitions and rewrote the MBR) but with Windows 7 was different. It remove two logical partition, kept the extended and swap and did not rewrote the MBR.

Anyway, the problem was solved. So thank you everybody for your support.
My System SpecsSystem Spec

 can't recover the MBR after starting factory restore and erasing linux

Thread Tools

Similar help and support threads
Thread Forum
Factory restore over Linux
A friend of mine has a Sony Vaio laptop that he gave someone at his job to 'clean up' and he got it back with Linux Qimo for kids installed. I'm not asking why. :shock: At any rate, given that it's Linux, are there any special steps I need to take to do a factory restore from the DVD (ordered...
Installation & Setup
How can I Recover the 20gb that i allocated for ubuntu linux
Hello..I used to have a windows 7 os in my desktop..then i kept ubuntu linux in dual boot mode by providing 20gb space of E drive..BUt for few days i have problems with windows7 showing a black screen after logging I formatted my desktop with windows7cd..Now i have windows7 working well..But...
General Discussion
Help me recover a HDD after erasing the first sector.
HDD: ST30005 28AS. Failing. I have to recover some data and throw it away. With Seatools dos cd, I accidentally the first sector. I also set it at that time at 33 gb. Now I can't see any partitions in it. I tried everything in HIREN's boot cd. The drive was failing, 15 minutes at windows...
Hardware & Devices
recover windows 7 after installing linux
hi guys i'm just so mad because at my self i was stupid enough to install linux ubuntu on top of my windows 7 , i have a hp pavilion notebook dv-6 2155dx 4gb ram 500gb hdd it comes with windows 7 pre-instal , is there anyway how to get back to my wondows 7 i don't have the cds for this notebook ,...
Installation & Setup
Recover files from Linux based? NAS drive
Thanks for for your time, I couldn't find any post close in nature to this problem. I have a crashed Lacie network storage device, something in it's networking board is fried. It's comprised of 2 separate HDD's, both 500gig. I was afraid they were going to be stripped but it appears they hold...
General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 06:56.
Twitter Facebook Google+