Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: What's everyone doing "driver" wise on new RTM install?

10 Aug 2009   #11
zrtom

W8 Pro, W7 Ultimate, XP Pro x64, Vista x64, Ubuntu
 
 
W7 RTM won't install video driver like in prior builds

Here's an interesting one. Fresh install of Windows 7 RTM x64 from TechNet. For the first time since build 6519 (I think it was 6519) Windows 7 didn't install the nVidia drivers on my Dell M1330. Even after a couple reboots and checks with Windows Update, it continued to show in Device Manager as a Standard VGA display adapter instead of 8400M GS. Every prior build I've tried (over 20) installed the nVidia drivers.

Has anyone had a similar experience with the RTM not installing the video drivers on a laptop?
I'll probably post an inquiry in the Drivers forum.
Tom


My System SpecsSystem Spec
.
10 Aug 2009   #12
banderz777

Windows 7 Ultimate X64
 
 

I also use window drivers for my Laptop, it finds everyone after I install and do a update, I will let windows do it's thing.
My System SpecsSystem Spec
11 Aug 2009   #13
Vocalpoint

Windows 7 Professional SP1
 
 

Quote   Quote: Originally Posted by scottsmithtech View Post
I let windows do the initial install ran the updates which included a few drivers then after a reboot I installed the latest Intel Chipset drivers and Video driver from Nvidia.
I "used" to subscribe to that...especially the chipset part - until I discovered that the Intel chipset installer does absolutely nothing and is not required as Windows 7 RTM corectly installs and supports everything right up to the X58 chipset.

Same for the video driver - while this first build of Win 7 Pro is more of a "test" build while I gather new info (like the Intel Chipset item) when I do a final "go-forward" build in the coming weeks - I am going to stick with the 185.xx nVidia driver that Windows Update provides. I find the actual nVidia installers to be pointless given they install like PhysX and the Stereo3D junk that really doesn't need to be there on a "non gaming" rig.

Given that this first go-round was the fastest, most trouble free install I have ever had - I see no reason to mess with any third party driver installs - especially if everything is working and no one piece of hardware really "needs" any updates....

Cheers!

VP
My System SpecsSystem Spec
.

11 Aug 2009   #14
wallyinnc

Windows 7 x64 finally!
 
 

I only updated my Radeon drivers, but I don't think it would have been necessary. I tried to install a Linksys wireless PCI card and with Win7 drivers or Linksys drivers it never worked fine. I dumped it.
So, I agree with the majority, if it is working, don't fix it.
My System SpecsSystem Spec
11 Aug 2009   #15
blackroseMD1

Windows 10 Tech Preview 9926 x64
 
 

Win7 installed everything on mine. However, I still prefer to manually update things like the video drivers, sound drivers and chipset drivers.
My System SpecsSystem Spec
12 Aug 2009   #16
nealh

Win7 Ultimate RTM w/dual boot XP Pro
 
 

well I setup a dual boot with winxp last night.(I am using Win 7 x64 from Technet with legit key)
winxp is on my C: drive and win 7 x 64 on my D: drive

I have a few issues, the biggest seems to be the HDD on my Marvel sata controller(non-raid setup) are not seen.

I have a Intel Badaxe2. I assumed the chipset and storage drivers would install at default. All I see is the HDD on Intel sata ports.

Win 7 did install drivers but they seem to be on the C:.

Win7 works but after manually installing ATI drivers I can not access ATI CCC it just "loads" but nothing opens(I manual installed the drivers on the D: ). I did this because I could not access videocard settings to make any changes.
My System SpecsSystem Spec
13 Aug 2009   #17
Snufffed

 

Quote:
I have a few issues, the biggest seems to be the HDD on my Marvel sata controller(non-raid setup) are not seen
You have to add the drivers prior to installation of Win7, you do remember the popup that says " Drivers " simply add the sata drivers to a floppy-usb-cd- or which ever media you chose. I also have to add drivers for my "Promise IDE Card" which will allow 4 IDE HDDs.
My System SpecsSystem Spec
13 Aug 2009   #18
Zidane24

Windows 7 Home Premium x64 - Mac OS X 10.6.4 x64
 
 

Quote   Quote: Originally Posted by zrtom View Post
Here's an interesting one. Fresh install of Windows 7 RTM x64 from TechNet. For the first time since build 6519 (I think it was 6519) Windows 7 didn't install the nVidia drivers on my Dell M1330. Even after a couple reboots and checks with Windows Update, it continued to show in Device Manager as a Standard VGA display adapter instead of 8400M GS. Every prior build I've tried (over 20) installed the nVidia drivers.

Has anyone had a similar experience with the RTM not installing the video drivers on a laptop?
I'll probably post an inquiry in the Drivers forum.
Tom
Same here on the 8 series driver not installing...more nvidia on this one probably. Other than that all my devices install fine but I still get the drivers from thei vendors...just to make sure that I am not missing any manufacture benefit. Speaking of that I need to grab my wireless driver from intel
My System SpecsSystem Spec
13 Aug 2009   #19
nealh

Win7 Ultimate RTM w/dual boot XP Pro
 
 

Quote   Quote: Originally Posted by Snuffy View Post
You have to add the drivers prior to installation of Win7, you do remember the popup that says " Drivers " simply add the sata drivers to a floppy-usb-cd- or which ever media you chose. I also have to add drivers for my "Promise IDE Card" which will allow 4 IDE HDDs.
Well I did the install unattended and never saw the message...duh.

Fortunately after posting it dawned on me to check device manager and low and behold, i needed the drivers. I went to Intel site and added via device manager and all seems well now.

I had huge issues with my x1900 and get ATI drivers and catalyst installed. I had to delete the videocard and reboot and manual put in the drivers and then cataylst to get these options. The newest catalyst 9.7 does not seem to work with my hardware at least via manual install with the .inf file
My System SpecsSystem Spec
13 Aug 2009   #20
zrtom

W8 Pro, W7 Ultimate, XP Pro x64, Vista x64, Ubuntu
 
 

Quote   Quote: Originally Posted by Zidane24 View Post
Same here on the 8 series driver not installing...more nvidia on this one probably. Other than that all my devices install fine but I still get the drivers from thei vendors...just to make sure that I am not missing any manufacture benefit. Speaking of that I need to grab my wireless driver from intel
Chris,
That is a relief to hear. Not necessarily good news but a relief that it's not just me.
Thanks.
Tom
My System SpecsSystem Spec
Reply

 What's everyone doing "driver" wise on new RTM install?




Thread Tools




Similar help and support threads
Thread Forum
Driver Install Error "Computer doesn't meet requirements"
Hey guys, My dad recently bought a HP Windows 8 laptop but can't get used to the new OS. He asked me to install Windows 7 on it for him. I'm currently trying to get the drivers sorted for it and for the Windows drivers such as Chipset and Graphics, i'm getting the error "This computer does not...
Drivers
"A required CD/DVD device driver is missing" upon windows 7 install
I've been trying to install Windows 7 on my Asus Q501L (which came with W8 already installed) via USB. I faced a problem - while the laptop was able to start the initials steps (the black screen where it shows the copying process of the Windows 7 files), i couldn't go any further than the step at...
Installation & Setup
Yiynova tablet monitor "device driver failed to install"
I have a Yiynova tablet monitor and its been working fine for about a month. I recently tried to download the beta version of a NVIDIA GeForce update (bad idea) and had to reinstall a previous version. After that, things started to go south for my tablet. I uninstalled and reinstalled the tablet...
Drivers
Can't install display driver "configuration registry database corrupt"
Acer E1-571: Windows 8.1, 2.4 GHz Intel i3, 8 GB ram, Intel HD 4000 So I recently recovered my computer from corrupt display drivers by booting into safe mode and uninstalling the bad drivers. So Windows is working good as ever except the fact that I have no official drivers installed. So I...
Graphic Cards
"A required CD/DVD drive device driver is missing" during install
Tried everything and by everything, i do mean everything. spent close to a week frying my brains on this problem. after getting to the select language and input screen, it loads and then goes to a screen saying that the required CD/DVD driver is missing. tried different OS, windows 7 home, home...
Installation & Setup
"A required CD/DVD device driver is missing" during Win7 Install
Hello everyone, first post and thread! :) After many hours today looking for answers to this problem in many threads (and websites), I've finally decided to post to get some help from you guys! Any help would be greatly appreciated. I have just finished building a new desktop, here is the...
Installation & Setup


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 03:56.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App