Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Unable to launch old OS after installing a new one(dualboot)

27 Dec 2011   #21

Windows 7 Ultimate x64

Just before I write this post,I launched the WinRe 3 more times.The first attempt and second attempt showed the same results.But after the second attempt,it reported that Windows cannot fix this automatically,OS loader not found.After the three attempts and I again tried to get into it and the winload.exe issue is there.
Then I jumped into G,system32 and looked for winload.exe.There are two files there.winload.exe and winload1.exe. winload.exe is 578 KB in size and the other one 590.I don't know how this happened.Maybe I can fix that winload.exe corrupt issue by renaming the 590KB file as winload.exe?I tried to do it but it says I need permission from Administrator.So I launched command prompt and activated the Administrator account.But I still cant make changes to that file.Please tell me if you know any ways to do that.
Will be doing everything you just said shortly.I haven't done a backup yet.I think if things go wrong,I can still do a clean install of my new OS as I have nothing precious in that partition :). Is it possible to transfer bookmarks from Firefox by copying the profile?
Thanks for your continuous support.

My System SpecsSystem Spec
27 Dec 2011   #22
Microsoft MVP


You cannot fix the winload issue any better than Startup Repair can, as it has all fixes and tests included and will run System File Checker if it is required, is run enough times, and System is not irreparable.

You needed to do the backup before you started changing Active flags as stated repeatedly. However you can go in at any time with DVD Repair console or Repair CD to Copy & Paste - in Windows Recovery Console to external USB drive.

I don't know which Firefox file might hold your profile as I back up my Bookmarks, but you can ask Google.
My System SpecsSystem Spec
27 Dec 2011   #23

Windows 7 Ultimate x64

Update:I just reinstalled Windows(the latest one).And it now shows me three options.One of them is Windows7(Recovered).I launched it and startup repair was started and it said that I will need to be logged in as a local user to repair it.So I selected my username and entered the password.The repair process continued and a while later a new dialogue box appeared stating that Windows couldn't fix it automatically.The problem is still that OS loader thing. What do you think about the current situation.Still hopeless?
My System SpecsSystem Spec

27 Dec 2011   #24
Microsoft MVP


What happens when you try to boot into the other two choices on Menu? One is C and boots correctly? What happens with the other one?

Again install Easy BCD to C, on Edit OS menu delete each entry and then add G again. Save and reboot.
My System SpecsSystem Spec

 Unable to launch old OS after installing a new one(dualboot)

Thread Tools

Similar help and support threads
Thread Forum
Installing 64bit ubuntu in 32bit win 7 dualboot
Can i install 64bit ubuntu in 32bit win 7 dual boot?
General Discussion
Dualboot XP/7 - installing Win 8 in place of XP
Hello! Currently I'm using dualboot with Win XP and 7. (XP was installed first) XP is installed on partition C: and 7 on F:. I'd like to install Win 8 in place of Windows XP, keeping the 7, but deleting XP (dualboot 7/8). Can I just format C: and choose it in Win 8 installation GUI, or do I...
Installation & Setup
BSOD. Unable to launch normally.
Hi, I have been getting the BSOD 0x00000050. I run a windows 7 64 bit operating system. I'm not the greatest with computer bugs and would love to get some help. It has be doing this for awhile now every time i restart but this time I can't start even after trying repeatedly. I looked into it as...
BSOD Help and Support
dualboot with fed16 win7 error: unable to install on selected location
I have two disks: 1 = 250 GB, all linux partitions 2 = 250 GB, will be allocated to Windows 7 (NTFS partitions) I have Fedora16 installed on disk0 because I only used Fedora. But since I'm a PHP programmer who programs in DOT.NET at times too I need windows installed too. I tried to install...
Installation & Setup
Borderlands unable to launch
I have Borderlands for PC which I purchased NOT from Steam. It worked a couple months ago but I reformatted my PC and now it does not launch after installation. Installation works fine and I tried reinstalling it a few times but it still will not launch when I try to launch it. It just shows that...

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 20:36.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App