Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: One initial Install Restart, Windows gets stuck in a restart loop

08 Jan 2012   #11

Windows 7 Home premium 64bit


RAM test showed no errors. Same with the HDD

I think you guys are onto something with this being a BIOS issue. I tried following the steps given by theog, but was unable to finish step 2: UEIF interface install of Win 7. I tried setting the UEFI DVD as first and only option in boot list. With a freshly formatted and clean HDD, this resulted in the same reboot loop. However, When I set the DVD drive ot boot with PAVA, it was able to load Windows 7 setup normally. Since both of these options were listed in the boot list, I think that the UEFI boot failed, and what I actually installed was through the PAVA boot. Does anyone have any ideas as to how I can get around this?

The Link above for UEFI install of Windows explains copying the cdboot.efi file from the DVD to a USB drive. I've tried this and still was unable to boot from it...I may need some additional information on how to try this correctly.

After referencing the Fatality P67 Performance manual, it suggests loading the ATA serial drivers to a floppy disk and using that at the time of install for AHCI support. I can't find any floppy disks around town, and when I copy all the files from the MB Support CD, windows does not recongize any of the driver files as ones compatible with my hardware. I'm stuck. Would appreciate some advice on how to fix this apparently UEFI issue.

Lastly, I've also tried instant flashing the BIOS version to 2.0, I'm currently at 1.0, but when I load the file to a USB and connect to the instant flash tool, it gives me a "No image found" error. Is anyone aware of any special steps that I need to take in order to get the BIOS to recognize the image file (I see the USB drive on the boot list, so it appears that it's being recognized in the BIOS, just no image file)?

My System SpecsSystem Spec
08 Jan 2012   #12

Systems 1 and 2: Windows 7 Enterprise x64, Win 8 Developer

Quote   Quote: Originally Posted by jefusan View Post
I have tried installing Windows makes no difference . I will try updating the BIOS version to 1.3 (the highest I found on ACRock's website), and see if that makes any difference. Anyone else have any ideas? I'm pretty much tapped...

RE: Windows 7 disc, I purchased an OEM version from
I could be wrong, but I believe the latest bios version is 2.0, not 1.3. 1.3 is the oldest version.

Please check the following:

ASRock > Products > Motherboard > Fatal1ty P67 Professional > Download
My System SpecsSystem Spec
08 Jan 2012   #13

Windows 7 Home premium 64bit

Lemur, you are right, I found v. 2.0. However, I am unable to get the bios instant flash to recognize the downloaded file (unzipped) as an image. I get a "cannot find image" error.

I have tried creating a USB Windows 7 Installer. I get the same reboot loop when I try to boot form the USB drive. Any ideas as to how I can resolve this or the BIOS instant flash issues?
My System SpecsSystem Spec

08 Jan 2012   #14

Systems 1 and 2: Windows 7 Enterprise x64, Win 8 Developer

  1. Create a bootable system USB pen drive.
  2. Download an updated ASRock BIOS file (WinZip format with .zip file extension) from the web site, unzip the BIOS file and save all files to the drive you created in step 1.
  3. Boot from the disk you created in step 2.
  4. At the "A:\" prompt, type BIOSfile.exe, then press <Enter>. For example: A:\P55DX_1.60.exe <Enter> then you will see a message "Please wait for BIOS loading ROM".
  5. After 30 seconds, you will see the message "Program ended normally", then you have finished upgrading the BIOS.
  6. After finishing upgrading the BIOS, restart your system and press <F2> to enter the BIOS setup utility during boot up.
  7. In Exit menu, please select "Load Default Settings" and press <Enter> to continue.
  8. Select "Exit Saving Changes" and press <Enter> to exit the BIOS setup utility.
  9. Now, system is booting up with new BIOS."
My System SpecsSystem Spec
08 Jan 2012   #15

Windows 7 Home premium 64bit

Lemur, thanks for e help.

I have created a bootable USB ( reference steps MS-DOS Bootable Flash Drive - Create) and installed DOS version 2.0 on USB. When I execute in DOS, I get following: ffs checksums =ok, ROM file ROMID is not compatible with existing BIOS ROMID.

The steps I followed appear to use a windows 98 version of DOS, I am not sure if this is the problem or not, any thoughts?
My System SpecsSystem Spec
08 Jan 2012   #16

Windows 7 Home premium 64bit

I have resolved flashing bios helps if you use the appropriate MB files (T.T). Now that I've used performance file, which only has ver 1.3 currently, it updated normally. I am (finally) able to get into windows setup after flashing. Waiting to see if install completes without issue.
My System SpecsSystem Spec
08 Jan 2012   #17

Windows 7 Home premium 64bit

Thanks everyone for your help. It appears as though we've fixed the issue. I have installed Windows 7 Home Premium edition, and have not had a random reboot or boot loop occur since I updated the BIOS. Summarizing info and steps here:
My Specs:
MB: Fatallty P67 Performance
CPU: Intel core i5-2500k
RAM: 2, g.skill's rip jaws 8BG DDRS3-1333 (240 pin 1.5V)
Video: ATI Radeon HD 4850 512mb series
OS: Windows 7 Home Premium 64bit
PSU: 550 Watt AntecTrue Power
HDD: Western Digital SATA drive WD5000

1) Create a bootable USB Drive via MS-DOS Bootable Flash Drive - Create
2) Go to : ASRock > Products > Motherboard > Fatal1ty P67 Performance > Download to get the most up-to-date BIOS version. Install this on USB from step 1, BIOSFILENAME.exe <enter>.
3) Restart system, enter BIOS, and under EXIT section, select Restore Defaults. You may also make changes to your UEIF or SATA settings at this time for proper WIndows installation<optional>
4) Restart System so that WIndows install CD boots and runs Setup.

Thanks again for the help.
My System SpecsSystem Spec

 One initial Install Restart, Windows gets stuck in a restart loop

Thread Tools

Similar help and support threads
Thread Forum
Initial BSOD, now restart loop....
I'm not even sure where to start really. Initially I got a BSOD and my computer restarted but upon trying to startup right after the windows logo it restarts again. I can't load safe mode. I can however enter my bios and have tried repairing what I can from the windows 7 disk. I can browse all my...
General Discussion
Startup Repair- windows cannot repair; Stuck in restart loop
Hi, I am unable to start up my laptop (Windows 7 Home Premium). TOSHIBA Satellite C660-1J6 It is stuck in a loop of 'attempting to repair this computer', which is unsuccessful and restarts. There are no restore points to use. I have received the BSOD which disappears quickly during startup....
General Discussion
Windows Update Stuck in Restart Loop.
Hi Guys, Windows 7 Ultimate x64 has gotten stuck in a loop where it wants to restart and then when your restart it doesn't do anything update related, it just restarts. Can anyone help?! Ybotmallah.
Windows Updates & Activation
Windows Update error, stuck on restart loop.
Greetings Seven Forums crew, I am having an issue with the Windows 7 Update Service. After installing the latest Microsoft Updates (November 2013), I am now stuck in a "restart your computer to finish installing important updates" message. No matter how many times I restart & check for updates,...
Windows Updates & Activation
Stuck in Restart Loop
Hi All, So, my computer is stuck in a restart loop. every now and then I see a screen with option to start windows normally or safe mode, but it loops faster then I can hit enter. being a comp guy and knowing enough about comps, tried to load Windows 7 install disk as well as Ubuntu Live...
BSOD Help and Support

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 20:36.
Twitter Facebook Google+