Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: One initial Install Restart, Windows gets stuck in a restart loop

07 Jan 2012   #1

Windows 7 Home premium 64bit
One initial Install Restart, Windows gets stuck in a restart loop

Hi All,

I have read many, many other threads that address infinite reboot loops, but none of the solutions have resolved my issue. I am hoping the community might be able to help me identify this problem.

I have just recently replaced my CPU and MB with the items listed below. After installing hardware, I ran KillDisk on the HDD, which will zero out the entire drive. The computer boots normally and will load into windows installation without issue. However, once Windows reboots to start windows for the first time, it is unable to do so. The load windows logo screen will load, and approximately right before Windows would normally load my screen goes black, the system turns off, sits off for about 1-2 seconds, and then turns itself back on and repeats this boot process. It turns off and restarts at the same time every time.

Steps I have done so far in an attempt to resolve the issue but failed with no change in the rebooting behavior:

1) removed all non-essential hardware (CPU, 1 stick of RAM, DVD drive, and Video card were the only things left), and tried reinstalling windows.

2) Swapping out one of the 2 RAM sticks I have to make sure it wasn't defective.

3) Trying to install Windows on a new harddrive to rule out that the HDD was defective.

4) trying to boot from the CD (After the initial install had partially finished) to see if HDD was related in anyway.

5) Installed a very simple DVI video card to see if ATI card may be the cause.

6) Resetting CMOS and reinstalling

7) Setting SATA control to AHCI instead of IDE and reinstalling.

Some additional thoughts. It doesn't not appear to be an overheat issue either, as I have looked at the temps through the BIOS tool and all levels (CPU, PSU etc.) looked normal. Secondly, I get an error when I try to load Safe Mode, stating that it cannot be loaded for the initial Windows load. I am in the process of wiping the drive again and trying to reinstall windows XP to see if it is a uniquely windows 7 issue or not. This, however, is my last idea. Does anyone else have an idea as to what may be causing this reboot loop, given all the steps I have taken? Or, more importantly, a way to fix it :)? Your help is appreciated.



MB: Fatallty P67 Performance
CPU: Intel core i5-2500k
RAM: 2, g.skill's rip jaws 8BG DDRS3-1333 (240 pin 1.5V)
Video: ATI Radeon HD 4850 512mb series
OS: Windows 7 Home Premium 64bit
PSU: 550 Watt AntecTrue Power
HDD: Western Digital SATA drive WD5000

My System SpecsSystem Spec
07 Jan 2012   #2

Systems 1 and 2: Windows 7 Enterprise x64, Win 8 Developer

Sorry you are having these problems. You have already done the most logical things. If it's not the memory, or the video card, or the hard drive, and the only things you have changed are the cpu and mobo, then you might wonder if there is a problem with one of the two. You could always boot a live CD of Ubuntu to see how your computer responds. Or XP installation sounds like a great idea for a test.
My System SpecsSystem Spec
07 Jan 2012   #3

Windows 7 Home premium 64bit

Hi Lemur,

Thanks for the quick reply. Clearly, the CPU and MB could be suspect, since they are new and I don't have a separate CPU or separate MB to test with. That said, given that I am able to progress as far as I am with the install (it expands and installs all of the files in the setup screen without issue as far as I can tell), would that rule out both of these parts?

I'm interested to hear your and others' thoughts about this, and possible other issues that might be the cause.

My System SpecsSystem Spec

07 Jan 2012   #4

Systems 1 and 2: Windows 7 Enterprise x64, Win 8 Developer

Is your bios version 2.0? Might not hurt to update.
Please let me know what the resolution is. I'm a little concerned as I'm ready to order the ASRock 970 EXTREME4
My System SpecsSystem Spec
08 Jan 2012   #5
Microsoft MVP


Where did you get Win7? Did you burn the DVD yourself? Confirm the ISO integrity using HashTab or download another, burn to DVD using ImgBurn at 4x speed, or write to flash stick using Universal USB Installer.

Next test your RAM - Test with Memtest86+

Test your HD using maker's HD Diagnostic extended CD scan.
My System SpecsSystem Spec
08 Jan 2012   #6

Windows 7 Home premium 64bit

I have tried installing Windows makes no difference . I will try updating the BIOS version to 1.3 (the highest I found on ACRock's website), and see if that makes any difference. Anyone else have any ideas? I'm pretty much tapped...

RE: Windows 7 disc, I purchased an OEM version from
My System SpecsSystem Spec
08 Jan 2012   #7
Microsoft MVP


Try burning this to DVD or writing to flash stick using Windows 7 USB-DVD Download Tool:
Win7 Home Premium x64 SP1 English Official ISO download

Check all of your cables and connections for the new hardware. Try flash stick install with the OD unplugged, HD set to boot first, then use one-time BIOS boot menu key to trigger stick booting under USB, Removable or HD's.
My System SpecsSystem Spec
08 Jan 2012   #8

Windows 7 Home premium 64bit

Greg, thanks for the ideas.

Currently running RAM diagnostic, will let that run over night to see what it finds.

I've downloaded the ISO file that you linked, but the USB-DVD tool you linked does not recognize it as a legitimate ISO file. I receive an error when I try to select the file. I assume that simply copying the ISO to a USB flash drive will not work. Any ideas?
My System SpecsSystem Spec
08 Jan 2012   #9
Microsoft MVP


Yes use Universal USB Installer with Win7 in dropdown, boot under USB, Removable or HD's using one time BIOS Boot Menu key. Set HD first to boot in BIOS.
My System SpecsSystem Spec
08 Jan 2012   #10

Microsoft Community Contributor Award Recipient


As your Asrock Fatallty P67 has a uEFI BIOS.

Follow Step One only in this tutorial using CLEAN/CLEAN ALL: (do not partition)
SSD / HDD : Optimize for Windows Reinstallation
One initial Install Restart, Windows gets stuck in a restart loop-capture001.png
& install Windows 64 bit following this tutorial:
How to install Windows 64 bit on a uEFI BIOS:
UEFI (Unified Extensible Firmware Interface) - Install Windows 7 with
One initial Install Restart, Windows gets stuck in a restart loop-capture002.png

Asrock uEFT BIOS setup, check your manual:
P67 Motherboard Series Manufacturing - ASRock Inc.

My System SpecsSystem Spec

 One initial Install Restart, Windows gets stuck in a restart loop

Thread Tools

Similar help and support threads
Thread Forum
Initial BSOD, now restart loop....
I'm not even sure where to start really. Initially I got a BSOD and my computer restarted but upon trying to startup right after the windows logo it restarts again. I can't load safe mode. I can however enter my bios and have tried repairing what I can from the windows 7 disk. I can browse all my...
General Discussion
Startup Repair- windows cannot repair; Stuck in restart loop
Hi, I am unable to start up my laptop (Windows 7 Home Premium). TOSHIBA Satellite C660-1J6 It is stuck in a loop of 'attempting to repair this computer', which is unsuccessful and restarts. There are no restore points to use. I have received the BSOD which disappears quickly during startup....
General Discussion
Windows Update Stuck in Restart Loop.
Hi Guys, Windows 7 Ultimate x64 has gotten stuck in a loop where it wants to restart and then when your restart it doesn't do anything update related, it just restarts. Can anyone help?! Ybotmallah.
Windows Updates & Activation
Windows Update error, stuck on restart loop.
Greetings Seven Forums crew, I am having an issue with the Windows 7 Update Service. After installing the latest Microsoft Updates (November 2013), I am now stuck in a "restart your computer to finish installing important updates" message. No matter how many times I restart & check for updates,...
Windows Updates & Activation
Stuck in Restart Loop
Hi All, So, my computer is stuck in a restart loop. every now and then I see a screen with option to start windows normally or safe mode, but it loops faster then I can hit enter. being a comp guy and knowing enough about comps, tried to load Windows 7 install disk as well as Ubuntu Live...
BSOD Help and Support

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 23:34.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App