Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: No drives found when trying to reinstall/repair Windows

26 Jan 2012   #1

Windows 7
No drives found when trying to reinstall/repair Windows

Hi all,

I have a big problem:
I have a netbook ASUS Eee PC 1005PXD.
After only two days of use, i get a black screen at the beginning: "Reboot and select proper boot device or insert boot media in selected boot device and press a key".

Pressing F9 on boot doesn't work and i'm still getting the black screen.

F2 is working, then in Boot Settings, i set Removable Device as 1st Boot Device. (and there is no Boot Booster option to disable).

Then, using the Windows 7 USB/DVD Download Tool, i create a Windows 7 bootable USB, in order to use the System Recovery.
When i get to the System Recovery Options screen, no Operating System appear in the list. (It say to load drivers in this case, but i have no idea which drivers and how to load them).

Then i press next without choosing OS, but pressing Startup Repair after that didn't help.
Also using the Command Prompt didn't help (bootrec /fixmbr, bootrec /fixboot, bootrec /scanos, bootrec /rebuildbcd) The two last commands (/scanos and /rebuildbcd) give: "Number of windows installed: 0".

Then i decided to reformat and reinstall Windows 7 (my netbook is new):
i boot using the Windows 7 bootable USB i created before, then on first screen i press on "Install now".
When i get to screen "Which type of installation do you want", i choose Custom.
Then i get to screen "Where do you want to install Windows?" but the list is empty, and at the bottom, it is written "No drives were found. Click Load Driver to provide a mass storage driver for installation".

Please helppp :)

My System SpecsSystem Spec
26 Jan 2012   #2

Microsoft Community Contributor Award Recipient


I have a netbook ASUS Eee PC 1005PXD.
After only two days of use,
(my netbook is new):
Return to the Retailer for FREE REPAIR or Replacement.
My System SpecsSystem Spec
26 Jan 2012   #3
Microsoft MVP


The problem is likely with your installer.

Have you tried running full Factory Recovery from it's partition on the HD? How to restore your Asus EeePC netbook to factory settings

If this isn't an option then confirm your ISO or download another, write to stick using Universal USB Installer with Win7 in dropdown menu.

Had you told your version and bit-rate OS we could have already linked the latest official ISO.
My System SpecsSystem Spec

26 Jan 2012   #4

Microsoft Windows 7 Home Premium 64-bit 7600

i had this issue with our laptop last week ,i ran system repair a couple of times and eventually got the computer did not shut down properly screen, i chose start windows normally and it booted properly.
i suspect it had overheated.
could this have happened with your netbook
My System SpecsSystem Spec

 No drives found when trying to reinstall/repair Windows

Thread Tools

Similar help and support threads
Thread Forum
IE10, IE11 will NOT reinstall into Win7 after op/sys reinstall/repair
Recently I had to *reinstall* the op/sys. Something got into my user profile documents & corrupted the files including the network ability to connect to the internet. Not wanting to dump the op/sys I chose the route of using the install disc to *overwrite* the current system to correct the...
Browsers & Mail
reinstall Windows but on restart no boot found
Hi all, I recently reinstalled Windows 7 after a virus, but I think during the re-install I must have messed with the partitions. Now it installs fine but when I switch the laptop off and reboot it doesn't recognize or run Windows, unless I plug the usb back in and install from there. Once...
Installation & Setup
Detecting drives; Done, No Drives Found - Error and Slow startup
Hey. When I start up my PC everything goes very slowly, things "chops" or lagged as most say. It comes up a menu that says: JMicron Technology Corp.. PCI Express to SATA1 HOST Controller ROM v1.02 Copyright 2005-2010. JMicron Technology Corp..
Hardware & Devices
Can't reinstall/repair windows 7
Hi everyone Recently my old laptop (toshiba a200-1vo) stopped booting. I'd get the "windows has failed to start" message which led me to try to start it up in safe mode, command line mode, etc which all resulted in a black screen with a movable cursor. I then tried booting from my win 7 CD to...
Installation & Setup
Windows 7 Pro 64bit reinstall - CD/DVD drive not found
Hi guys, Wondering if any one can throw any more ideas my way on this one. I have a Sony Vaio VGN-NR11s which has been running a retail boxed version of Windows 7 Professional 64bit fine since its release. My system was a mess, updates stopped working, got some viruses so decided to format...
Installation & Setup

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 01:44.
Twitter Facebook