Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Error In Doing System Setup After Deleting Partition

04 Feb 2012   #1
Himself12794

Windows 7 Home Premium 64bit
 
 
Error In Doing System Setup After Deleting Partition

I recently had a linux partition on my computer. I deleted the partition on my computer. My computer worked fine until I shut it off. When I turned it back on, I had a BOOT problem. I fixed that.

However, in the middle of fixing it I attempted an ACER factory restore option. After fixing the boot problem, Windows will seem to start normally but after showing the logo, it says Setup is starting services. After a few seconds an error pops up saying that:

"Windows could not complete installation. To install Windows on this computer, restart the installation."

So, using a repair disc I'm able to get to windows recovery environment where I see there is now an x: drive named BOOT. I can still see my files but I cannot get to anything except through the CMD option.

I tried to do a system restore, but it says I have to have a protection thing turned on, something that I cannot do. I'm at my whit's end. I cannot think of anything else to do at this moment. Can anyone help me? I cannot afford to buy anything nor get a new computer.


My System SpecsSystem Spec
.
05 Feb 2012   #2
wanchoo

Windows 7 Pro with SP1 32bit
 
 

Looks like a missing MBR problem. Perhaps the computer was using Linux MBR for booting. With deletion of Linux it went away. Now perhaps you need to reformat the Hard Disk and then reinstall your Windows 7 afresh.
My System SpecsSystem Spec
05 Feb 2012   #3
theog

Microsoft Community Contributor Award Recipient

ME/XP/Vista/Win7
 
 

Are you doing the ACER factory restore option from the Recovery partition or Acer Recovery disks?

information   Information
We always assume you have made your Recovery Disks using the OEM manufacturer's Recovery Media Creator app the first day you had your new PC.
& made the Startup Repair CD.
startup repair disc-create


Did you make the OEM manufacturer's Recovery Disks?

Error In Doing System Setup After Deleting Partition-acer001.png

You can Order Acer recovery disks from here:
https://secure.tx.acer.com/RCDB/Main.aspx?brand=acer


My System SpecsSystem Spec
.

05 Feb 2012   #4
Himself12794

Windows 7 Home Premium 64bit
 
 

I used the acer factory recovery settings. I selected the one that saves all the personal documents and files in a backup, then goes back to factory settings. I was not able to create recovery discs because there were no disks available at the time. As for boot MBR, I can even see that file when I go into the recovery environment. I can access command and all.
My System SpecsSystem Spec
05 Feb 2012   #5
Himself12794

Windows 7 Home Premium 64bit
 
 

I feel I also should let you know that there is an E drive that wasn't there before called PQSERVICE that seems to have a lot of boot information on it, including BOOTMGR.
My System SpecsSystem Spec
05 Feb 2012   #6
theog

Microsoft Community Contributor Award Recipient

ME/XP/Vista/Win7
 
 

PQSERVICE is the Recovery Partition.


I would scan the whole hard drive with the manufacturer's diagnostic tools.
Hard Drive Diagnostics Tools and Utilities (Storage) - TACKtech Corp.
HD Diagnostic
My System SpecsSystem Spec
05 Feb 2012   #7
gregrocker

 

You should never start Factory Recovery without having the Disks as a backup. Disks are 5 for $2 on the wall rack at Walgreens.

You can try running Factory Recovery again, but you may have boot sector corruption if you had GRUB on the HD when dual booting Linux. In this case you need to wipe the HD first: SSD - HDD Optimize for Windows Reinstallation

Your options then are to order Recovery Disks from Acer or use a Win7 installation DVD for your licensed version to clean reinstall with the Product Key on COA sticker, following these steps to get a perfect clean reinstall of factory OEM: Reinstalling Windows 7

Win7 Home Premium x64 SP1 English Official ISO download
Windows 7 USB-DVD Download Tool
My System SpecsSystem Spec
05 Feb 2012   #8
Himself12794

Windows 7 Home Premium 64bit
 
 

I did have GRUB, but I don't seem to any more.
My System SpecsSystem Spec
05 Feb 2012   #9
gregrocker

 

It still needs to be wiped as given because GRUB code which can corrupt Win7 remains in the boot sector. This is why I said it needs to be wiped if it had GRUB on the HD.
My System SpecsSystem Spec
06 Feb 2012   #10
Himself12794

Windows 7 Home Premium 64bit
 
 

Thank y'all for your help. I ended up backing up all important files and doing a complete restore as suggested by gregrocker.
My System SpecsSystem Spec
Reply

 Error In Doing System Setup After Deleting Partition




Thread Tools




Similar help and support threads
Thread Forum
"setup was unable to create new system partition" no error log
Hi. Just spent the last 48 hours trying to install a fresh Win 7 on my pc. I used Ubuntu before and formated the drive from GParted in Ubuntu. I'm running into the error: "setup was unable to create a new system partition or locate an existing system partition" I have tried: 1. Running...
Installation & Setup
Error message of "Setup was unable to create a new system partition"
Let me start off my saying I've installed this exact copy of windows 7 before on this computer with no problems and it worked for years. I'm trying to install Windows 7 ultimate 64 bit version when I run into this message "Setup was unable to create a new system partition or locate an existing...
Installation & Setup
Setup was unable to create a new system partition - Installation Error
Hello, I have my HP Laptop which came with Windows Vista as the OS. I want to upgrade to Windows 7 so I bought Windows 7 from my local store. I entered the disc and did boot from CD. It reached to the page where it shows the disk partition. I deleted the partitions and created new one....
Installation & Setup
Install Error Setup was unable to create a new system partition
I am having a problem with doing a fresh install of Windows 7. It is on a Dell Inspiron 1546 with a 150 GB hard drive. There was an original install but the computer was having issues as some files were corrupted. I used the Windows 7 disc to format the hard drive and booted from CD after...
Installation & Setup
Issue deleting old system partition
:/ So yeah... I am having issues deleting stuff from my old windows partition It contains program files, and windows folder, which I seem to be unable to delete, even after taking ownership of them http://gyazo.com/63c61f705084dbf0c079f1427db8d349.png The end result I want, is to get rid of...
Hardware & Devices


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 11:16.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App