Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Cloned 1TB C: Drive to new 2TB, now I can't get Windows Update.

12 Feb 2012   #1

Windows 7 Ultimate 32-bit SP1
Cloned 1TB C: Drive to new 2TB, now I can't get Windows Update.

I just used Acronis True Image WD Edition to clone my 1TB WD SATA drive to a 2TB Seagate SATA Drive to upgrade the boot drive in my HP PC. The cloning process went well and was without errors, and the computer boots fine from the new drive. All settings are correct, etc. The problem is that I can no longer get Windows Updates, download updates to Security Essentials, or upload troubleshooting info to MS. I can access the internet, browse sites, download files, get e-mail, etc. I did have to reactivate Office 2010 when I booted from the new drive, and that went fine.

Windows Update gives me an error message that the update service is not running and I should restart the computer. However, according to services.msc, the update service is running. I tried stopping and restarting the service but it didn't change anything. It was suggested that this hardware change might have caused Windows to deactivate, but it still shows as activated. Nonetheless, I reactivated it (successfully) but there was no change.

The UAC message I get before I run any MS system program (like mmc) shows the publisher as "Unknown". My user account (the only one on the machine) has Administrator privileges, but in order to run certain system programs from the command prompt I have to invoke cmd.exe by selecting "Run as Administrator" or else I'll get the message that I must have Administrator privileges to run the particular system program.

When I reinstalled the original 1TB drive, everything worked fine.

Frankly I'm stumped and would appreciate any ideas as to what may have happened and how to fix it.


My System SpecsSystem Spec
12 Feb 2012   #2

Windows 7 Ultimate SP1 64-Bit

Welcome to Windows Seven Forums.

This a real stab in the dark, but I'm wondering if the problem is related to the fact you've cloned to a larger size drive?

Perhaps partitioning the 2TB drive into 2x1TB partitions might help?

Failing that, I'll defer to experts who have more knowledge on drive systems and cloning than I do.
My System SpecsSystem Spec
12 Feb 2012   #3

Windows 7 Ultimate 32-bit SP1

I suppose it's possible, but the PC doesn't have any troubles recognizing, booting from or accessing the drive.

It's almost as though the OS has "forgotten" who Microsoft is (as evidenced by its showing the publisher of MS system programs as "Unknown") and/or that file and folder ownerships and privileges have somehow become corrupted.
My System SpecsSystem Spec

12 Feb 2012   #4


This often works to reset Windows Update when it stops working: How do I reset Windows Update components?
My System SpecsSystem Spec
12 Feb 2012   #5

Win 8 RP, Win 7, XP

The problem is maybe that security modules are not functioning properly.

Try creating a new user account with admin privileges and see if it can start system programs and Microsoft is recognized as publisher.
My System SpecsSystem Spec
12 Feb 2012   #6

Desk1 7 Home Prem / Desk2 10 Pro / Main lap Asus ROG 10 Pro 2 laptop Toshiba 7 Pro Asus P2520 7 & 10

Welcome swperk Now I use EaseUS to do as EVERYONE knows after I go on about it so much - have never had a problem like this with my clones and in fact I used to keep two 1TB drives in the machine before the SSD and regularly clone form one to the other and then unplug the one I cloned from and use the fresh clone.

It was just a matter of re-cloning back to get an "updated" drive and repeat the process I find this better than backing up to be honest. If one drive crashes completely the others there ready to go.

EaseUS is free and only has one drawback you can only clone from small to large ot same to same ie 1TB to 2TB or 1TB to 1TB

Might be worth a try mate Easeus Todo Backup Free - < easier than the site watch out for the add on Ask bars or whatever happens to pop up during install and look what have you got to lose? All you need is a spare drive to test out on if you don't want to use the original drives.
My System SpecsSystem Spec
12 Feb 2012   #7

Windows 7 Ultimate 32-bit SP1

Thanks for all the suggestions.

I tried using the Window Update troubleshooter, and I was encouraged when it told me it found two bad components and repaired them, but that didn't fix it. Every time I run it, it says it found two bad components and fixed them, but every time no success. The errors it reports are that one or more Update components were configured incorrectly, and that the Windows Update location had to be change to the default location.

I set up a new administrator account, but the same problems remain.

I have EaseUS installed, but do not have another drive with enough capacity to try it out on yet.
My System SpecsSystem Spec
12 Feb 2012   #8


Try running SFC -SCANNOW Command.

If this fails consider a Repair Install which should set it right.
My System SpecsSystem Spec
13 Feb 2012   #9

Windows 7 Ultimate SP1 64-Bit

You may also want to download and run the System Updates Readiness Tool, which is designed to fix updating problems.

Download: System Update Readiness Tool for Windows 7 (KB947821) [August 2011] - Microsoft Download Center - Download Details

This is the 32-bit version.
My System SpecsSystem Spec
13 Feb 2012   #10

Windows 7 Ultimate 32-bit SP1

Thanks once again for the help. I ran SFC /SCANNOW and it said it found errors that it couldn't fix. I just ran the Readiness Tool but it stopped with an Installer error 0xc8000247.

I don't know what else to try besides re-cloning with Acronis.

Very strange!
My System SpecsSystem Spec

 Cloned 1TB C: Drive to new 2TB, now I can't get Windows Update.

Thread Tools

Similar help and support threads
Thread Forum
Recently cloned drive - Update Service not functioning
Hi all. Windows update is not functioning. The message received is: "Windows update cannot currently check for updates because the service is not running. You may need to restart your computer" Background: I cloned a dying HDD (48+ bad sectors) to a new healthy one using HDClone...
Windows Updates & Activation
Problem after having cloned drive. (showing incorrect space on drive)
First off PC specs: AMD Phenom II x4 processor - 3.4 Ghz 8GB DDR3 RAM Nvidia N460 GTX GFX card 240GB SanDisk SSD Windows 7 64 bit So here is the problem. I had a Western Digital 300 GB SATA drive that was starting to quit on me. So using an Ubuntu live CD I cloned the 300 gig drive onto...
General Discussion
Windows explorer crashing on cloned hard drive
I have bought laptop with ore installed windows 7 premium 64 bit. It came with a 320 gig hard drive. I have upgraded to a 1 tb and using seagate disk wizard I cloned the 320 hd to the 1 tb. But ever since then the 1 tb hard drive boots fine to windows but the explorer keeps crashing and restarting...
General Discussion
cloned Windows 7, need to change PATHNAME to drive D?
how can I do a mass drive change, to every single file, exe, sys, EVERYTHING, to get the OS in sync with drive D? It originally came from Drive C, and nothing works, even if I try to start stuff manually it doesn't work. EVERYTHING for this windows 7 is in Drive D... the Pathnames and targets...
Performance & Maintenance
Cloned Drive with Windows 7
I installed W7 on my D: drive and it was only 80GB, and had everything running to my satisfaction. Started adding a few programs from my Vista install and thought the drive was to small, so cloned the drive unto a backup drive and installed a 1TB drive. Cloned the image back unto the new drive, but...
Installation & Setup

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 16:28.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App