Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Win7 will not complete install on SSD - works fine on HDD

06 Mar 2012   #1

Windows 7 pro
Win7 will not complete install on SSD - works fine on HDD

New gaming PC project:
Asus Rampage Extreme IV
I7 3960x
32gb Gskill 2133 mhz
Sound Blaster Recon 3D
2 Corsair Force GT 60gb sata3
2 Corsair Force GT 120gb sata3
Win7 home 64bit w/anytime upgrade to Professional (Didn't know about the 16gb ram cap...)
9800 GTX video (ran outta money...)

I apologize this might be lengthy...

The issue I'm having is everything seems fine till the first reboot, then I get errors about some random important file is missing or corrupt, please insert your DVD and repair windows or whatever the hell it says. The specified missing file is always different each install attempt (I have made about 30ish attemps so far in every drive configuration I could think of). Once it even said 'a system file' is missing or corrupt with no file specified. One attempt (120gb drives in raid0 with no other drives attached) did make it to the Win7 load screen, but then windows encountered an 'unknown error' and had to close while finalizing.

What I wanted to do was raid0 the 60's for boot and raid0 the 120's for games, but I can't do that because while this mb has 4 sata3 ports, only 2 ports are raid capable (Intel C600 controller) as the other 2 are on an ASMedia controller. As that is the least of my problems and only my fault for making assumptions before I buy crap, what I thought to do instead was install win on one 60 on the ASMedia sata3 controller in AHCI with OPROM enabled, use the other 60 for task file, and raid0 the 120's for game installs.

At first I thought the problem was bad drives because it installs fine on my old HDDs, but all 4 drives DOA seems unlikely so I figure I'm doing something wrong. There are multiple posts about issues with these drives on Corsair forums, however none of their solutions provide a fix. Currently I have Win7 installed on 2 seagate 160gb HDD's in raid0 on sata2 with both 60's on sata3 ASMedia and both 120's in raid0 on sata3 Intel C600 controller. I am convinced there is no problem with any drive as I have multiple games installed on the raid0 with task file on 1 60 and the other 60 is dedicated to ready boost. Honestly I have no idea what ready boost does, and with 32gb of ram it probably doesnt do much - but I can't think of anything else to do with the drive to see if I get any system hangs or issues. After a week in this configuration I have had no issues whatsoever.

I have run error checking from the properties tab in win for all drives, as well as chkdsk from command prompt and the disk checking utility in partedmagic which all came back no problems found. ATTO benchmark shows the the 60's around 475mb/s read/write and the 120's in raid0 are about 1100mb/s read/write. These SSD's are lightning fast. My HDD's are not - 275mb/s read/write in raid0 . Must needs faster boot.

I have tried installing win on each drive individually on each controller twice (16 attemps of my life wasted) and tried each set in raid0 a few times. Every attempt started out with a partition deletion and a secure erase using partedmagic AND sata3 controller in AHCI mode per Corsair forums. I have done Corsair's 1.3.3 firmware update to each drive. I have tried letting windows partition/format each drive during the install. I tried booting from my HDD's, then creating partition tables, allocating sapce, and formatting the SSD's from disk management, then installing win on the drives already setup. And a few other various things in different orders.

My steps for the 1 result that yeilded and actual win7 loading screen after 1st reboot:

2 120gb ssd's on Intel C600 sata3

enter bios - change sata from raid to ahci - exit

boot with partedmagic bootdisk - deleted partitions both drives - system suspend for drive reset - secure erase both drives - shutdown

plugged in 2 160gb hdd to sata2

enter bios - change sata from ahci to raid - exit

enter raid setup utility - create raid0 on 120gb ssd's with 32kb strip - exit

boot win from hdd - create MBR partition table, allocate all avail space, format NTFS (not quick format) - shutdown

unplugged 2 160gb hdd

boot from win7 install disk - install to SSD raid volume - 1st reboot yeilds load screen then 'unknown error', but i guess it was some-what better than windows failed to start due to whatever random file missing or corrupt.

I don't know what else to try - I'm hoping i'm making some obvious mistake I keep overlooking that one of you can point out or something that needs to be done for booting from SSD's I don't know about.

-Sorry for the long post
-Thank you for taking the time

My System SpecsSystem Spec
06 Mar 2012   #2
Microsoft MVP


Where did you get WIn7? Did you burn the DVD yourself? Confirm ISO integrity and burn another using ImgBurn at 4x speed. Or write to flash stick using Universal USB Installer with Win7 in dropdown menu.

Reset BIOS to defaults, then set SATA controller to AHCI. Remove all but one HD, then try install again.

Next try removing all but one stick of RAM to try install. Try swapping RAM sticks. Test your RAM - Test with Memtest86+

Win7 does not like RAID. It confers no benefits as it isn't even redundant since if one HD fails you lose everything.
My System SpecsSystem Spec
06 Mar 2012   #3
Hipster Doofus

Windows 7 Pro x64 -- PCLinuxOS KDE4 FullMonty 2011

EDIT - already done
My System SpecsSystem Spec

06 Mar 2012   #4

Windows 7 pro

Win7 dvd from best buy
I have done the memtest86+ all 8 sticks of 4gb pass
I have tried fresh installs on all drives on both sata3 controllers as a single disk after clearing cmos and secure erase on the drives (ahci is the default sata setting)

I will try copying the windows dvd to a flash drive and a blank dvd with only 1 mem stick, 1 drive, and no sound card. I don't think it is a problem with the install dvd as I've installed from that dvd to standard hdd twice - once on a single hdd then as a raid0.

Is it possible to copy my existing install from my HDD to one of the SSD?
My System SpecsSystem Spec
06 Mar 2012   #5
Microsoft MVP


You can try this: SSD - Install and transfer the Operating System

In addition to the methods given there, you can clone over with Macrium, or the free Premium Acronis app which comes when any WD or Seagate HD is in the mix. Win7 backup imaging can also be tried.

What is the exact failure point and verbatim error when installing to only one HD? Clean Install Windows 7
My System SpecsSystem Spec

 Win7 will not complete install on SSD - works fine on HDD

Thread Tools

Similar help and support threads
Thread Forum
No 32 bit browser does NOT work. 64 bit works fine. Win7-64
Hi All, Windows IExplored(9)-32 & Crome-32 do not work. (Error 105 (net::ERR_NAME_NOT_RESOLVED): Unable to resolve the server's DNS address.) IExplorer(9)-64 works just fine. I've been researching my issue for a few days now and have no success inplementing the recommended fixes I've found,...
Browsers & Mail
did a fresh install of windwows 7 and everything works fine... but
did a fresh install of windows 7 and everything works fine... but I have a Application and driver recovery cd when i did a fresh instal all the programes disapeard (works processor), do i need to put the "application and driver recovery cd in as well and run it.
General Discussion
32-bit works fine, cant install 64-bit?
Hey all. First time poster, long time lurker! Ive had my i5 rig running on XP pro for a bit and then decided to upgrade to win7 Ultimate. installed 32bit fine, decided to go to 64bit. Install gets all the way through then reboots (which im told will happen). once its rebooted, install gets...
Installation & Setup
Cant install 64bit but 32bit works fine
Hello, i am a newbie to this forum, so if i leave any relevant info out apologies in advance. I have recently built a new htpc (i listed all specs) all the hardware i purchased was brand new. i had win xp and tried to upgrade to win 7 64bit but kept getting blue screened, so then i tried win 7...
Installation & Setup
ATI card works fine in Win7 Ult RC, not in Win7 Prof
I've been using the Windows 7 Ultimate release candidate as an evaluation copy for a while now with no problems. I have an ATI radeon mobility X1600 graphics card in my laptop and I'm using an external monitor through my laptop's DVI port. I bought a product key for Windows 7 professional and...

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 09:32.
Twitter Facebook