Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Can't do a fresh install of Windows 7 - 64 Bit (MBR Part Table)

30 Apr 2014   #21
Microsoft MVP


Quote   Quote: Originally Posted by SIW2 View Post

Booting windows from gpt requires efi. That is windows limitation. Linux will boot off juat about anything, including a damp piece of string.

You can use gpt partitioned devices as storage, but if you want to boot windows from it, you will have the extra complications and limitations of efi to deal with.
Yes, I remember GPT storage drives from the early days here before we had to deal with the UEFI crapware.

Professor, do you see any real benefit to UEFI or Secure Boot?

I am just shaking my head at UEFI, Secure Boot and Windows 8, at the absurdity of these being considered progress by anyone. Instead they have grotesquely fumbled what was a near-perfect stasis in Windows 7.

SSD's are the real progress, all that's needed besides SP2.

My System SpecsSystem Spec
30 Apr 2014   #22

Microsoft Community Contributor Award Recipient

Vista x64 / 7 X64

Complicated question.

Clearly it has been introduced to benefit the industry, it gives them control over what the user can do.

It is possible to produce a list of supposed advantages. However, you could also produce a list of supposed advantages for bios.

Practical benefit to the end user is down to a few seconds saved at boot. Complications are many.

It is not impossible something else may come from it that by coincidence is also of benefit to the end user. Until and unless that happens, probably best to stay away from it.

Buyers of new machines don't get the choice.
My System SpecsSystem Spec
30 Apr 2014   #23
Microsoft MVP


Unless you want to reinstall in Legacy BIOS: Bypass UEFI to Install WIn7

However there can be hurdles. I have a Lenovo G500 on which I used UEFI when it wouldn't budge in Legacy no matter what I tried, however I've just found new search results where it was done resetting BIOS to PC defaults after setting Legacy - something else to remember.

Some require firmware update that hasn't been released, possibly so OEM can maintain more control over what's installed. I think that may be the case here where Win7 will not Dual boot with 8 in UEFI: Windows 7 Clean Dual-Boot Installation is Stuck on "Starting Windows"
My System SpecsSystem Spec

30 Jun 2014   #24
Rob 0

7 Ultimate

I solved this problem by pushing my usb key to the top of the boot list in bios boot and placing my hard drive in the second position... "Windows cannot be installed to this disk. The selected disk has an MBR partition table. The EFI systems, Windows can only be installed to GPT ...problem solved for 8.1.
My System SpecsSystem Spec
30 Jun 2014   #25

Windows 7 Pro x64 Windows 10 Pro x64

I had to do the exact opposite on a GPT drive, amazingly simple to do. :)
My System SpecsSystem Spec
05 Nov 2014   #26

windows 7 64bit

"Simple Fix Before realizing this I noticed that during the boot process you can (maybe just on some systems and not all), at least on the Biostar I was building (Edit: amny newer MB's I notice), see the switch from the one DVD mode type to the other by means of seeing the words "Press any key to boot from DVD" move to another location on the screen. I simply ignored the first flash of those words and clicked a key to boot from the DVD when I noticed the words flash again a second time in a different location. The Windows 7 then installed as before without problem."

Pause and Reflect, this took care of it exactly. Just waiting for a few seconds to see the same Start up Message in a different location and with a different font came up. It did and solved the problem.
My System SpecsSystem Spec

 Can't do a fresh install of Windows 7 - 64 Bit (MBR Part Table)

Thread Tools

Similar help and support threads
Thread Forum
Install Windows 7 to SSD Drive, Selected Disk has MBR Partition Table.
Hello, I have a Dell Latitude E6410 that has Windows 7 with a SSD hard drive. I am trying to format the hard drive and reinstall windows 7 home prem. I went into the bios changed boot list option to legacy. The only options I get are Legacy and UEFI. My hard drive is recognized in the bios. I...
Installation & Setup
How to create install disks from an install of Windows 7/Recovery Part
Hi I have a new Asus CM6730 W7 PC (x64) it did not come with Install disk but it does have a recovery partition. How do I make install disk for this W7 install, I want to format the recovery partition to use it for other things. Thanks Daniel
General Discussion
Fresh Install Win 7 Enterprise- 1 part of partition access denied
Hello Again As the subject suggests, I have had to re install Windows 7 Enterprise and it seems to have lost part of the partitioned drive. As per the picture the PS3 drice and Panthro drives are part of an internal hard drive, when I click on it I get the error message? Would be very...
Hardware & Devices
Fresh Install of Win Pro 64 Missing part of HD
Great install! Clean and fast. However I am puzzled to see that part of my 320 gb 7200 drive is not recognized. A right click on C drive states that I have 282 GB left out of 297GB. I do not want to move forward with my install before accounting for this space. So...anyone have any advice? ...
Installation & Setup
Can't Install Windows 7 on GUID Partition Table
Is it possible to install Windows 7 on a GPT disk? I created a RAID 0 array on my dual Xeon 5580 system and tried installing Windows 7 Ultimate 64-bit RTM. When I got to the "Where do you want to install Windows" part I used shift-F10 to open up a command window, then I used diskpart to create a...
Installation & Setup

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 08:07.
Twitter Facebook Google+