Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Problems w/factory restore - receiving WinReLauncher.exe error

08 May 2012   #1

Windows 7 Starter
Problems w/factory restore - receiving WinReLauncher.exe error


I recently had a virus and was able to successfully remove it from my computer; however, I am having problems when I try to restore the computer to original factory settings.

My goal is to do a full factory reset, but when accessing the "Repair My Computer" option from the F8 screen, I am given the following error:

"WinReLauncher.exe - entry point not found. The procedure point ?Get ESPPartition@CSTDisk@@QAE?AVCSTPartition@@XZ" could not be located in the dynamic link library STDisks.dll."

I am running Windows 7 on a Dell Inspiron Mini laptop.

I have already tried using CCleaner and Glary Registry cleanup, both of which I downloaded from Cnet.

I would love any help that can be provided to me! Thanks so much in advance...

My System SpecsSystem Spec
08 May 2012   #2

Windows 7 Home Premium 32bits

Hello DreamSE22 and welcome to SevenForums
This sounds like the link to the Dell DataSafe is broken. Can you see the recovery partition? You might have the unhide files and folders to look inside that partition. Does that partition have a drive letter assigned? I see that it's windows 7 starter, is it 32bit? You might be able to fix this with reagentc.exe from elevated cmd prompt. Check what you have and let us know what you find out.
Tom :)
My System SpecsSystem Spec
02 Jul 2012   #3

Windows 7
@ tjg


I am having the same issue. When I try to restore my computer winrelauncher fails.

I have tried booting in safe mode and restoring from there but that has failed too.

I will attach some pictures showing my errors.

My goal is to erase everything and start over. I do not have a windows 7 disc

thank you

Attached Thumbnails
Problems w/factory restore - receiving WinReLauncher.exe error-photo-jul-02-5-28-03-pm.jpg   Problems w/factory restore - receiving WinReLauncher.exe error-photo-jul-02-11-03-43-am.jpg  
My System SpecsSystem Spec

02 Jul 2012   #4

Windows 7 Home Premium 32bits

Hello jedagolfer123

First you need to test your memory and make sure it is OK. If it is, try ccleaner and check your reg.
Hope this helps, and maybe someone else might have better answers.

TJG :)
My System SpecsSystem Spec

 Problems w/factory restore - receiving WinReLauncher.exe error

Thread Tools

Similar help and support threads
Thread Forum
dell datasafe factory image restore error
hi, im trying to restore my dell laptop to factory image using its dell datasafe local backup, but everytime it restarts it comes up with a error message saying "windows failed to start. a recent hardware.........insert your windows installation disc...........file:...
Backup and Restore
Removing factory restore image partition - any operational problems?
Hi. I've searched and read until I'm cross-eyed and still don't feel I've found a definitive answer to this. For one thing, sometimes the threads are discussing removing the Windows 7 hidden System partition and sometimes the partition containing the OEM's factory restore wim. But, sometimes it...
Backup and Restore
Factory Restore not working, error 0xe0ef000d, Image Restore?
Hello people. I'm new to this so please bear with me. Okay so I'll give a brief explanation of what's going on. So a couple of years ago I gave my old computer(HP Pavillion p2 Series /with Windows 7 home) to my younger siblings, because I moved and got a new computer for school. I put a secure...
Backup and Restore
Factory restore error: 0x40011002000100a
Hello. I am having HORRIBLE problems with my laptop. 1. It's freezing constantly, I HAVE Black screen of death. 2. Windows welcome screen takes forever to log in. 3. No AMD whatever or something and there is plenty more. And decided to try restore my laptop to new, I can't because as title...
Installation & Setup
Factory Restore Unsuccessful in preventing Loop Error
Hi, recently my Acer Aspire 7740-5691 experienced some malware problems and I had to restore it. I was getting this error: "The computer restarted unexpectedly or encountered an unexpected error. Windows installation cannot proceed. To install Windows, click OK to restart the computer and...
BSOD Help and Support

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 08:09.
Twitter Facebook Google+