Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: oxc000000e Boot failed-required device is inaccessible (Windows 7)

07 Jun 2012   #121
Kaktussoft

Microsoft Community Contributor Award Recipient

Microsoft Windows 7 Home Premium 64-bits 7601 Multiprocessor Free Service Pack 1
 
 

Quote   Quote: Originally Posted by moh3en View Post
Quote   Quote: Originally Posted by Kaktussoft View Post
Quote   Quote: Originally Posted by moh3en View Post

i goto bios. and default was "AHCI". again same error
So it was ahci already. Windows tries to start msahci as well. But it wasn't there!
What other SATA options do you have in bios? (AHCI, RAID,IDE?) give a summary please
It's include AHCI and IDE. also i set to IDE and Save (F10) and boot loading same error!
only AHCI and IDE possible? or are there more options to select from?


My System SpecsSystem Spec
.
07 Jun 2012   #122
moh3en

Windows 7 Home Premium 64bit
 
 

in Startup repair.
oxc000000e Boot failed-required device is inaccessible (Windows 7)-2012-06-07-15.59.38.jpg

just only AHCI and IDE and no more!


My System SpecsSystem Spec
07 Jun 2012   #123
Kaktussoft

Microsoft Community Contributor Award Recipient

Microsoft Windows 7 Home Premium 64-bits 7601 Multiprocessor Free Service Pack 1
 
 

Quote   Quote: Originally Posted by moh3en View Post
in Startup repair.
Attachment 215475

just only AHCI and IDE and no more!
can you see any details? Which file is corrupt? and is it code 0x2 .. what file and what error?
My System SpecsSystem Spec
.

07 Jun 2012   #124
moh3en

Windows 7 Home Premium 64bit
 
 

Quote   Quote: Originally Posted by kaktussoft View Post
Quote   Quote: Originally Posted by moh3en View Post
in startup repair.
Attachment 215475

just only ahci and ide and no more!
can you see any details? Which file is corrupt? And is it code 0x2 .. What file and what error?
oxc000000e Boot failed-required device is inaccessible (Windows 7)-2012-06-07-16.14.44.jpg

Quote:
startup diagnosis and repair log:
Number of repair attempts : 6

session details:
System disk = \device\harddisk0
windows directory = c:\windows
autochk run = 0
number of root causes = 1

test performed all have error code = 0x0

root cause found:
=======================
a recent driver installation or upgrade may be preventing the system from starting.

Repair action: System file integrity check and repair
result: Failed error code = 0x2
time taken = 55554 ms


My System SpecsSystem Spec
07 Jun 2012   #125
Kaktussoft

Microsoft Community Contributor Award Recipient

Microsoft Windows 7 Home Premium 64-bits 7601 Multiprocessor Free Service Pack 1
 
 

in recovery environment ->command prompt

Code:
 
sfc  /scannow  /offbootdir=c:\   /offwindir=c:\windows
post results
My System SpecsSystem Spec
07 Jun 2012   #126
Kaktussoft

Microsoft Community Contributor Award Recipient

Microsoft Windows 7 Home Premium 64-bits 7601 Multiprocessor Free Service Pack 1
 
 

Quote   Quote: Originally Posted by moh3en View Post
Quote   Quote: Originally Posted by kaktussoft View Post
Quote   Quote: Originally Posted by moh3en View Post
in startup repair.
Attachment 215475

just only ahci and ide and no more!
can you see any details? Which file is corrupt? And is it code 0x2 .. What file and what error?
Attachment 215477

Quote:
startup diagnosis and repair log:
Number of repair attempts : 6

session details:
System disk = \device\harddisk0
windows directory = c:\windows
autochk run = 0
number of root causes = 1

test performed all have error code = 0x0

root cause found:
=======================
a recent driver installation or upgrade may be preventing the system from starting.

Repair action: System file integrity check and repair
result: Failed error code = 0x2
time taken = 55554 ms
No filename??? Like this for example

root cause found:
boot critical file: c:\windows\system32\drivers\msahci.sys is corrupt.
repair action: File repair
result: failed error code : 0x2

repair action: system file integrity check and repair
result: failed error code : 0x2.
My System SpecsSystem Spec
07 Jun 2012   #127
moh3en

Windows 7 Home Premium 64bit
 
 

Quote   Quote: Originally Posted by Kaktussoft View Post
in recovery environment ->command prompt

Code:
 
sfc  /scannow  /offbootdir=c:\   /offwindir=c:\windows
post results
Beginning system scan. This process will take some time.

Windows resource protection could not perform the requested operation.
My System SpecsSystem Spec
07 Jun 2012   #128
moh3en

Windows 7 Home Premium 64bit
 
 

Quote   Quote: Originally Posted by kaktussoft View Post
no filename??? Like this for example

root cause found:
Boot critical file: c:\windows\system32\drivers\msahci.sys is corrupt.
Repair action: File repair
result: Failed error code : 0x2

repair action: System file integrity check and repair
result: Failed error code : 0x2.
oxc000000e Boot failed-required device is inaccessible (Windows 7)-2012-06-07-16.36.16.jpg


My System SpecsSystem Spec
07 Jun 2012   #129
Kaktussoft

Microsoft Community Contributor Award Recipient

Microsoft Windows 7 Home Premium 64-bits 7601 Multiprocessor Free Service Pack 1
 
 

Quote   Quote: Originally Posted by moh3en View Post
Quote   Quote: Originally Posted by kaktussoft View Post
no filename??? Like this for example

root cause found:
Boot critical file: c:\windows\system32\drivers\msahci.sys is corrupt.
Repair action: File repair
result: Failed error code : 0x2

repair action: System file integrity check and repair
result: Failed error code : 0x2.
Attachment 215479
same if bios sata is set to IDE?
My System SpecsSystem Spec
07 Jun 2012   #130
moh3en

Windows 7 Home Premium 64bit
 
 

Quote   Quote: Originally Posted by Kaktussoft View Post
Quote   Quote: Originally Posted by moh3en View Post
Quote   Quote: Originally Posted by kaktussoft View Post
no filename??? Like this for example

root cause found:
Boot critical file: c:\windows\system32\drivers\msahci.sys is corrupt.
Repair action: File repair
result: Failed error code : 0x2

repair action: System file integrity check and repair
result: Failed error code : 0x2.
Attachment 215479
same if bios sata is set to IDE?
no. it's AHCI.
My System SpecsSystem Spec
Reply

 oxc000000e Boot failed-required device is inaccessible (Windows 7)




Thread Tools




Similar help and support threads
Thread Forum
boot selection failed because a required device is inaccessible
Hi, I know a lot of people have posted this but I think mine is different to theirs. I took a SSD drive used to boot my sons pc, placed it in my computer and cloned it with Norton ghost onto a bigger drive. When I put the new drive in his PC I got the error "boot selection failed because a...
General Discussion
boot selection failed because a required device is inaccessible
Ok, so my recovery partition disappeared, so as a last resort I followed these instructions - and changed my active partition to the second partition in my list... and now my laptop is utterly bricked. I've tried downloading a windows 7 starter image and putting it on a USB and booting from that...
General Discussion
the boot selection failed because a required device is inaccessible
I have an Intel i5, Windows 7 Ultimate, and an SSD as my main drive and 2 SATA HDDs. One day, I got a BSOD appeared and my PC restarted restarted. After that, the following error appeared: Window failed to start. A recent hardware or software change might be the cause. To fix the...
General Discussion
oxc000000e Boot failed-required device is inaccessible
Hello, Installed Acronis True Image Home 2011 a couple days ago. I did not setup any items within Acronis yet for backups, etc. After install my system appeared O.K. and have shutdown/restarted several times without issue. Yesterday, the computer shut down inadvertently, then at boot i get this...
Installation & Setup
Boot selection failed because a required device is inaccessible
right, i've noticed another thread with the similar problem, here, and apparently it's fixed, but as i'm running my system on a laptop, i'm wondering what i can do to recover my system without any data loss. error message's more or less the same, "Windows failed to start. A recent hardware or...
General Discussion


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 09:14.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App