Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: oxc000000e Boot failed-required device is inaccessible (Windows 7)

05 Jun 2012   #61
Kaktussoft

Microsoft Community Contributor Award Recipient

Microsoft Windows 7 Home Premium 64-bits 7601 Multiprocessor Free Service Pack 1
 
 

And now the msahci.sys error stays?

No error 0xc000000e anymore.

You told me before... e:\Windows\system32\drivers\msahci.sys is simply not there!
Someone deleted it!

dir e:\Windows\system32\drivers

any files there?

You can try to boot and enter BIOS settings. Set SATA to IDE (sometimes called legacy) save settings and try to boot. Post results. If still problems, put setting back!


My System SpecsSystem Spec
.
05 Jun 2012   #62
gregrocker
Microsoft MVP

 

Quote   Quote: Originally Posted by moh3en View Post
Quote   Quote: Originally Posted by gregrocker View Post
Confirm that you Rebuilt MBR after marking 200mb partition Active with PW CD: How to Rebuild MBR with partition magic? Partition Wizard Rebuild MBR Video Help.

Confirm you then ran Startup Repair three separate times. Not two times. Three times.

Then confirm you did all of the above with the Win7 partition itself marked Active.
Please describe it exactly?

How much more specific do you need:

Quote   Quote: Originally Posted by gregrocker View Post
From booted PW CD mark the 200 mb System Reserved boot partition Active by rightclicking to Modify>Set to Active, click OK.

Then click on Disk 1 to highlight it, from Disk tab select Rebuild MBR, OK, APply both steps.

If this fails to start Win7 boot into Win7 DVD System Recovery Options or System Repair Disk to run Startup Repair - Run 3 Separate Times until Win7 starts on its own.

If these steps fail, change the Active flag to Win7 partition itself and repeat the steps above exactly.

If these steps fail then we have to consider the possibility your original problem was infection and attempt to disinfect and then run the repairs again. Steps here: Troubleshooting Windows 7 Failure to Boot
My System SpecsSystem Spec
05 Jun 2012   #63
moh3en

Windows 7 Home Premium 64bit
 
 

Quote   Quote: Originally Posted by Kaktussoft View Post
And now the msahci.sys error stays?

No error 0xc000000e anymore.

You told me before... e:\Windows\system32\drivers\msahci.sys is simply not there!
Someone deleted it!

dir e:\Windows\system32\drivers

any files there?

You can try to boot and enter BIOS settings. Set SATA to IDE (sometimes called legacy) save settings and try to boot. Post results. If still problems, put setting back!
yes. now i get this error:
File:\Windows\system32\drivers\msahci.sys0xc000000fWindows failed to load beacuse a critical system driver is missing or corrupt.


what's your mean this text?

You can try to boot and enter BIOS settings. Set SATA to IDE (sometimes called legacy) save settings and try to boot. Post results. If still problems, put setting back!

now it's boot from CD first and second IDE 1: WDC WD5000

how check for file with recovery? how i can goto factory setting? when active for LENOVO_PART.. in boot goto recovery but i just see cmd and no more... and when close cmd automatic restart!!
My System SpecsSystem Spec
.

05 Jun 2012   #64
Kaktussoft

Microsoft Community Contributor Award Recipient

Microsoft Windows 7 Home Premium 64-bits 7601 Multiprocessor Free Service Pack 1
 
 

Any important files on your harddisk? Do you have external usb-disk to backup files?
My System SpecsSystem Spec
05 Jun 2012   #65
moh3en

Windows 7 Home Premium 64bit
 
 

Quote   Quote: Originally Posted by Kaktussoft View Post
Any important files on your harddisk? Do you have external usb-disk to backup files?
yes. i have backup of files! i just keep LENOVO_PART Drive.
My System SpecsSystem Spec
05 Jun 2012   #66
Kaktussoft

Microsoft Community Contributor Award Recipient

Microsoft Windows 7 Home Premium 64-bits 7601 Multiprocessor Free Service Pack 1
 
 

Quote   Quote: Originally Posted by moh3en View Post
Quote   Quote: Originally Posted by Kaktussoft View Post
Any important files on your harddisk? Do you have external usb-disk to backup files?
yes. i have backup of files! i just keep LENOVO_PART Drive.
What lenovo laptop do you have? type please
My System SpecsSystem Spec
05 Jun 2012   #67
moh3en

Windows 7 Home Premium 64bit
 
 

Quote   Quote: Originally Posted by Kaktussoft View Post
Quote   Quote: Originally Posted by moh3en View Post
Quote   Quote: Originally Posted by Kaktussoft View Post
Any important files on your harddisk? Do you have external usb-disk to backup files?
yes. i have backup of files! i just keep LENOVO_PART Drive.
What lenovo laptop do you have? type please
Lenovo idealpad Y460
My System SpecsSystem Spec
05 Jun 2012   #68
Kaktussoft

Microsoft Community Contributor Award Recipient

Microsoft Windows 7 Home Premium 64-bits 7601 Multiprocessor Free Service Pack 1
 
 

Since you have 3 primary partition and 1 extended one, you already have the max of 4 partitions.

Within PW delete partition 200MB (partition is not really needed)
Make 420GB partition smaller. Make it 350GB or so. There will be 70GB unallocated space then. Format the unallocated space as NTFS (quick format) and make it primary. Mark that partition as active.

Now of course apply the changes. Post camshot when it has done the job.

http://consumersupport.lenovo.com/sg...%2064bit&cid=0
important drivers needed later maybe
My System SpecsSystem Spec
05 Jun 2012   #69
Kaktussoft

Microsoft Community Contributor Award Recipient

Microsoft Windows 7 Home Premium 64-bits 7601 Multiprocessor Free Service Pack 1
 
 

Or use Lenovo Drivers Update Utility - CNET Download.com to update all your drivers later
My System SpecsSystem Spec
06 Jun 2012   #70
moh3en

Windows 7 Home Premium 64bit
 
 

Kaktussoft Drive C is now 420gb and Drive D is 30gb. i want change it. beacuse before all files was in Drive C and lost it.
Now i want 50gb for Drive C and factory setting and other in Drive D. if change partition Not a problem? for factory setting!

Also don't tell me about how do factory setting?
My System SpecsSystem Spec
Reply

 oxc000000e Boot failed-required device is inaccessible (Windows 7)




Thread Tools




Similar help and support threads
Thread Forum
boot selection failed because a required device is inaccessible
Hi, I know a lot of people have posted this but I think mine is different to theirs. I took a SSD drive used to boot my sons pc, placed it in my computer and cloned it with Norton ghost onto a bigger drive. When I put the new drive in his PC I got the error "boot selection failed because a...
General Discussion
boot selection failed because a required device is inaccessible
Ok, so my recovery partition disappeared, so as a last resort I followed these instructions - and changed my active partition to the second partition in my list... and now my laptop is utterly bricked. I've tried downloading a windows 7 starter image and putting it on a USB and booting from that...
General Discussion
the boot selection failed because a required device is inaccessible
I have an Intel i5, Windows 7 Ultimate, and an SSD as my main drive and 2 SATA HDDs. One day, I got a BSOD appeared and my PC restarted restarted. After that, the following error appeared: Window failed to start. A recent hardware or software change might be the cause. To fix the...
General Discussion
oxc000000e Boot failed-required device is inaccessible
Hello, Installed Acronis True Image Home 2011 a couple days ago. I did not setup any items within Acronis yet for backups, etc. After install my system appeared O.K. and have shutdown/restarted several times without issue. Yesterday, the computer shut down inadvertently, then at boot i get this...
Installation & Setup
Boot selection failed because a required device is inaccessible
right, i've noticed another thread with the similar problem, here, and apparently it's fixed, but as i'm running my system on a laptop, i'm wondering what i can do to recover my system without any data loss. error message's more or less the same, "Windows failed to start. A recent hardware or...
General Discussion


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 04:18.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App