Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: 64bit install fails with "Windows could not configure one or more.....

11 Jul 2012   #1

Windows 7 Home Premium 64bit
64bit install fails with "Windows could not configure one or more.....

I am performing a clean install of Windows 7 64bit Home Premium with SP1 integrated on a Dell Studio XPS 8100, and after the first reboot during installation, I get a message "Windows could not configure one or more system components. Windows installation cannot proceed. To install Windows, click "OK" to restart the computer, and then restart the installation."
This is a 64 bit machine. Was running Windows 7 64bit Ultimate until yesterday. Tried partitioning/cleaning/wiping the drives in so many ways I couldn't even count, including "clean all" from repair disk, booting to ubuntu live cd and making sure no rogue filesystems/partitions exist, letting windows installer create partitions, precreating the partitions in diskpart/ubuntu. Have tried several iso's and several cd's/usb drives. Messed with some bios settings, but to no avail, and made sure my bios was up to date. Downloaded drivers from dell and loaded chipset drivers pre-installation just in case. Have removed all extraneous devices from system excepting the keyboard, mouse, HD, CD-drive, and video card. I am at my wit's end!!

Here's the really weird part that may help narrow down the issue. The 32bit version of Windows 7 Home Premium installed completely fine, with no issues whatsoever, even without pre-loading the chipset drivers.

If anyone could throw me a few suggestions, I would really appreciate it. This was meant to be a quick refresh of my system and is now turning into a nightmare.

System Specs
i7 870k
8GB 1333-MHz DDR3
Intel H57 Chipset
Two regular old 7200 Western Digital drives
GH50N CD-DVD Drive
GTX 560ti
let me know if I should be more specific or any other details needed.

My System SpecsSystem Spec
12 Jul 2012   #2
Microsoft MVP


Where did you get Win7? Did you burn the DVD yourself? Download the latest official ISO and burn to DVD or write to flash stick using Steps 1 and 2 in Clean Reinstall - Factory OEM Windows 7. Follow these steps closely to get a perfect reinstall.

If one method fails, try the other installer method.

Next remove all but 2gb RAM to try install. Test your RAM - Test with Memtest86+ for 5-6 passes or overnight, swap RAM sticks, check for debris in slots.

Unplug all other HD's and peripherals, reset BIOS to defaults, while in BIOS look for EFI Boot Disk in BIOS Boot order and remove it. Set SATA controller to AHCI to try install.
My System SpecsSystem Spec
12 Jul 2012   #3

Windows 7 Home Premium 64bit

Iso's were from digitalriver. Burned the DVD's myself using both Windows tool and poweriso. Created usb drives myself using Windows tool and unetbootin. Tried with 2gb RAM. Reseated RAM. Switched RAM out. Cleaned RAM with eraser. Checked slots for debris.

Ended up getting frustrated, so the next time the computer booted, I tried a random thing from my googling.

I let the install try to finalize, let the error message pop up, pressed shift+f10. This brought me to a command prompt, where I typed:

cd oobe


This somehow allowed the install to finalize, but I did not click anything on the error message, simply moved it out of the way. Went through the install, computer rebooted a bunch and it seemed bad but then it came up fine. Installed drivers but Windows was only using 2gb of 8gb of RAM. It actually read 8gb installed, 2gb usable.

Then I went to sleep.
Woke up to a perfect Memtest 86+.

Installed some Windows updates then decided to reseat RAM and CPU, and reset CMOS. Now everytime I boot the computer, my CPU fan goes crazy fast during the initial Windows loading animation, and the computer shuts down.
My System SpecsSystem Spec

12 Jul 2012   #4

MS Windows 7 Ultimate SP1 64-bit

Follow this procedure perfectly:

Clean Reinstall - Factory OEM Windows 7

Since you played around with ubuntu, unetbooin then a Diskpart CLEAN (and use no other program for this purpose) is a necessity.

If you want to put the ISO on to a USB, then:
Prepare the USB stick.
Use 7-Zip to extract the iso to the usb.
(or you can put the iso on to a DVD and then copy it over to the stick)

This is the only way I've ever done this and durn it, the procedure works every time!


Run CMD.EXE as administrator
WIN | type CMD.EXE | do NOT hit ENTER | CTRL + SHIFT + ENTER key combo |
ALT + y key combo

WIN=key with Microsoft logo on top

Type following commands and hit ENTER key after each command.
DISKPART starts the DiskPart program
LIST DISK shows numeral assigned to disks
note the numeral assigned to your usb stick
The numeral 2 will be used in this example
DETAIL DISK the info shown will confirm the correctness of your selection
CLEAN ALL the entire usb stick will be overwritten with zeros
This can take awhile if usb stick has large capacity.
Keep the faith-the DiskPart prompt will eventually return.
CREATE PARTITION PRIMARY create a primary partition on the USB stick
FORMAT FS=NTFS format the partition
ACTIVE the partition can contain operating system startup files
ASSIGN the next available letter is assigned to the USB stick
EXIT exit from the DISKPART program
EXIT exit from the command shell


Notice that you want to use CLEAN ALL on the usb stick.
Why? Because this way any bad sectors will be so marked and will not be used.



1. Prepare UFD (USB Flash Drive)
2. Burn the ISO file to DVD by right-clicking on a ISO file and choosing Burn disc image or by using ImgBurn free iso image burner
3. Copy DVD to UFD (USB Flash Drive)


1. Prepare UFD (USB Flash Drive)
2. Extract the ISO file to the UFD using 7-Zip
7-zip archiver pack-unpack wim,zip,tar,gzip,bzip2,xz,7z unpackonly arj,cab,chm,cpio,craffx,deb,dmg,fat,hfs,ISO,LZH,LZMA,MBR,MSI,NSIS,NTFS,RAR,RPM,UDF,VHD

My System SpecsSystem Spec
24 Aug 2017   #5

windows 7 pro x64

i have exactly the same problem with my intel core i3 1st gen desktop. 8gb kingston ram. msi450 gts grphics card. intel 55pj motherboard. i was restoring a windoos image (3years old). the system.restored but after that pc was restarting at logon screen. now i cant install 64 bit windows. tried 7, 8.1, 10. but win 7 32 works fine. some times pc goes into a state that when i turn it on processor fan goes mad and pc restarts in lool. but that thing ends after messing with the hardware a little like rams. removing cables etc.
as far as my experience is. i think this is a problem in the motherboard and smwhere near the processor.
if any1 can help let me know.
My System SpecsSystem Spec

 64bit install fails with "Windows could not configure one or more.....

Thread Tools

Similar help and support threads
Thread Forum
Error during install - "windows could not configure one or more..."
Hi All, I'm hoping someone can help me diagnose what is causing this error during install - "windows could not configure one or more system components". I go through the setup process and everything seems to be going normally, then the system reboots and comes back to the last stage of the setup...
Installation & Setup
Service Pack 1 fails to configure/install
1. System Update Readiness tool runs to completion. 2. SFC scan detects errors but cannot fix them. 3. The SP1 update (KB976932) has failed (and succeeded once) with several error codes: 1/16/2013 - Code 8024000B - Installation status: Cancelled 9/7/2013 - Installation...
Windows Updates & Activation
Windows Update Readiness Tool Literally "Fails" to install
To be honest, I just downloaded Windows Update Readiness Tool because my "Turn Windows Feature On or Off" shows up blank every time I open it just like the picture attached. So, I researched that the way to fix it is by installing Windows Update Readiness Tool, and so, I did. But, when I try to...
Installation & Setup
Canon LiDE 600F scanner fails to install on Windows 7 64bit
Hi My Canon LiDE 600F scanner is failing to install on Windows 7 (64bit) (version 6.1 build 7600). This scanner works fine on WindowsXP, however. I spoke Canon about this and they obviously get this complaint all the time and they say that their drivers (which they have failed to up...
KB958559 fails to configure in Windows 7
Hello, I am running Windows 7 Professional 64-bit edition on a brand-new Dell Inspiron. I have an AMD that is capable and set for virtualization. I have 6GB of RAM, and when I say the computer is "brand-new" I mean it - I just unboxed one week ago tomorrow! I have installed all Windows...

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 01:41.
Twitter Facebook