Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: appropriate permission to access

18 Jul 2012   #1

Microsoft Windows 7 Professional 64-bit Service Pack 1
appropriate permission to access

In the attempt to run the setup of a program I get this:

“Windows cannot access the specified device, path, or file. You may not have the appropriate permission to access the item.”

I am the administrator. Usually, by right clicking the mouse, and selecting run as administrator, this does the job. Did not work this time. How do I solve this?

Suggestions on how to get around this?

Win7 Pro SP1 64bit

My System SpecsSystem Spec
18 Jul 2012   #2

Windows 10 Pro X64

What program are you trying to install? Does it tell you what device/path/file is causing the problem?
My System SpecsSystem Spec
21 Jul 2012   #3

Microsoft Windows 7 Professional 64-bit Service Pack 1

Thanks for the reply but I found the problem.

I set up a second account to log in as the Admin. There was only one line in the "environment variables".

Under User Accounts, Change my environment variables, my listing had two Temp Variables.

I have no idea what the section is all about but I took a chance and removed the second one.

After that, no problems, and I was able to install the program that gave me that message in the first place.
My System SpecsSystem Spec

22 Jul 2012   #4

Microsoft Windows 7 Professional 64-bit Service Pack 1

Well, here I am call solution did not work. Did fix what I had removed since it did seem to work. Did read where I should leave those TMP and TMP as they were.

Again I am trying to run a program that I downloaded from the web and up came that same message as before.
My System SpecsSystem Spec
22 Jul 2012   #5

Windows 10 Pro X64

Okay, can you please answer my question then?

Also, open a Elevated Command Prompt, then type set > EnvironmentVariables.txt and press Enter.
Type notepad EnvironmentVariables.txt and press Enter.
A Notepad window will open.Copy and paste the data there into your reply. That will be the complete set of Environment variables.
My System SpecsSystem Spec
23 Jul 2012   #6

Microsoft Windows 7 Professional 64-bit Service Pack 1

Is this the correct txt that you were looking to see?

C:\Windows\System32>set> EnvironmentVariables.txt
AMDAPPSDKROOT=C:\Program Files (x86)\AMD APP\
CommonProgramFiles=C:\Program Files (x86)\Common Files
CommonProgramFiles(x86)=C:\Program Files (x86)\Common Files
CommonProgramW6432=C:\Program Files\Common Files
Path=C:\Program Files (x86)\AMD APP\bin\x86_64;C:\Program Files (x86)\AMD APP\bin\x86;C:\Program Files\Common Files\Microsoft Shared\Windows Live;C:\Program Files (x86)\Common Files\Microsoft Shared\Windows Live;C:\Program Files (x86)\PC Connectivity Solution\;C:\Windows\system32;C:\Windows;C:\Windows\System32\Wbem;C:\Windows\System32\WindowsPowerSh ell\v1.0\;C:\Program Files (x86)\ATI Technologies\ATI.ACE\Core-Static;C:\Program Files (x86)\Common Files\Acronis\SnapAPI\;C:\Program Files (x86)\Common Files\Intuit\QBPOSSDKRuntime;C:\Program Files (x86)\Windows Live\Shared;C:\Windows\system32\wbem;C:\5UTL_Hardware\BlueTooth_Bluesoleil\Mobile;C:\2DB\Calibre\
PROCESSOR_IDENTIFIER=Intel64 Family 6 Model 26 Stepping 5, GenuineIntel
ProgramFiles=C:\Program Files (x86)
ProgramFiles(x86)=C:\Program Files (x86)
ProgramW6432=C:\Program Files
My System SpecsSystem Spec
23 Jul 2012   #7

Windows 10 Pro X64


Looks to me like you may have some kind of malware, or is your user account name actually kjhfksdjlhflskdjfhsl????

What anti-virus software do you have? Run a full scan.
Also download and run Malware Bytes Anti Malware Free and do a Full scan.
My System SpecsSystem Spec
23 Jul 2012   #8

Microsoft Windows 7 Professional 64-bit Service Pack 1

Well, that is a strange story. For what ever the reason, when the machine was setup prior to sending it to me, the owner had that strange name. I did find a way to make a change but it was a partial solution. So I have to users with names including that one. I just can not find a way to get rid of is a pane.

I thought before that my solution was it, but it was not. Strangely, after it happened a second time, again later in the day, I tried to run that new program again and it work again.

Why would it give that strange message in the am while in the pm it does not happen?
My System SpecsSystem Spec
23 Jul 2012   #9

Windows 10 Pro X64

I don't know why it seems to have morning sickness (sort of like my wife had when she was pregnant ).

As for the weird account name. The only way to get rid of it is to create a new account using Control Panel / User Accounts. This is one easy (sort of) way to do it.

You can use the Windows Easy Transfer to transfer your profiles and settings to a new account:
  1. Go to Start type Easy Transfer Click Windows Easy Transfer in the search results.
  2. You will get a welcome message to Windows Easy Transfer. Click Next.
  3. Choose a different partition or internal hard drive, external hard disk or USB flash drive. Can't be the same drive you are transferring from (the "old computer").
  4. Select This is my old computer.
  5. Check the box before your current user account, and click Next.
  6. You can input a password if you want.
  7. Click Save to save the transfer file. The transfer file will be a single file with the extension .MIG. Please remember the location.
  8. Create a new account via Control Panel - User Accounts.
  9. Log off the current account and log on the new account.
  10. Open Windows Easy transfer again and click This is my New Computer.
  11. Choose "Yes, open the file" to navigate to the .MIG file.
  12. Check the box before your old account, then click the Advanced Options above the Transfer button, then you choose which user account you want to transfer.
  13. Click Save and Transfer. Now, you can see what are the files that were transferred.
Test if everything works correctly in the new account now. If yes you can delete the old account via User Accounts.

If not, please delete the new account via User Accounts. Go back to step 8, and repeat the step 9 and 10, then check the box before your old account, and click on the Customize button next to this old account, and uncheck the box before Windows Settings, then click the Transfer button.
My System SpecsSystem Spec
24 Jul 2012   #10

Microsoft Windows 7 Professional 64-bit Service Pack 1

I use Kapersky Pure 2.0 and I am a subscriber to Malwarebytes Anti-Malware which also begins a boot up.

I think I will just live with the strange name since it really does not present a problem for me.
My System SpecsSystem Spec

 appropriate permission to access

Thread Tools

Similar help and support threads
Thread Forum
You don't currently have permission to access this fold
Hey Everyone I recently just did a complete new install from Windows 7 7227 to Windows 7 7600 RTM. The issue is I have 2 HD's installed on My Computer. One is System (for my OS) and one is Logical (for my stuff). Before I did a complete install and was running on Windows 7 7227, I had My...
Installation & Setup
Don't have permission to access folder - yet again
Hi folks, First, yes I have searched the forum and looked at other threads with the same error message but haven't found anything that helps. If I've missed something relevant please let me know. System Acer Aspire all in one Win 7 Home premium 64 bit SP1 Problem description. I am...
General Discussion
you don't currently have permission to access this folder
Hello, I am on my Laptop, i have 3.5 IDE Hard Disk which is quiet few years old, my some Pictures and data is stored on it, now i am looking for few pictures of mine, and few notepads, i try to connect it on my laptop by using 3.5 hard drive ide enclosure caddy. problem is i keep getting ''you...
General Discussion
I don't have permission to access my C drive!
On my new win7 home 64bit system I wanted to share my drives so that it would work with my other winxp computer as well so I used the trick of assigning permission to "Everyone" on all my drives. This worked great (better than the homegroup). However today I decided it wasn't a great idea to share...
Network & Sharing
Windows can't access file. May not have permission to access.
Hello, I am attempting to access an application.exe file on my desktop. Each time that I click on it the Windows message, "Windows cannot access the specified device, path, or file. You may not have the appropriate permissions to access the item." pops up. I am the system administrator so this...
General Discussion
Can't access printer/ no permission
I have tried to follow the steps to take ownership of the printer but when I right click on properties the only tabs are 'General' and 'Hardware'-- no 'Security' tab. So, I can't follow the rest of the steps. How do I find the printer through Windows Explorer? I am the only user on my computer...
Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 07:42.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App