Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: difficulty installing win7 64bit via USB key

31 Jul 2012   #11

Windows 7 x64

If the OP's problems involved UEFI, a configuration error would have been generated when trying to set up a drive. He also tried both versions.

Since it was not, I must assume the problem is a hardware one. UEFI is only the bios, not the OS. If it loads all the files, but is not able to start Windows, perhaps running the Windows 7 compatibility checker might help.

Again gregrocker, a system defaults to a particular boot version. All of mine default to a MBR install. The Install will take care of whether the drive is configured as GPT or MBR. But, of course, there are situations that might alter the normal install.

My System SpecsSystem Spec
01 Aug 2012   #12

Windows 7 x64

If you have the 32 bit version of Windows 7 available, you might try that. It would help with possible driver problems, media, and any UEFI involvement since the 32 bit version does not have UEFI capability.
My System SpecsSystem Spec
01 Aug 2012   #13

windows 7 64 bit

Thanks to you both for your comments. I have tried everything you all suggested but to no avail. I have tried both within the UEF Interface and in legacy Bios but it won't insall past the message "Starting Windows". There is just one more thing to try before I move on to something else. In Step 1 of the tutorial called "How to Install Windows 7 Using UEFI" there is a comment about putting the directory of the file cdboot.efi at the Shell Dos prompt. Can anyone tell me how to put this in please. I can easily get to the Shell prompt via the boot priority of "Launch from EFI shell" but I don't know the command lines to enter to tell it to search for the *.efi file .

If that doesn't work then I have come to the conclusion the problem does not lie within UEFI. I have also tried all sorts of combinations of hardware and put the components in other computers to prove they work so I am thinking it must be either a faulty Installation disc or a faulty mainboard or CPU. If I have to start down this path I will start with the cheapest component first and that is the installation disc.

If someone can give me some clues on the command to put in at the Shell prompt I would be eternally grateful.

My System SpecsSystem Spec

01 Aug 2012   #14

Windows 7 Ultimate x64 SP1

Check out the link in my signature for instructions on how to install Windows under EFI.
My System SpecsSystem Spec
01 Aug 2012   #15


If you are installing in Legacy mode with no EFI Boot Disk in the BIOS boot order, but instead have the DVD/USB or HD drive set first to boot, then we can help you troubleshoot the install normally.

Try wiping the HD with Diskpart Clean Command
from Win7 installer command line in System Recovery Options

Just to make sure follow the Clean command with the command Convert MBR, then Exit. Then try install.

If it fails define an NTFS Primary partition marked Active using Step 2.2. in SSD - HDD Optimize for Windows Reinstallation

Check in BIOS for SATA controller setting. Try AHCI first, then IDE mode.

Remove all but 2gb RAM to try install.

Report back results for more steps if necessary.
My System SpecsSystem Spec
01 Aug 2012   #16

Windows 7 x64

Quote   Quote: Originally Posted by valjo View Post
Can anyone tell me how to put this in please. I can easily get to the Shell prompt via the boot priority of "Launch from EFI shell" but I don't know the command lines to enter to tell it to search for the *.efi file .
I am really surprised you are talking about the EFI shell. So you must be using something like shellx64.efi?

I have been running a UEFI system for 2 years, numerous installs and never had a need to us that, which I can launch from the bios.

The questions you are asking, along with the results you were getting earlier, make me think you are not using a normal Windows 7 install DVD... Can you tell us?

I can't look right now, but what chipset are you using?
My System SpecsSystem Spec
02 Aug 2012   #17

Windows 7 x64

Quote   Quote: Originally Posted by valjo View Post
I tried the following -

5. Finally I tried installing the OS from the USB key (with UEFI). I got the DOS type screen with the "Shell" prompt.
I have been doing some research and thought this would be a good place to mention, making a bootable Flash Drive using the normal tutorial is not enough to be able to boot to the UEFI version. Even the Microsoft Windows 7 USB/DVD download tool will not make the flash drive UEFI bootable.

First, make sure you format the flash drive as FAT32, NTFS will not work.

Then you need two extra steps to get it to boot UEFI. One is create a folder named boot in the efi folder, so it will be efi\boot, then put a file called bootx64.efi in that folder.

To get the bootx64.efi file, you need to rename bootmgfw.efi to bootx64.efi.

You can get bootmgfw.efi from a normal Windows 7 x64 install from the Windows\boot\efi folder. Or you can use 7-zip to extract it from your flash drive in the sources\install.wim\1\Windows\Boot\EFI folder
My System SpecsSystem Spec
02 Aug 2012   #18

windows 7 64 bit

Thanks for that. Some one else said the exact same thing a few hours ago and I am in the middle of that right now. When I originally generated the flash boot drive I used NTFS and did not generate the extra directories. I guess that is why it did not work. I will let you know how it goes.

Some one else also asked for my system details. I posted these when I registered with the forum. Look there and you should find. If you can't open that let me know and I will be happy to re-list the details for you. He also asked if I have a genuine Microsoft DVD or something else. I have always purchased genuine Microsoft CDs and DVDs and this one is no exception.

My System SpecsSystem Spec
02 Aug 2012   #19

Windows 7 x64

I hope we can get this thing working. But even though your install media is genuine, there still be some type of error with it. A scratch or fault in manufacturing can do strange things.

You comment earlier about "Shell" after trying to boot to the UEFI flash drive confused me. I was thinking UEFI shell...
My System SpecsSystem Spec
02 Aug 2012   #20

windows 7 64 bit

Well I went through the process as suggested above and it at least got me to the same location that the DVD got me i.e. the screen that says "Starting Windows" and just before the 4 colors appear as a windows logo. To me it seems that, if there is a scratch or some fault on the DVD then that same fault has been transferred to the USB drive.

I think I will now buy another copy of the Microsoft Win 7 DVD. That is the cheapest of all options at this time. Hopefully I will hit the problem first up. Purchasing another copy of Win 7 in this part of the world can be a time consuming process. I have to order it from interstate. When it arrives next week I will come back to you to tell you if it solved the problem.
My System SpecsSystem Spec

 difficulty installing win7 64bit via USB key

Thread Tools

Similar help and support threads
Thread Forum
driverless USB keyboard having difficulty in installing.
I have an A4tech USB KL(S)-40 keyboard which does not require any driver in order to function. However, my windows say that no driver found and therefore it will not be HID compliant keyboard. Because it is not HID compliant, software needed for the keyboard to function cannot be installed.... What...
Hardware & Devices
Having difficulty installing network printer
Ok, downstairs I have a desktop computer with XP Home. There is an old (but works GREAT) Epson Color Stylus printer connected to the parallel port. I also have a Canon Pixma ip4000 connected to the USB port. Upstairs I have 2 XP Home laptops. They connect fine to my network and access share files...
Hardware & Devices
Win7 64bit SP1 not installing
i'm getting the error while trying to update to service pack1: ERROR_MOD_NOT_FOUND(0x8007007e) tried to download the SP1 and then install it, the same error. as suggested by MS tried with my Kaspersky off with no luck, too. Disconnected all cameras and printers - the same error... could...
Windows Updates & Activation
Difficulty installing Office 2010 64-bit
Hi, I have a 64-bit Toshiba laptop with Windows 7 64-bit installed on it. I want to reinstall Office 2010 (Home & Business) in 64-bit mode instead of 32-but mode that it automatically installed in. I bought a Product Key code for Office 2010 with the new Laptop, which I bought about a month...
Microsoft Office
Difficulty installing programs
Ok I am having a hard time installing programs where both users can see them. everytime I DL google chrome it automatically installs it to my users files instead of askign where i want to install it. How do i change it so when I run .exe files it asks where I want to save it?
General Discussion
Installing programs on 64bit win7
I installed win7 64bit but i'm noticing everytime I install any software including software that uses 64bit it's installing under the x86 folder... why the heck is this? like my adobe suite went there.. and when i open my process manager they all say *32 by them.. how can i move them to reach their...

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 20:53.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App