Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Laptop stuck on acer software installation after system restore

27 Aug 2012   #1

windows 7 home 64bit
Laptop stuck on acer software installation after system restore

Ok, so earlier today i decided that i needed to restore my laptop to factory default. As you can see from the title, i use an acer laptop which means i used the acer Erecovery software. All went well at first, although it took a stangely long time at a screen which said "setup is starting." The problem now is, I am now stuck on the acer 'software installation screen!' It is stuck at 41/48 where it is trying to install v1.0. I think i heard the sound of an error earlier which worries me as i dont want to force restart my laptop as it clearly says not to do that and doing this caused my hard-drive to break last time!
I have been on this screen for about 2 hours now, and will leave it overnight if i have to. I just need to know what to do if it does not fix!

My System SpecsSystem Spec
27 Aug 2012   #2

Microsoft Community Contributor Award Recipient

Windows 7 Home Premium SP1, 64-bit

Have you categorically rejected the idea of doing a clean install, as opposed to a recovery to factory specs via the Acer software?

Acer software and support being what it is, I'm not surprised by your predicament and don't have a solution to that other than to wait as long as you can stand to see if it sobers up.
My System SpecsSystem Spec
27 Aug 2012   #3


It's only remaining steps are to install the factory bloatware which most tech enthusiasts avoid by doing a Clean Reinstall - Factory OEM Windows 7. This is a vastly superior install which actually allows the user to enjoy native Win7 performance, which a factory install like Acer's doesn't come close to.

You can try running Recovery again from its hotkey at boot, or using the Recovery Disks you should have made as a backup. If you did not then these can sometimes be ordered from Acer. When running them it may be necessary to first wipe the HD with Diskpart Clean Command to clear old boot code and the partition table to allow Recovery to proceed. Since you need the Win7 disk or Repair CD Command Line to wipe the disk you might as well do the Clean Reinstall.

Acer Support: Frequently Asked Questions list for Recovery media and Restoring a system to factory load
My System SpecsSystem Spec

28 Aug 2012   #4

windows 7 home 64bit

Well.., After trying greg's suggestion my laptop kept going back to the same screen every time I turned off! I tried doing recovery again and now my laptop is unusable! It says something about a driver fault and I need to reinstall windows ( which I dont have the disk for.)
My System SpecsSystem Spec
28 Aug 2012   #5


This is why you needed to make the Acer Recovery disks when you set up your PC, so you'd have a backup method in case Recovery fails which it can do.

Your options now are to call Acer Tech Support to order the Recovery disks, or to follow the steps in this tutorial to Clean Reinstall - Factory OEM Windows 7. Everything you need is in the link to get a superior install without the factory bloatware and duplicate utilities.

You would already know that the latest Win7 installer is provided if you'd even bothered to read the tutorial, so you need to decide now if you're going to be thorough to get the best possible install, asking back all the questions needed to get it done right. If not then order your Recovery disks or take it to a shop.
My System SpecsSystem Spec
01 Nov 2014   #6

Windows 7 64bit & 32bit, Home, Pro, Ultimate
Acer restore hanging at Office 2010 install

The simple solution to this is:
use a boot disk (win 7 or other) that you can access the hard drive partitions with
Boot to this disk and Delete the 100mb system boot partition
Reboot the computer and hit Alt>F10
Restore to factory settings, system will now load properly. Not sure what the issue with the boot partition is but this resolves and allows the restore to function properly.

Saw this solution posted on-line under other forums, decided to post it here. It worked for me just fine.
My System SpecsSystem Spec
12 Nov 2014   #7

Windows 7 x64

There is an even easier solution, hold down Alt and press the Home key, there will be a box behind the installation page that needs your attention, had this twice yesterday on a recovery i was doing.
My System SpecsSystem Spec
12 Nov 2014   #8

Windows 8.1 Pro 64-bit

Quote   Quote: Originally Posted by jcjsmc View Post
There is an even easier solution, hold down Alt and press the Home key, there will be a box behind the installation page that needs your attention, had this twice yesterday on a recovery i was doing.
Awesome, I hit it and at first this did nothing. I know this thread is old, but I really, really thank you for posting this here also, so that people like me searching through google can find it quickly. (for what I Googled, this thread of one of the first results, if not the very first.)

Since it didn't work at first, I literally just started tapping the buttons and then I saw the box behind the installation. I clicked something (damn me for not paying more attention) and after the reboot the Software installation came up (stuck on Installing Office 2010... 35/48) It's been there for a couple days now. *facepalm* I thought this would have fixed it but it hadn't seemed so yet. I'm going to try it again. Because the odd thing was that it took me through the OOBE setup... but then popped up the acer software install again. It doesnt stop, and the prompt doesnt come up anymore.

Still looking for a solution...

Edit: I was skeptical at fist, and with good reason, to try the other solution posted to delete the 100mb partition. I did this, and now when I try to enter recovery I get this message "Restored failed - Error code=0x0 (WIMAppleImage cannot apply image : The operation completed successfully)

Wait what? It completely successfully? *Click OK*

System Recovery Options:
The tool failed to run. Try choosing another tool. *Click OK*

This failed. I restored the partition with a partition recovery tool. Thankfully, I already have a bit of knowledge with Windows and a few other helpful tools. Attempting the restore one more time before doing a clean install.

I do not like the other guys attitude, surprising he is still around here. Forcing a clean install down everything's throat isnt the solution to everything. Currently, I'm working on this laptop for a customer who is NOT computer savvy, and the customer would prefer all the bloatware to be on the PC (crazy I know, but it's their request) It's not my job to educate people, but my job to service their PCs. And once in awhile I come across a strange problem I cant fix I come to these threads looking for a solution. A clean install isnt really a solution, it's a shortcut around the problem, sure... but not always everyone's preference. Yes, I will whine and whine and whine.

Thanks to the other two guys for posting what they thought was a solution, but it didnt work for me this time. If trying the factory restore again doesnt work, I'll post the solution I've found here.
My System SpecsSystem Spec
20 Nov 2014   #9

Windows 7 64bit & 32bit, Home, Pro, Ultimate
Acer restore hanging at Office 2010 install

jcjsmc - Yeah I saw the window, but couldn't keep it active long enough to complete it. Glad you were able to find an easier method. I even did an MSconfig and stopped the program installer from running so I could complete the OOBE and then msconfig to start normal but the install still hung at the Office install. Weird ~ I know.

Even more interesting - after getting everything to install fine, load anti-virus, copy user data back etc. I decided to open that Acer program installer and use it to install a few of the programs that it didn't install, (and hopefully uninstall the ones I didn't want), it started a complete install of all of the programs and once again hung at the Office install. This time there were no windows hidden behind the installer. Not real happy with this Acer program. I was able to finally get the installer stopped and make it quit trying again after every reboot. Handled my installs/uninstalls through Control Panel. Avoid that Acer program if possible just to avoid the irritations.

Trillionsin - Sorry you had trouble getting the restore to function after deleting the 100mb partition. I had no trouble at all getting the restore to function. You could have even deleted the primary partition since the restore is working off the "hidden" D: partition. The restore doesn't care if the partitions are there or not, as long as it has space to create them and restore the image. That's why I was confused as to why the 100mb boot partition was able to fix it. Only surmising that something got written to it that initiated the Acer program install function. I didn't go and detail inspect that as I didn't have time to. Just guessing. I do an extensive amount of system/partition imaging and restoring so I'm well versed in numerous programs as well as the "nuts-and-bolts" of how imaging works. That boot partition for Win7 and above is essentially the "boot.ini" of 2000/XP. Providing more room for more booting options etc. Most programs shouldn't be writing info there, however it is possible to put script there to initiate specific .exe's.
Anyway I digress, again I'm sorry you had trouble getting to the restore after deleting the boot partition. I didn't anticipate that, only posted the info as it worked for me with nothing indicating other potential failures. Here's hoping you were able to resolve the issue. (I'm hoping it wasn't my attitude that you were having issue with).
If you're still having trouble, post here and I'll help anyway I can if you're interested in my help.

My System SpecsSystem Spec
20 Nov 2014   #10


Over a million consumers have used Clean Reinstall Windows 7 without a single complaint, one of the most viewed and used Help tutorials on the web. I also wrote others like Troubleshooting Windows 7 Failure to Start and the basic Troubleshooting Steps for Windows 7 which comb the OS to solve almost any problem. Then there is Troubleshoot Windows 7 Installation Failures which resolves any install problem. These are all based on tens of thousands of consumers I've helped here for 5 1/2 years, 8-10 hours per day volunteer time without missing a single day since Win7 beta.

So how is it surprising that I am still here, and where am I trying to cram a Clean Reinstall down anyone's throat - when I also provide help to do the inferior Factory install to anyone who asks, even pioneering a way to Boot Recovery Partition using EasyBCD?

If you work in a shop you should know that Hirens or Universal Boot disk can boot any bootable partition.
My System SpecsSystem Spec

 Laptop stuck on acer software installation after system restore

Thread Tools

Similar help and support threads
Thread Forum
Stuck in system recovery options after system restore
Hello, As the title says my computer is stuck on the system recovery options. I was having issues the other day with my computer it kept crashing,programs not fully loading and all around slowness. it was fine a few days before so i figured i must of downloaded a virus while looking for a zuma game...
Performance & Maintenance
Acer system restore stuck on black screen with cursor
For the past couple of days I would turn on my computer and only the background and bottom bar would load. Nothing would open, couldn't click on anything, ctr alt delete didn't work. This morning I started it in safe mode with no network and it turned on fine. I turned on again normally and started...
Backup and Restore
Acer Aspire stuck on software installation
My laptop (acer aspire 7750-6423) recently crashed and would no longer load up windows. I couldn't repair or recover anything from the hardrive and had to buy a new one. I went through erecovery and came to software instillations. It was working fine till it got to "installing LITE-ON Camera 1.3M...
Backup and Restore
ACER Aspire System Restore stuck!
My Wife's laptop Acer Aspire One D255 with OS Win 7 Starter, needed to be restored and a clean install, the problem is that when it was first bought no backups were made mainly because it doesn't have a disc drive. I used the Advanced Recovery Method that was pre-installed to ''Return your...
Backup and Restore
System restore saying no OS is installed, system repair stuck in loop
Last night i closed my laptop without shutting it down. I woke up this morning and turned it on and it went to the system repair screen and ran through that. It says there are problems but they are not automatically repairable. I then tried to do the system restore to an earlier point in time...
General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 05:59.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App