Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Hang up at expanding files (various percentages, various error message

11 Sep 2012   #1

Windows 7 Pro x64, Vista home x32, XP Pro x32
Hang up at expanding files (various percentages, various error message

My setup is as follows:
i5 2500k @stock
Asrock z77 extreme 4
MSI 560 ti 448
8 gb ddr3 @1866 (2X4)
120 gb sandisk ultra ssd (windows drive)
1 tb 7.2rpm hd
650 watt seasonic x series psu

It all started a couple of weeks ago, I had switched out my p67 mobo for the new z77 one because the former died on me after 6 months of use. After making sure everything was in working order, I installed everything back into the case.

I had windows 7 pro 64 on my ssd at the time, and when I tried to start up windows on the new motherboard, a quick bsod would pop up about half a second into load and would never get past that. I figured I'd just do a clean install of windows and that would fix whatever was wrong.

Upon trying to re install, the installation would get hung up at "expanding files (0%)", even after moving ram, changing the ssd and disc drive from a sata3 port to a sata2 port, and various other suggestions I read on the internet.
I tried booting from a thumb drive and had a small amount of success; the installation would hang up at anywhere between 10-40% as apposed to 0.

I am using student upgrade media, which had worked fine for me on the initial install 6 months ago. I've tried re downloading the files, making a new iso and burning at various burn speeds (x8 down to x1), downloading the provided iso from the official microsoft site, and nothing seems to be working.

Last thing I tried was taking everything out except for the mobo, drive, cpu, 1 stick of ram, and the disc drive and still no luck.

Any suggestions? I've tried everything in the stickied thread to no avail, and have tried absolutely everything I can find on the internet relating to this subject. Should I buy the full retail copy or would that leave me in the same situation?

Any help would be greatly appreciated.

My System SpecsSystem Spec
11 Sep 2012   #2


There is no point in buying full retail if you qualify for Student Upgrade as the installers are exactly the same - it's only the key which determines which will activate.

Is your BIOS EFI? If so remove EFI Boot disk from boot order, enable Legacy BIOS and install to wiped MBR disk. Set SATA controller to AHCI first to try install, then IDE mode.

Try wiping the SSD first with Diskpart Clean Command before install.

Will it install to HDD?
My System SpecsSystem Spec
11 Sep 2012   #3

Windows 7 Pro x64, Vista home x32, XP Pro x32

Thanks for the response.

Yeah, I tried installing on the hdd once I got home from work but it didn't really work

I had taken the EFI off the boot order as well, no difference.

After I had tried installing on the hdd I tried installing on the ssd without rebooting and the expanding files had gotten to 13%, which is the furthest it had gotten with the dvd. I don't know if that's just random or if that actually means something...

I'll hooking up the ssd to an older build and wiping it with diskpart when I get home.
My System SpecsSystem Spec

11 Sep 2012   #4


There may also be a Legacy BIOS setting to enable in BIOS setup to disable EFI further. Read your mobo manual on the model's Support Downloads webpage for how to deselect EFI fully.

You can also try installing with EFI to wiped HD which formatted GPT to see what happens: UEFI (Unified Extensible Firmware Interface) - Install Windows 7 with - Windows 7 Forums
My System SpecsSystem Spec

 Hang up at expanding files (various percentages, various error message

Thread Tools

Similar help and support threads
Thread Forum
Help with ArcheAge, Error Message 126, Missing dll files
So for 4 days I've been attempting to run this game. I can download it fine using the Glyph launcher. But when I attempt to play, I get d3dx9_42.dll is missing and then gives me error 126 error loading DLL:CryRenderD3D9dll. Now I'm not exactly computer savvy, but with suggestion of downloading...
Getting Error Message when playing MP4 Files
So today when I log into my computer and then go to my videos library and click play all, I have over 600 video files I get the error message saying No playable file is found and then I do a system restore and then it works fine, what can I do so this will never happen to me again, my default...
Music, Pictures & Video
Expanding Windows Files Error - Former Linux Hard Drive
Hi guys, I need some help. I am trying to load Windows 7 to a brand new HHD, but I am having problems loading Windows 7, as I cannot go beyond the "expanding windows file" step. I will try to be brief with all I have try based on suggestions from other posts, but first my system: Dell Vostro...
Installation & Setup
I cant move files and am getting the following error message...
I can't move files or rename them, and i keep getting the error message "Could not find this item" and "this file is no longer located in..." Tried contacting support but they were no help
General Discussion
Windows 7 Ultimate N x64 Hang Up in Expanding Windows F
Yesterday I finished downloading from MSDN the WIndows 7 Ultimate N x64 to burn the ISO I used imgburn to burn it's ISO and make it bootable. After creating the bootable CD I Install in on my PC and suddenly i encounters some hang-up which is i didn't encounter some of x64 and x86 Win7 OEM...
Installation & Setup
Installing windows 7 error when expanding files
Okay i can get the windows installion all the way to part 2 installing windows where it says expanding files it will get to around the high 80% or 90% complete then i will get an error that says windows cannot access the installion sources verify that the installation sources are accessible, and...
Installation & Setup

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 11:52.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App