Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Infinite Loop during install, but not like others I have read

11 Sep 2012   #1

Windows 7 Home Premium 64 bit
Infinite Loop during install, but not like others I have read

I tried to search through the forums before posting. I've seen similar situations, but not the same as mine. Fortunately, I don't need anything on the HDD, so would be fine with wiping the HDD completely if I could only figure out how.

Here's the situation. I had upgraded from W7 Home Premium 32 bit to 64 bit, but started having driver issues, so I decided to go back to 32 bit. I can't remember where it was in the installation, but it looked like it had hung, so I tried to restart, and now find myself in this predicament:

Upon start-up, I get the "Windows is starting services" screen, and a bit later, I get a window that says "Install Windows X The computer restarted unexpectedly or encountered an unexpected error. Windows installation cannot proceed. To install Windows, click "OK" to restart the installation. OK" If I resart, it obviously goes through the same thing.

The hard part is that even if I change the bios settings or go into the boot menu on startup, I can't get the computer to boot off of the usb drive (there is no optical drive). I'm assuming that this is the case because in a normal installation when the system restarts, it can't just keep booting from the installation media and starting the installation over. In this case, that's what I want it to do, but I can't.

If I try to cycle power to get into the menu that would let me boot in safe mode, I can, but then I just get a message that says installation can not be performed in
safe mode, and I'm back to the loop again.

The bios options are pretty limited - I can change the order of the boot menu, but can't disable the HDD.

Any advice on how to get out of this?

Here's what I know of my system specs:

Dell Vostro V13 laptop
4GB Ram
Bios Version A02

My System SpecsSystem Spec
11 Sep 2012   #2

Windows 7 Pro x64 Windows 10 Pro x64

Has this usb been tested on any other pcs ? How did you prepare it ?
My System SpecsSystem Spec
11 Sep 2012   #3


Download another official Win7 ISO with SP1 and write to flash stick again using the tool given in Steps 1 and 2 of Clean Reinstall - Factory OEM Windows 7, then follow closely the steps in the blue link tutorial to get a perfect reinstall.

If you have Dell then first tap the F12 key at boot to run the onboard hardware diagnostics just to check those out: Dell Diagnostics Utility - How to Run the. If they won't run then you know you can delete that as well as the Recovery partition which also will not run after a Clean Reinstall. So delete all partitions during reinstall and either create and format new ones or click Next to let the installer do it for you.

If there are further problems access a Command Line by pressing Shift + F10 at first screen after booting installer, run Diskpart Clean Command
My System SpecsSystem Spec

12 Sep 2012   #4

Windows 7 Home Premium 64 bit


Thanks for the replies. I created the usb drive manually (using dispart, copying the boot sector and then copying the files from a CD image). It tested fine on another laptop. I also ran the diagnostics and it turned up no issues.

I successfully started the fresh instiallation now. Inside the bios where you do the boot preferences, there was a little plus sign next to the USB option. When I expanded it, there were two items below - one was a generic USB hub, and the other had the name of my USB drive. The generic USB hub was above the named USB drive. I switched the order, and it seemed to work. I'm not sure what the computer was trying to do before, but I suspect that was what was causing it to not boot through USB.

One other question - I had some warranty repair done on my laptop, and the bottom of the laptop where the COA was located was replaced. Is that stored in the reserved portion of the HDD or somewhere else that I can get it to enter for the install?

Thank you for the help!
My System SpecsSystem Spec
12 Sep 2012   #5


Did you look under the battery where Dell often puts sticker? If not you 'll need to contact them.

As I stated earlier the only way to recover without COA sticker is to use Dell Reinstallation DVD.

If you have a backup image of your installation there is also a way to backup the SLP activation file to reinstall afterwards but it is not supported by these forums so you'd have to research that on your own.

If you still have your Recovery partition onboard you might be able restore it to run at boot: Dell Recovery Partition - restoring F8 link
My System SpecsSystem Spec

 Infinite Loop during install, but not like others I have read

Thread Tools

Similar help and support threads
Thread Forum
Infinite 4 Flashing Screens Loop During Windows 7 Install.
Hey Everyone, I built my first ever CPU this past December and I am now running into an issue trying to install Windows 7 Professional 64 bit OEM. I have tried looking up this issue with no luck of finding anyone running into the same problem I have encountered. I am not entirely sure of what...
Installation & Setup
Windows update infinite loop trying to install win7sp1
This morning my plan was to finally get the upgrade to win7 sp1 on my system. I've tried in the past, but also failed. When i try to start the sp1 update (downloaded manually b/c windows update doesn't show the update), it instantly stops because it is unable to determine my windows version. ...
Windows Updates & Activation
Front Page 2003 Infinite Install Loop
I have just installed Front Page 2003 on my Win 7 Home Premium 64-bit computer, and it keeps wanting to install the program over and over again. I keep getting the message: "Please Wait While Windows Configures Microsoft Office Front Page 2003... Gathering required information..." Does anyone have...
Microsoft Office
*HELP* win 7 crashed during install now stuck in infinite loop
I was trying to reinstall window 7 on my laptop i couldnt factory reboot it so i was installing it with a window's 7 set I had on my laptop but it crashed part way through and no its stuck in an infinite loop and it comes up the error of "the computer restarted unexpectedly or encountered an...
Installation & Setup
infinite loop, cannot install, Radeon X1050
Hi all, I have attempted to do a clean install of Win 7. When it gets to the point to restart for first use, I get the BSoD and "The device driver got stuck in an infinite loop". The machine just keeps rebooting itself, getting the same message, then repeating over and over. I tried booting...

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 02:17.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App