Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: New System not Detecting HDD to Install Windows 7

12 Sep 2012   #1

Windows 7 ultimate 64
New System not Detecting HDD to Install Windows 7

  • i5 3750k
  • Asrock z77 extreme4
  • 8 gigs ddr3 ripjaw gskill
  • nvidia gtx 260
  • Antec 650w
  • Windows 7 64 bit
  • Hard drives attempting to use for new install: Western Digital X2, Seagate

Problem I am having is hard drives I plug into the Asrock z77 are not showing up in Windows 7 install. When I first unpackaged the computer, I attempted to use an old Western Digital hard drive from my previous Q9550/EVGA 780i system. I was unaware that hard drives from another chip set install probably wont boot into windows. So I foolishly I attempted to boot into windows right after I assembled the new i5 computer with a old hard drive from a Q9550 system. Not sure if this might be part of the problem, but I figured I would mention it.

The hard drive showed up in BIOS but did not show up "Where do you want to install windows". Neither did my other hard drives ( another Western Digital & Seagate). However, if I take any of these hard drives and put them back into my old Q9550/EVGA 780i and put in the Windows 7 install CD, they will show up in the box of drives available. In other words, all hard drives are showing up to install windows 7 on in my old q9550/evga 780i system, but none of the drives are showing up in my new Asrockz77.

Hard drive showing up in Asrock Z77 bios:

When I try to install windows 7 to a hard drive it does not show up

Here is the SAME hard drive put back into my old q9550/evga 780i system. It shows up.

All hard drives show up in the q9550/evga 780i, none of them show up in the Asrock z77

  • Changing sata cables in case ones I were using were faulty.
  • Trying different sata ports
  • Upgraded to latest Board BIOS
  • One stick of RAM at a time
  • Diskpart: tried disk part command, then disk list and it displays "no fixed disk to show"
  • Different storage modes: AHCI

I am insuring that only a single HDD and CD are plugged into the sata ports at a time. They are both plugged into Intel sata controller ports, not the Asmedia ones as confirmed by this screen shot and video. ASRock Z77 Extreme4 Review [HD] - YouTube

Never encountered an issue like this before and its really pulling my hair out.Thanks in advance

My System SpecsSystem Spec
12 Sep 2012   #2

Windows 7 ultimate 64

Also important UPDATE: I read trying different storage modes might fix the problem. And it worked, sort of. For whatever reason the drives will not display with AHCI storage mode; however, they WILL display when I switch to IDE storage mode.

The problem I have now with IDE storage mode, is everything is going at an incredibly slow speed. It literally took 30 minutes at the "setting up files" blue screen that comes after the windows logo when the win 7 install CD boots.

Perhaps my drives are not AHCI compatible? They are older Sata2 drives.

here is one of the drives I am using:
Seagate Barracuda 7200.11 ST3500320AS 500GB 7200 RPM 32MB Cache SATA 3.0Gb/s 3.5" Internal Hard Drive -Bare Drive
My System SpecsSystem Spec
12 Sep 2012   #3

Multi-Boot W7_Pro_x64 W8.1_Pro_x64 W10_Pro_x64

Did you do a BIOS RESET for the new motherboard?
If not, give that a try.
My System SpecsSystem Spec

12 Sep 2012   #4

Windows 7 ultimate 64

Quote   Quote: Originally Posted by DavidW7ncus View Post
Did you do a BIOS RESET for the new motherboard?
If not, give that a try.
That just clearing CMOS right? Or a bios option?
My System SpecsSystem Spec
12 Sep 2012   #5

Multi-Boot W7_Pro_x64 W8.1_Pro_x64 W10_Pro_x64

Yes, enter your BIOS.
I expect there is an option to do a reset and it will be displayed.

I would do a hard reset by powering everything down, disconnecting power cable, and removing the CMOS battery for a minute or so.
There should also be a jumper to do this.
Instructions for this should be in your Motherboard manual.

As your already assembled, try the easy way first by looking in BIOS for the reset option...
My System SpecsSystem Spec
12 Sep 2012   #6

Windows 7 ultimate 64

Reset bios, still having same issue.
My System SpecsSystem Spec
12 Sep 2012   #7


Do you have an EFI BIOS? If so remove EFI Boot disk from BIOS boot order and look for a Legacy BIOS setting to enable. Or you can install to UEFI (Unified Extensible Firmware Interface) - Install Windows 7 with - Windows 7 Forums

If not I'd contact your system builder to ask why no HD's are being detected.

Have you slaved one to wipe it with Diskpart Clean Command first? Try it wiped first, then try it formatted and marked Active using Step 2.2 in SSD - HDD Optimize for Windows Reinstallation.

Where did you get Win7? Did you burn the DVD or write it it flash stick yourself, and how?
My System SpecsSystem Spec
13 Sep 2012   #8

Windows 7 ultimate 64

It is a UEFI bios.

I contacted Asrock, and ultimatly he thought it may be the windows 7 ISO burned to a CD I am running. It is a free and legal version provided by digital river. But I am somewhat skeptical thats the problem as it uses the same hashes as the retail version supposedly Official Windows 7 SP1 ISO from Digital River My Digital Life

Pretty significant update as well, I went to my local frys and purchased an asus p8z77 and still encountered the same issue.

As far as my drives. I always format them inside the windows 7 installation menu themselves. When the drives are listed I just right click and format. Unless I add a new hard drive after the fact I format it within the OS. It is worth mentioning disk part and disk list in the windows 7 install lists no fixed drives available.

Seems we can rule out motherboard being the issue safely. I am going to head to frys to buy a retail system builder copy of win 7 and a new hard drive.

Unfortunately only hard drives available for me to test at frys at this time is a western digital caviar green wd5000csrtl 500gb sata 3, Thats all they have in stock believe it or not. - Western Digital Caviar Green WD5000CSRTL 500GB 7200 RPM 16MB Cache SATA 3.0Gb/s 3.5" Hard Drive

Let me stress though, both the asus p8z77 and asrock extreme 4 BOTH detect the hard drive in IDE storage mode. But it goes astronomically slow, literally 30 minutes to get past the windows 7 splash screen. The drives don't show up in AHCI mode, but do in IDE.

thanks for helping everyone
My System SpecsSystem Spec
13 Sep 2012   #9


If it's an EFI BIOs then you need to take the steps given in your Manual to disable EFI BIOS or else follow the extra steps I gave you to install to an EFI BIOS which also require wiping the HD so it will format GPT.

You can cross-check the installer by writing a new ISO to flash stick from Step 1 and 2 in Clean Reinstall - Factory OEM Windows 7
My System SpecsSystem Spec
06 Aug 2014   #10


The most effective method to this problem is to delete this disk partition where you are loading windows.Download Gparted live cd here:
GParted -- Live CD/USB/PXE/HD

In Bios set boot settings to boot from CD/DVD as first option(if already not done), boot from Gparted live cd ( burnt to a cd), and delete the windows partition from the HDD. DO not format or allocate space using Gparted live cd. Just delete the partition and now insert your windows installation disk and restart.

Now during installation win will detect the HDD and you can choose to allocate and format the earlier deleted partition using windows during installation (Go to HDD advanced options during installation of win).

(If you format using Gparted live cd(linux program) , windows installer sometimes creates problems during /after windows installation.)

So just delete the partition and do nothing else in Gparted live cd.

Start installing win 7/8 now.
No need to load SATA drivers or change drivers setting sin BIOS.
All the best.
My System SpecsSystem Spec

 New System not Detecting HDD to Install Windows 7

Thread Tools

Similar help and support threads
Thread Forum
New Windows 7 Install Not Detecting HDD
Specs: MOBO: Gigabyte GA-880GM-UDH2 Rev. 1.0 (AMD SATA) BIOS Rev: F8 HDD: WD Black WD1001FALS 1TB SATA HDD Plugged in to SATA2_0 First off, I've read several post reporting the same thing and have tried to take the advice given in each. My question doesn't come from a laziness in research...
Installation & Setup
Gateway fed 1000 operating system windows ME bios not detecting usb
When I go into the bios (f10) I go into boot and it comes up with first device, second, third and so on. in the options for the boot devices, I try every option and the usb is bootable and plugged in!! trying to replace ME to windows 7. Please help!!!!!:cry:
Installation & Setup
System not detecting SSD after crash
For starters, my SSD is the boot drive. Last night I put my computer into sleep mode. This morning when I woke it up, everything was fine except the mouse was lagging. The mouse eventually froze and my computer reset. Now it gets stuck at the boot screen and can only detect my secondary HDD and my...
Hardware & Devices
New Windows 7 Home x64 install not detecting External Drive.
So after my prehistoric motherboard finally died, I bit the bullet and did a complete system overhaul, upgrading to my current listed specs in my profile along with a new Windows 7 Home Ultimate x64 install. However, it has provided me with an unexpected issue. Windows no longer detects my...
Hardware & Devices
Dual boot system failure, not detecting Windows 7 anymore
Hello, I know just enough about computers to get myself in trouble. I had a 160GB Hard drive that was getting kind of crowded, it was my sole hard drive. I had XP on it and as I had no problems with it, I was content to stick with it. I bought a 500gb hard drive and as my fiancee had bought me...
Installation & Setup
win7 32bit CLEAN install on MSI CX600 not detecting HDD
hey all i need some help. i recently had to get a new hdd for my MSI CX600 laptop and im trying to install windows 7 on it, when it asks to select what drive to install on no drives are listed. the hdd is listed in the bios and i have tried the shift+f10 and list disk etc and nothing is...
Installation & Setup

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 08:19.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App