Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: PCIe eSata attached HDD changes boot order, but only when plugged in

14 Sep 2012   #1

win7 pro x64
PCIe eSata attached HDD changes boot order, but only when plugged in

My system was running smoothly until I added a PCIe x1 eSata card ("ASRock sata3 card" with Marvell 88SE9123 / 88SE9120 chipset) that uses a Marvell Magni controller with a driver version . The Marvell card driver installed OK; the board is recognized at boot time and recognizes the HDD when it is attached (a Freecom Hard Drive Quattro, 2 TB with USB, Firewire and eSata interfaces; it houses a Samsung HD204UI disk).

When the HDD is not plugged in the systems boots OK, but when the HDD is plugged into the Sata 3 card, the system fails to boot with the message: "Reboot and select proper Boot device or Insert Boot Media in selected Boot device and press a key".

When I interrupt the boot process during POST to force the system to boot from its "Intell0" RAID0 HDDs (which otherwise works fine) the system ignores the setting and keeps trying to boot from the eSata attached Freecom drive.

I have updated the ASUS P8P67 rev 3.1 MoBo bios to 3207; the Marvell drivers for the MoBo to Version I have disabled and enabled the Marvell controller OPROM in the bios - no difference. The Freecom HD is OK - works fine on another machine. The onboard ASUS eSata connection (also with Marvell) works with the same Freecom disk - no boot issues, regardless whether the HDD is plugged in or not. I have also checked that the Freecom partition (there is only one) is inactive.

The ASRock Marvell controller is the first to load when booting, then follows the MoBo ASUS Marvell controller. Both are displayed at boot time, before the other drives are activated. It seems that the ASRock Marvell controller hijacks the boot order and sets it to point at the HDD attached to it. When no HDD is attached the problem disappears. The ASRock OPROM might dictate the system to boot from its attached HDD, but I am not sure this is what is truly happening, or how I could change this.

I found a workaround after updating the Marvell 'Magni' drivers for the Sata 3 card as posted on the ASRock website. This changed the driver version for the ASRock PCIe card to version, and the driver version for the ASUS onboard eSata Marvell drivers to version When booting with the Sata 3 card HDD unplugged, the systems boots fine (as it did before), and when the HDD is plugged in after Win7 has started, it connects without a problem. Booting with the HDD plugged in however still does not work. This workaround might also work with the previous driver set; I have not tried this out yet. I am semi happy with this result; it is sufficient for back-up purposes.

A hint could be that updating the Marvell drivers downloaded from ASUS vs ASRock produces different and distinct driver versions for all Marvell devices. It seems that they cannot be updated separately (the driver installer is an exe file, no inf is available).

Another idea stems from a similar experience with an older eSata PCIe card: PEXESATA2 from StarTech which is based on a Silicon Image Sil 3132 SATALink controller with driver version This controller has a separate flash bios capability which might allow for more specific tuning. I have not researched this in full because after equally failing to boot I hoped to solve the problem by buying the more recent eSata ASRock card. The fact that both produced the same error with two distinct controller architectures suggests that the ASUS bios might be the culprit.

A final possibility is that the Freecom HD influences the boot order (which it could only do when plugged in), but this seems far fetched. Moreover, its single partition is set to 'inactive', ie not bootable.

Any ideas?

My System SpecsSystem Spec
14 Sep 2012   #2


Is the external marked Active? If no Mark as Inactive - Windows 7 Forums.

Otherwise if Win7 HD is set in BIOS first HD to boot then an external should not override it unless there is a setting awry in BIOS setup, or there is boot code on the external that is interfering. This is sometimes solved by moving the data off to wipe the external with Diskpart Clean Command however you should know if it was ever made bootable.

Today I saw the first good comment on Marvell controllers here in 3 years, about their newer ones. It may be you need to circumvent them.
My System SpecsSystem Spec

 PCIe eSata attached HDD changes boot order, but only when plugged in

Thread Tools

Similar help and support threads
Thread Forum
UEFI hard drive boot order and boot menu are completely ignored
I have a bit of a puzzle, and I don't know whether to blame the motherboard maker, Microsoft, or -- this is a really distant third choice, obviously -- myself. (That being said, UEFIs and GPT drives are new to me, so that distant third choice might not be as distant as I'd hoped.) I recently set...
PC Custom Builds and Overclocking
Boot from one of 2 attached drives with BIOS boot order no problem?
I got a SSD now in my system connected to the first sata port with win7 installed My previous (mechanical) sata hard disk who was prev. setup on this port is still usable and also has win7 installed on it. i wnat to use it as a experiment setup. If I connect this old hdd to another sata port say...
Installation & Setup
Boot from eSATA dock
Have a Dell Zino that has been overheating. Plan on cleaning the heatsinks, new thermal grease. Would like to remove the hard drive and install it in an external eSATA dock. Will I be able to boot with this setup?
Hardware & Devices
Windows 7 PCs Can Make Drives over 2.2 TB Attached through eSATA .....
More - Windows 7 PCs Can Make Drives over 2.2 TB Attached through eSATA Appear Smaller - Softpedia
External Hard Drive attached by eSATA not detected
Alright, so I have an 1TB Toshiba External Hard Drive and it has the option for either USB or eSATA. I had it attached by USB up til now cuz I didn't have an eSATA cable or port. Today, I went to MicroCenter and got an eSATA to eSATA cable and a port thing that has two eSATA females and two SATA...
Hardware & Devices
Hard Drive attached by eSATA is not detected
Hi. Just today I finally received my shipment of a WD HDD - Western Digital Caviar Black WD1001FALS 1TB 7200 RPM 32MB Cache SATA 3.0Gb/s 3.5" Internal Hard Drive -Bare Drive and a Rosewill Enclosure - Rosewill RX-358-S I put the hard drive in, made sure it was in the SATA...
Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 20:41.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App