Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: bootrec acts on usb drive rather than hdd

15 Oct 2012   #1

Windows 7 Professional 64 Bit
bootrec acts on usb drive rather than hdd

I am trying to recover to delivery state after having installed Ubuntu. Lenovo recovery partition was still intact, so I managed to restore the drives Windows7_OS and SYSTEM_DRV.

But first of all, the letters of the partitions get messed up after every reboot. I assign Windows7_OS the letter C, SYSTEM_DRV gets S, and Lenovo_Recovery gets Q. Diskpart then lists the drives with correct letters. After rebooting, they're back to D,C,E, respectively.
Worse, when I boot the Windows recovery disk from a usb stick, it does recognize correctly the Windows installed on drive D. But when I go to command prompt and enter

bootrec.exe /fixmbr
bootrec.exe /fixboot

then the Windows recovery disk commits suicide. It seems to attempt to fix its own bootmgr. At the moment, both usb stick and hard disk run with grub (Windows recovery on a multiboot installed via YUMI). After I run the commands above, the hard disk still runs with grub, but the usb stick now has bootmgr and fails to boot. I have tried this several times, each time recreating the Windows recovery disk with YUMI, and every time getting the same result.

Also, while the Windows recovery disk finds the Windows installed on drive D, "bootrec /scanos" gives no results.

F11 option for recovery at startup is of course gone.

Any suggestions welcome.

My System SpecsSystem Spec
15 Oct 2012   #2


Why would you think Factory Recovery would run correctly after you imposed both another OS and bootloader on the HD? I've never heard of such a thing. Factory Recovery wipes the HD unless it offers an option to back up data and/or save a data partition. It has never made allowances for a foreign boot loader.

If you are a tech enthusiast who runs Linux distros then you I don't know why you would be running the intrinsically corrupt Lenovo factory preinstall with its sponsored crapware and duplicate utilities that throttle Win7. Better to Clean Reinstall - Factory OEM Windows 7 then use the safest method to Dual Boot Ubuntu using EasyBCD.

You might also be able to use EasyBCD to add a Factory restored Win7 to Dual Boot but it's infinitely better to go completely Clean.
My System SpecsSystem Spec
16 Oct 2012   #3

Windows 7 Professional 64 Bit

Yes, this is the first new Windows computer I got in 10 years, and I was a bit shocked to see how much junk came installed with it. Sadly this is not my personal computer, but from work. And our computer guy prefers the Windows delivered by Lenovo, probably because it comes with all the drivers. So the main purpose of all this is to get back the F11 option.

But I guess it would be ok if I installed a clean Windows, downloaded the drivers and software from Lenovo, and then made a backup image like you describe in your linked post. Is there any possibility to have the backup bootable, in the sense that it comes on the same usb stick as the Windows recovery disk? The X1 has no dvd drive, so otherwise the recovery option would freeze two usb sticks, one for the backup, and one for the system recovery.
My System SpecsSystem Spec

16 Oct 2012   #4


Win7 is driver-complete in the installer and quickly updated via optional Windows Updates when you enable Automatically get recommended drivers and updates for your hardware. There will be very few drivers which need to be imported from the Lenovo Support Downloads webpage afterwards, and I would not change out any that are not missing in Device Manager after all Updates are done.

You can use the Win7 installer USB flash stick made from tutorial to boot to reimage your HD from a saved image on external HD.
My System SpecsSystem Spec
18 Oct 2012   #5

Windows 7 Professional 64 Bit

Ok, thanks. In the end I managed to follow your tutorial. There were still some problems, like the fact that Lenovo apparently ships their laptops with 4 primary partitions preinstalled, so that a priori one can't create a new partition. And I did not have access to a Windows with administrator rights, so I had to follow this guy's advice to create a bootable Windows usb stick under Ubuntu:

Create a Windows 7 bootable USB from Ubuntu Linux cloud101

Now everything is running fine, Ubuntu next to Windows 7.
My System SpecsSystem Spec
18 Oct 2012   #6


You should have asked us about the partitioning problem as we deal with that every day here and can tell you based on a Disk Mgmt screenshot which partition to convert to Logical so you can add as many adjacent Logical partitions as you want.

To create a bootable WIn7 installer: Universal USB Installer
My System SpecsSystem Spec
18 Oct 2012   #7

Windows 7 Professional 64 Bit

Ok, but in the end it's fine. I deleted the SYSTEM_DRV partition, which I guess I will not need unless I want to use Lenovo recovery, and that option is gone anyways. And I didn't try the Universal USB Installer, but I did try YUMI. And YUMI needed administrator rights, too. Anyways, thanks again for the help.
My System SpecsSystem Spec

 bootrec acts on usb drive rather than hdd

Thread Tools

Similar help and support threads
Thread Forum
B(lack)SOD - ran sys recovery 3x, ran bootrec commands.. no luck
After numerous attempts to fix this I am getting really lost. I'm sort of technical but not THAT technical. Once I'm in console, I struggle... My problem: When I rebooted recently, I got an error talking about using bootsect, something about /nt60 SYS, but now I simply get a black screen....
BSOD Help and Support
Bootrec.exe Tool - How to Use in Windows Recovery Environment
How to Use Bootrec.exe Tool in Windows Recovery Environment You can use the Bootrec.exe tool in the Windows Recovery Environment to repair the following item in Windows 7 should you be experiencing startup issues that cannot be resolved by the Startup Repair option: The Boot...
bootrec /scanos doesn't find windows 7
Suddenly, I cannot boot into Windows 7 Ultimate. Repair disc could not repair the problem. I switched to the command prompt and issued "bootrec /scanos". It found 0 OS installed even though the Windows directory was still there. I have tried bootrec with all options and "bootsect /nt60 SYS...
Installation & Setup
pc not booting at all, bootrec.exe not finding os
I think I really screwdriver up my Pc somehow... :( My original problem was my Pc would get BSOD seemingly randomly while running after effects. You can see the original thread here:...
General Discussion
BOOTMGR missing, bootrec.exe access denied
Hey, recently, a friend of mine deleted something that he shouldnt have (or did something he shouldn;t have) and now, BOOTMGR missing keeps coming up, i've been trying to fix it for 2-3 days now :( and well, my current situation is that i cannot boot any CD from my disk drive, I have windows 7...
BSOD Help and Support

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 00:58.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App