Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Setup was unable to create a new system partition

17 Apr 2016   #171
TMY

Win 7 Ultimate 64
 
 
similar issue on Lenovo S30

As the above poster, I went thru all kinds of tricks mentioned here and in other posts, but the trick was to remove all devices from the computer, which were, other things connected via USB, such as USB sticks, external drives.

On the computer I just recently had the issue with, a Lenovo S30, I also disconnected a drive that was hooked up via the SCU connecter which was not yet even enabled.

And incidentally, to install, on this computer (the Lenovo S30), it's easier to do it to a drive that is connected via the SATA ports, than the crazy workaround that is required via the SCU ports.

Install to the single drive, in my case a SSD, then after install good, connect up all the other internal drives.

Hope this will help anyone with this issue.


My System SpecsSystem Spec
.
27 Apr 2016   #172
videobruce

Win7 x64 & XP
 
 

My situation is somewhat different.

The HDD that I'm all of a sudden having this problem with is partitioned into three parts, the 1st being the active partition.

It is NOT a SSD and I don't want to wipe the 'clean' the drive.

I have been trying different custom W7 builds via a USB stick. I have done at least SIX, probably eight re-installs without this issue using what is already inside the installer. Deleting the existing active partition, then using the 'trick' to combine the system & reserve partitons before the install. I could do that in my sleep.

All of a sudden, the reserve partition was not created. It just creates the primary which doesn't let the O/S get installed.

I use True Image to 'image' by bootable drives, in this case I did a 'restore the MBR' which did nothing. I even tried Partition Assistant to rebuild the MBR, but still no change. I wrote zeros to that partition (didn't think it would do anything, but I gave it a try).

I can restore images to that partition ok. I can access the 2nd & 3rd parttition ok.

Any ideas??
My System SpecsSystem Spec
19 Dec 2017   #173
ToySldr

Win 7 64bit
 
 

I know this is pretty old, but I just ran into the same problem as the OP. I followed the directions using diskpart and can't seem to get past that issue. I physically have 2 HD's installed, one is an SSD (the one that I want the OS installed to) and the other is a standard platter HD. Disk 0 Partition 1 (System) gives me the error" setup was unable to create a new system partition....." I am installing Win 7 64 bit from a USB. I've done this many times in the past, but this time it is kind of a nightmare. Any help would be greatly appreciated.
My System SpecsSystem Spec
.

20 Dec 2017   #174
nalbe

windows7 ultimate x32
 
 

Did you try to:
1.unplug second hdd
2.use another usb stick
3.use another usb port
4.download another win installer, check hashsum
My System SpecsSystem Spec
20 Dec 2017   #175
Megahertz07

Windows 7 HP 64
 
 

Please edit your profile with ALL your hardware specs.

Is it a new MoBo?

Detach ALL other disks leaving on only the target disk.
Boot from the Win 7 installation disk. Go to install - Advanced - Delete all partitions - Create new. Install on the big NTFS.
Clean Install Windows 7 - Windows 7 Help Forums
My System SpecsSystem Spec
Reply

 Setup was unable to create a new system partition




Thread Tools




Similar help and support threads
Thread Forum
Setup was unable to create a new system partition....
okay, so... where to start... I built a new rig 4 days ago. started installing windows 7 and had nothing but issues. I wanted to install the os on my SSD, but it wouldn't show up in the windows install. I found out that I had to prep the drive and install drivers before I could use it. so I...
Installation & Setup
Setup was unable to create a new system Partition ...
Hello. First thing - sorry for creating this thread, I know this problem have been solved million times before, but I tried most of tutorials here, and it just doesn't work... I wanted to install untouched version of Windows 7 SP1 x64, so I formatted my HDD. First problem was that disk was GPT...
Installation & Setup
Setup was unable to create a new system partition
Hi folks! I've been experiencing some troubles installing Windows 7 from a bootable USB. I was so clever that I deleted all the partitions even with my Windows 8. I was trying to downgrade and had loads of issues getting the USB to work, but that's fine now and I got to the setup. However,...
Installation & Setup
setup was unable to create a new system partition.
HI, Yesterday i want to install windows 7 on my laptop but when i format Local disk C and click next it says setup was unable to create a new system partition. I boot through Pen Drive. I dont have a dvd rw(not working) and i have Data on other drives... please tell me solution..without wiping...
Installation & Setup
Setup was unable to create a new system partition - I can not create p
Hello guys,'ve looked for everything that google and not found my solution. Is giving the following error when trying to install windows 7 in HD: "setup was unable to create a new system partition or locate an existing system partition" I've tried to do some procedures, but also can not...
Installation & Setup


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 07:45.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App