Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Setup was unable to create a new system partition - I can not create p

06 Dec 2012   #1
Thrall

 
 
Setup was unable to create a new system partition - I can not create p

Hello guys,'ve looked for everything that google and not found my solution.

Is giving the following error when trying to install windows 7 in HD:
"setup was unable to create a new system partition or locate an existing system partition"

I've tried to do some procedures, but also can not create partition, do not know what else to do.

I've tried also to give a "clean" and nothing also, can someone help me?

Thanks!!!


My System SpecsSystem Spec
.
06 Dec 2012   #2
theog

Microsoft Community Contributor Award Recipient

ME/XP/Vista/Win7
 
 

My System SpecsSystem Spec
06 Dec 2012   #3
Thrall

 
 

i have 8 hd's with same problem friend

all wester digital 500gb
My System SpecsSystem Spec
.

06 Dec 2012   #4
whs
Microsoft MVP

Vista, Windows7, Mint Mate, Zorin, Windows 8
 
 

Create a primary active partition of 50GB or more on the HDD and install into that.
My System SpecsSystem Spec
06 Dec 2012   #5
Thrall

 
 

how do I do that? by diskpart?

Quote   Quote: Originally Posted by whs View Post
Create a primary active partition of 50GB or more on the HDD and install into that.
My System SpecsSystem Spec
06 Dec 2012   #6
whs
Microsoft MVP

Vista, Windows7, Mint Mate, Zorin, Windows 8
 
 

Diskpart
List disk
Select disk n (where n is the number that was given for your SSD in List disk)
Clean (this would clean the whole disk)
Create partition primary size=50000 (this would be for 50GBs)
Format fs=ntfs quick
Active
Exit
My System SpecsSystem Spec
06 Dec 2012   #7
Thrall

 
 

Friend when I get this part:
Create partition primary size=50000

It turns out this problem:
diskpart has encountered an error the request could not be performed because of an i/o device error


What to do? Thanks for now!!

Quote   Quote: Originally Posted by whs View Post
Diskpart
List disk
Select disk n (where n is the number that was given for your SSD in List disk)
Clean (this would clean the whole disk)
Create partition primary size=50000 (this would be for 50GBs)
Format fs=ntfs quick
Active
Exit
My System SpecsSystem Spec
06 Dec 2012   #8
whs
Microsoft MVP

Vista, Windows7, Mint Mate, Zorin, Windows 8
 
 

That means there is a problem with your disk or the Sata controller - which is more likely since you seemed to have the problem on different HDDs. Hard to say how to cure it short of a new mobo.

Do you have an eSata port on that system ??
My System SpecsSystem Spec
06 Dec 2012   #9
Thrall

 
 

Quote   Quote: Originally Posted by whs View Post
That means there is a problem with your disk or the Sata controller - which is more likely since you seemed to have the problem on different HDDs. Hard to say how to cure it short of a new mobo.

Do you have an eSata port on that system ??
I have 8 HD's 500gb equal to that of, and everybody is giving this same problem, I use a 320gb hd normal functioning normally and windows in it ...

My cable is Sata.
My System SpecsSystem Spec
06 Dec 2012   #10
whs
Microsoft MVP

Vista, Windows7, Mint Mate, Zorin, Windows 8
 
 

As I said, sounds like a Sata controller problem. If you has an eSata port (which few machines have) and an eSata enclosure, we could test it from there.
My System SpecsSystem Spec
Reply

 Setup was unable to create a new system partition - I can not create p




Thread Tools




Similar help and support threads
Thread Forum
Setup was unable to create a new system Partition
I'm trying to install a fresh copy of Windows 7 onto my brand new mSATA SSD. I keep getting the same error "Setup was unable to create a new system Partition". My Specs are as follows: Intel® NUC Kit DC3217IYE Integrated Board: D33217GKE mSATA M500 Crucial 240gb SSD Intel® Core™ i3 3217U...
Installation & Setup
Setup was unable to create a new system partition...
So I bought a new SSD drive and tried installing windows 7 ultimate x64 on it. Before that I had a samsung baracuda HDD drive and reinstalled windows 7 on it a couple of times. Now when i try to install windows 7 on any of the drives i get the same error all over again. Tried creating a partition...
Installation & Setup
Setup was unable to create a new system partition
Hello all! I have installed windows countless times and this is the first time I have ever run into this problem. Yes, I have read countless forums on this; however, none of them help at all. I unplugged all USB devices etc. Being that this is the first time something like this has happened,...
Installation & Setup
Help! Setup was unable to create a new system partition.
I get this error when I'm installing windows 7 from USB. Help would be greatly appreciated.
Installation & Setup
Setup was unable to create a new system partition
This is a fresh Windows 7 install on a 500GB HDD (previously used under XP) In the BIOS the Storage is configured as: Raid. Obviously I have the right raid ICH10R drivers from Asus (they are on a USB drive) Installation starts, Windows sees the disk, I specify the drivers, BUT when I click Next,...
Installation & Setup


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 19:26.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App