Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Asus N76 UEFI - W7 64 Install Hangs on Logo (DVD UEFI Boot)

04 Oct 2013   #131

XP Pro

"You said that you'd disabled Legacy Options in BIOS. Disabling Legacy Mode or CSM choices should be sufficient to enable UEFI install.

That's why I asked if you have UEFI boot choices for your installer. Did you try the UEFI DVD boot?

You'll always have to choose your boot device when installing, using either the BIOS Boot Priority order choices, or the one-time BIOS boot Menu key at boot."

Not sure if you're referring to my post, but just changing to UEFI and leaving legacy boot options enabled was not enough to get the card to work. The card needs to have the legacy options disabled in order for the handle to be open for Windows to use it. I've switched to UEFI mode and left legacy option roms enabled and after Windows is installed (7 or 8), the card error code 10's. If you then disable legacy option roms, even though the partition is EFI, Window's will then fail to boot. The install has to be done with legacy options disabled from the beginning.

My problem now is that I can't get Windows 7 to install. 8 works fine, but the 7 installer stops doing anything on the Starting Windows splash screen. I've tried three different discs and two different computers. I'm working on this with Dell, not the point of this posting.

The point of this posting is to say that at least on Dell's, you have to switch to UEFI and disable legacy option roms for the 9240 to work. I've seen machines that allow you to switch between UEFI and legacy boot mode that don't have the option to disable legacy booting and those are hit or miss on whether or not the card will work. I've seen it work on an Optiplex GX620, but not on an Optiplex 745 or a 7010.

My System SpecsSystem Spec
04 Oct 2013   #132


If you want to quote someone click the Quote button on their post. That's why the Quote button is there.

Did you try to Bypass UEFI to Install WIn7 yet?
My System SpecsSystem Spec
07 Oct 2013   #133

XP Pro

Quote   Quote: Originally Posted by gregrocker View Post
If you want to quote someone click the Quote button on their post. That's why the Quote button is there.

Did you try to Bypass UEFI to Install WIn7 yet?
I can't bypess UEFI. I have to use it.

I tried turning on the legacy rom's, booting the 7 installer, using disk part to create a gpt partition, but then the installer says "Windows cannot be installed to this disk. The selected disk is of the GPT partition style."

Tried this as well.

I am currently installing 7 with legacy options enabled, but switched to uefi booting. The only boot device allowed is the UEFI DVD and the 7 installer is letting me install to the GPT partition I created with the technet link. I'm pretty sure this won't work and when I disable legacy ROMs, 7 will stop booting, but I'll let you know for sure when the install is done.
My System SpecsSystem Spec

07 Oct 2013   #134

XP Pro

My above posting didn't work. After 7 was installed the 9240 produced the predictable error code 10. I turned off legacy option ROMs and could then no longer boot into 7. I've also since tried installing 7 to a UEFI only motherboard of a custom build machine my friend has. I can't be certain his legacy options were disabled completely as there was no specific option like the Dell BIOS. Only to choose UEFI only. I did an install on his machine and then put the drive in the Dell and it failed to boot. In talked with Dell, they sent me one of their own Windows 7 x64 w/ SP1 discs to try as well as a link that I had already been to.

Installing Windows 7 on UEFI based computer - Ask the Core Team - Site Home - TechNet Blogs

Then said this.

"Just to make sure, here is a link to how this is supposed to be done. There is only 1 step that is different from a regular reinstall. If this does not work, then the issue sounds like a UEFI issue since it is happening across several platforms ."

The several platforms are a Dell T1650, a Dell Optiplex 7010, and a Dell Optiplex 745.

I like how they blame a universal standard and not their equipment.
My System SpecsSystem Spec
07 Oct 2013   #135


If you want to install to UEFI then you need to disable Legacy BIOS (which you said you enabled) use the special steps in UEFI (Unified Extensible Firmware Interface) - Install Windows 7 with - Windows 7 Forums deleting all partitions at the drive selection screen, or wiping the HD first with Diskpart Clean Command.

If you want to Bypass UEFI to Install WIn7 then you'll need to enable Legacy BIOS or CSM, disable Legacy if it has a separate BIOS setting, also wipe the HD as shown in the steps in blue link.

Just to be sure, reset the BIOS to defaults before trying each way.

If these both fail then please post back camera snaps of all the BIOS choices for UEFI and Legacy, including the Boot options for either mode. Screenshots and Files - Upload and Post in Seven Forums - Windows 7 Forums
My System SpecsSystem Spec
08 Oct 2013   #136

XP Pro

So I've come to the conclusion that this card just isn't going to work with my particular system. The card will always error code 10 in Win 7 or Win 8 (x64 for both) if legacy option ROMs are enabled. If they aren't enabled, I can't boot Windows from a previous install with them enabled and I can't do a fresh install of Windows 7 (the OS I need to have installed) because the installer locks up when trying to load. This is a separate problem I've been working with Dell on.

"On Mon, Oct 7, 2013 at 1:21 PM, wrote:

I will wait for your reply on this. Just to make sure, lets do all troubleshooting with onboard only and do not use any additional cards until we can figure out what the issue is. This all could be a limitation of our hardware with UEFI and we will need to wait for a proper BIOS update to resolve this. I have been talking to several other agents, Seniors, and managers about this and all is showing it should work with Secure Boot off while running on the onboard card. As for the LSI card we are not sure as we do not use that card on the system.

Thank you for choosing Dell,

M-F 7:30AM-4:30PM
Dell Workstation
Dell Drivers/Downloads: Product Selection | Dell US "

That's one of my most recent messages from them.

I can install Win 8 with only UEFI and legacy option ROMs disabled, and the card does work in Win 8, no error code 10, but that's when something else I noticed hit me. When legacy option ROMs are disabled, when the computer boots, it no longer loads the 9240's firmware or whatever the correct term would be. Usually (when legacy is enabled) before I can access the computers BIOS or before it starts to try and PXE boot or anything, the 9240 will take over the legacy option ROM and load itself in, checking for any attached drives and gives you a chance to modify any of its settings through a GUI or CLI. With legacy disabled, it just skips over this and when I get into Win 8 (for testing purposes), the card works, but I can't see any attached drive.

My current goal is to see if there's now some LSI software that will allow me to get the drives up in Win 8 with legacy disabled and a successful Windows install of the card. Unfortunately my managers, seniors, etc., have decided they are going to return the equipment and I don't have much time left to try things out.
My System SpecsSystem Spec
08 Oct 2013   #137


Please reply to the steps I gave you.

Sometimes it requires CSM or Legacy to install Win7 in UEFI mode at all.

If UEFI doesn't work for you with Legacy or any CSM listings enabled or disabled, then try to Bypass UEFI to Install WIn7 with UEFI disabled, Legacy or CSM fully enabled.

If neither works then try another card.
My System SpecsSystem Spec
09 Oct 2013   #138

XP Pro

I appreciate the help, but this card just isn't going to work with this machine.

With legacy options enabled, the card takes over the option ROM and Windows doesn't have access to the ROM in order to successfully install. I can install Windows, but I can't use the card, error code 10. With legacy disabled, I can't even install 7, the installer won't load, something Dell has said they may need a BIOS update for. I can install 8 and the card installs in 8 with legacy disabled, no error code 10, but you can't see any attached drives. Also, with legacy disabled, I can no longer access the cards built-in GUI or CLI to set up RAID and make all sorts of configuration changes before the computer boots. Because legacy is disabled, it just doesn't even give the card a chance to tell the computer it's there on boot up. Windows knows it's there because it's installed in the PCIe slot, but because legacy ROMs are disabled on the motherboard, it can't properly interact with the card because it never got the chance to initialize itself on boot up.

It's all a mute point now anyways. The superiors only wanted the cards to run 15000rpm SAS drives to store large data files for a sever training class (this is a community college). Why they thought spending 10K plus for this without testing it is beyond me, but they are returning everything they can and buying regular SATA drives, so I can't work on it anymore. I still wanted to see if there was LSI software I could run in Windows 8 to see and manipulate attached drives or just use legacy to load the cards GUI, create a virtual partition, install 7 to it, and see if that worked. But alas, we'll probably never know at this point.

Thanks again for the help, sorry I couldn't continue to work on it.

Btw, I tried the link you provided, as well as a few others that involved using diskpart, and none of them worked for the reasons described above. Even when I did successfully get an EFI install in 7, the card won't work because of what I said above. When I turn off legacy after the successful install, Windows will error on boot. So the problem isn't that 7 (or 8) won't install UEFI, it's that 7 won't install without legacy enabled and the card won't work (or will work and not see attached devices) if legacy is enabled or disabled. I.e. the card doesn't work with this system; at least not without possible software by LSI or installing Windows to an attached device instead of a drive connected to the motherboard.
My System SpecsSystem Spec
09 Oct 2013   #139


Thanks for clarifying. Be aware we see nothing but problems here with RAID since Win7's release. I would avoid it unless the benefits are known to outweigh the pitfalls which are manifold.
My System SpecsSystem Spec
11 Oct 2013   #140

Windows 8 HP x64

Back again. Enabling CSM & disabling Secureboot worked just fine. Also upped the RAM from 4 to 8GB. Combined with the new SSD I have a fast responsive Win7 laptop now. Once experienced, you never want to go back to HDD. The performance gain is astonishing and really worth shelling out some €.
My System SpecsSystem Spec

 Asus N76 UEFI - W7 64 Install Hangs on Logo (DVD UEFI Boot)

Thread Tools

Similar help and support threads
Thread Forum
UEFI hanging at boot logo.. Virus related?
Ive seen this on laptops, desktops, asus, acer, hp, gigabyte motherboard in desktop, etc etc. Does anyone know what I would search to find more info on this? It hangs at the motherboard boot logo but doesnt go any further as when it trys to boot to the drive it never moves on. Doesnt even try to...
General Discussion
ASUS X55A Windows Install + UEFI Confusion
Can someone elaborate on this UEFI thing as I am totally confused. There is an option in the BIOS that says: Delete Boot Option, but there is nothing to delete. There is also no Add Boot Option. Also there are supposed to be other options such as Launch CSM or Secure Boot Control, but they are...
BSOD Help and Support
Acer TimelineU M5-581T| UEFI| Windows 7 install hangs at Logo
hi, i am having a peculiar problem with my newly purchased Acer TimelineU M5-581T laptop. it has 20GB SSD and 500GB HDD and UEFI MB also supports legacy BIOS. it came with Windows-8 pre-installed and had a single drive C:. i needed to partition it and had created drive D: with windows disk...
Installation & Setup
UEFI boot keeps changing; UEFI/Win7 handshaking confusion
Trying to understand handshaking between UEFI & Win 7. Have Win7 Pro sp1 64 installed on SSD, mb=Asus F2A85-V Pro. Example: boot to flashdrive to do Acronis backup of SSD; remove SDD, insert spinner; boot again to flashdrive to do Acronis restore to spinner (to test backup); remove flashdrive, boot...
Installation & Setup
Boot UEFI from wake on lan, or convert UEFI MBR to legacy.
Hi all, Currently having a wake on lan issue with a certain computer. The machine is setup correctly but the windows boot information is stored in a 100mb UEFI partition, and when the computer wakes on lan, it will not boot windows, just sit at a blank screen. When it wakes on lan it is...
General Discussion
What's the benefit of UEFI and install Windows in UEFI mode?
I am not sure if this subforum is the right place, if not, pleases help me transfer to the right forum... I recently just build a new setup with Asus P8Z77-V LK, this motherboard comes with UEFI boot and legacy BIOS boot support. So I tested install windows 7 in both mode, and I didn't find...
Installation & Setup

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 09:29.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App