Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Asus N76 UEFI - W7 64 Install Hangs on Logo (DVD UEFI Boot)

08 Dec 2012   #31

Windows XP Professional SP3/Windows 7 Ultimate x64

This is not completely related to this post, but if nothing works you can make Windows 8 look like WIndows 7. Check this.

My System SpecsSystem Spec
08 Dec 2012   #32

Windows 7 Ultimate 64-bit

Hello all,

First, it is not the DVD. There is nothing wrong with the DVD. I have used this DVD elsewhere, as I said, it just hasn't been activated. I know it "looks" like as if the DVD is corrupted but let me assure you, it is not. This is an authentic W7 DVD. I managed to install W7 on the SSD from within Windows 8 but when the system booted and when I selected to continue with the Windows 7 installation, it again froze at the Windows logo....Same as what happens when the DVD boots. I think *there must be somethng* in the EFI that prevents Windows 7 from booting.

Anyway, I finally had enough.....

I took the original hard disk out and I put the SSD. Downloaded Windows 8 Enterprise 90-day Demo and did a clean install. I started having random crashes. Intuition told me that the OS confuses itself between the built-in VGA adapter and the NVIDIA one (screen was flickering) so I disabled the Intel one as I don't need it. That resolved the crashes. Some of the ASUS software must have been some sort of driver that manages my dual VGA adapters....

Anyway, I installed a third party Start Menu and now I feel comfortable again, however I still wait for ASUS to respond to my inquiry about

- How to boot in MBR Legacy Mode (since every EFI BIOS is supposed to have this)
- Explain why W7 install freezes

Hopefully I hear from them.
My System SpecsSystem Spec
08 Dec 2012   #33


They can most likely help you over at to clean reinstall your licensed version on the SSD, so you don't need to use Enterprise when you own another version. Theog may already know this as he's helping at both Forums.
My System SpecsSystem Spec

09 Dec 2012   #34

Windows 7 Ultimate 64-bit


I found the setting for Legacy MBR Support!!! It was under a menu called "Launch CSM"!!

Have a look and this was thx to a Linux article!

Linux on the Asus Vivobook S200 (x202e)

Who would have thought this? I found CSM curious and I searched it on the net!

Attached Thumbnails
Asus N76 UEFI - W7 64 Install Hangs on Logo (DVD UEFI Boot)-20121209_202123.jpg   Asus N76 UEFI - W7 64 Install Hangs on Logo (DVD UEFI Boot)-20121209_202209.jpg  
Attached Images
Asus N76 UEFI - W7 64 Install Hangs on Logo (DVD UEFI Boot)-csm.png 
My System SpecsSystem Spec
09 Dec 2012   #35

Windows 7 Ultimate 64-bit

W7 Install booted fine!!

I am SO going back to Windows 7!

Mark this thread as solved!

Thank you Greg for trying to help me! I mean it, thanks for your time!

Attached Thumbnails
Asus N76 UEFI - W7 64 Install Hangs on Logo (DVD UEFI Boot)-w7.png  
My System SpecsSystem Spec
09 Dec 2012   #36


Good work!

I'm curious if after Launch CSM if the regular (not UEFI) DVD drive and (not Windows Boot Manager) HD became available to choose, as that's what we've seen mostly so far wtih UEFI mobos?

If not were you able to boot UEFI DVD and install to Windows Boot Manager HD bypassing UEFI even though these Boot Options are normally associated only with UEFI install and disappear when Legacy BIOS is enabled?
My System SpecsSystem Spec
09 Dec 2012   #37

Windows 7 Ultimate 64-bit

Well, I have a multiboot USB Flash Drive, it is multi-partitioned and it is an MBR based and I successfully booted from it! I think the regular internal drives are not in the screen as an MBR option because they are GPT based.

I have an internal MBR drive in my ZALMAN USB HD 2.5" enclosure and as you can see, it appears on the list so I can boot from. I am sure once I convert my SSD to an MBR drive (and I will during install), it will appear on the list.

I will have to do this later though as I have to go to work now I will let you know how I go and you can ask away any questions if you have. This was a big relief from me.

Now that I know what happens, I think I understand why W7 install kept hanging on the logo.

After I clean installed Windows 8, when Windows 8 was launching, it did *not* show me the Windows logo on the splash screen, the flag but instead I kept seeing the ASUS logo all the way until the Windows login screen appeared. So I think there must some sort of internal splash screen in the EFI storage that gets automatically pulled when Legacy MBR is turned OFF *and* Windows is loading and only W8 has this functionality and it makes the W7 incompatible.

To confirm my theory, I will launch W7 install again in UEFI mode while I have Legacy MBR enabled and see if it works.
My System SpecsSystem Spec
09 Dec 2012   #38

Windows 7 Ultimate 64-bit

I have edited the above post as I had some typos and misrepresentations in my text, sorry.
My System SpecsSystem Spec
09 Dec 2012   #39

Microsoft Community Contributor Award Recipient


You can install Windows 8 x64, Windows 7 x64, & linux in uEFI mode. No need for Legacy BIOS/MBR.
My System SpecsSystem Spec
10 Dec 2012   #40

Windows 7 Ultimate 64-bit

I have successfully installed Windows 7 (finally) on my new laptop on the SSD using Legacy MBR Mode. So at this point, I am running in full MBR mode. Again, to do this, I had to enable "Launch CSM". UEFI and secure boot is turned off.

I will use the original HD (1TB) for backup in the second HD bay and will format the whole disk as MBR/NTFS.

FYI, I tried to boot the DVD in UEFI mode while Legacy MBR is turned on, by selecting UEFI DVD option, it did not boot. Instead, it went straight to the internal HD.

As suspected, once the internal HD became MBR based, it now appears on the Boot Menu.
My System SpecsSystem Spec

 Asus N76 UEFI - W7 64 Install Hangs on Logo (DVD UEFI Boot)

Thread Tools

Similar help and support threads
Thread Forum
Win7x64 UEFI-boot install hangs at "Starting Windows" on Skylake
Let me first address a few things: - I have read extensively on this topic, using guides such as this to determine whether or not I have bootable media for UEFI, which I do. - I have both an original, unused Windows 7 Pro w/ SP1 x64 install DVD, connected through the USB 2.0 external DVD...
Installation & Setup
UEFI hanging at boot logo.. Virus related?
Ive seen this on laptops, desktops, asus, acer, hp, gigabyte motherboard in desktop, etc etc. Does anyone know what I would search to find more info on this? It hangs at the motherboard boot logo but doesnt go any further as when it trys to boot to the drive it never moves on. Doesnt even try to...
General Discussion
Acer TimelineU M5-581T| UEFI| Windows 7 install hangs at Logo
hi, i am having a peculiar problem with my newly purchased Acer TimelineU M5-581T laptop. it has 20GB SSD and 500GB HDD and UEFI MB also supports legacy BIOS. it came with Windows-8 pre-installed and had a single drive C:. i needed to partition it and had created drive D: with windows disk...
Installation & Setup
UEFI boot keeps changing; UEFI/Win7 handshaking confusion
Trying to understand handshaking between UEFI & Win 7. Have Win7 Pro sp1 64 installed on SSD, mb=Asus F2A85-V Pro. Example: boot to flashdrive to do Acronis backup of SSD; remove SDD, insert spinner; boot again to flashdrive to do Acronis restore to spinner (to test backup); remove flashdrive, boot...
Installation & Setup
Boot UEFI from wake on lan, or convert UEFI MBR to legacy.
Hi all, Currently having a wake on lan issue with a certain computer. The machine is setup correctly but the windows boot information is stored in a 100mb UEFI partition, and when the computer wakes on lan, it will not boot windows, just sit at a blank screen. When it wakes on lan it is...
General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 15:36.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App