Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Yet More cd/dvd driver missing (RFM)

07 Oct 2009   #1

Ubuntu 9.04
Yet More cd/dvd driver missing (post-RFM)

Ok so I think I have a new one. I downloaded a copy of Windows 7 and obtained a key through the MSDNA program that my uni subscribes to. This is a completely legitimate operation that (from what I can see) is putting out the release version of window 7 a bit early. When installing I don't get any "This is beta software, it may break" style messages and while I can't find the version string, I'm thinking that it is what is going to go out to the public.

Through the MSDNA program a downloader gets the iso, and then verifies the CRC so there is no chance of a download error.

So I try to install and every time get "A required CD/DVD drive device driver is missing. (etc)".

Here is what I have tried, roughly in order.

  • Official sata, then raid, then ide drivers from motherboard manufacturer (via flash drive).
  • Using IDE cd drive (liteon) instead of sata cd drive (liteon)
  • Using a usb-based cd drive (optiarec) on different usb ports with various states of other drives plugged in / not plugged in.
  • Using a flash drive to install by copying files from iso. (worked fine. Same cd error message
    • Tried this with various states of including and removing cd drives because I though if installer could not see any drive it may cry.
    • Tried along with above drivers.
    • Tried along with all previous vista installed drivers from drivestore folder and around. (took bloody ages)
    • Tried with other non-official drivers
  • Tried a few cd, ahci, etc drivers from vista.
  • Tried various states of using previous versions (7100 and 7048) drivers.
  • Went back to the sata drive, then the IDE drive with various different bios settings.
  • Tried sata drive on different chipset (I have two different sata controllers on the board). Unfortunately could not turn main sata controller off because I need it for my hdd.
  • Tried various drivers and driver packs semi-official, then anything I could find on rapidshare etc. These included large nforce packs.
  • Tried removing all the sata hdds except the ones I need.
  • Burnt a 7100 dvd which seemed to work fine. Tried cd swapping at various stages of install (i'm getting desperate here).
  • Tried changing boot order as per windows kb
[edit] Also: (gah it deleted my edit)
  • I am running a M2N32-sli deluxe board. It's an epic board with vast amounts of feature but I can't set ahci / ide (etc) mode on it.
  • I don't have the official driver cd for this board any more, but I've tried all the official drivers and they don't work.
  • I'm trying to install onto raided raptors, So I can't install on a different system and move the drives (I could but it would be messy and I'm not quite that desperate yet).

I think thats it I have read every forum thread tried everything I possibly can. The stupid thing Is that in searching for a driver I can look in my large (1tb) volumes, the flash drive, and cd drives and even my raided raptor drives. Everything works fine but because of this (I'm beginning to believe bugged) screen I can't go any further.

To try next:
  • Different methods of flash installation (bartpe instead of straight copy)
  • Bios updates for motherboard / drives (pretty sure running close to top version though).
  • Other ... dirty ... tricks.
I'm supposed to be getting this version as the pre-cutting edge wave of folks who are going to say yer go get this it's awesome and people believe me because I do everything with computers. If I can't get past things like this then lamen folk sure as hell aren't going to be able to.

My System SpecsSystem Spec
07 Oct 2009   #2

Microsoft Community Contributor Award Recipient


Hi kimbecause

Try changing your DVD drive.
My System SpecsSystem Spec
07 Oct 2009   #3

Ubuntu 9.04

Thanks for the response. I have tried 3 different dvd drives - a sata and ide liteon, and a usb optiarec one.

Since posting I have also tried some more disc swapping during the installation and have tried to install at all on two other computers - still the same thing.

I think it's busted.
My System SpecsSystem Spec

07 Oct 2009   #4

Windows 7 x64 HP, Windows 7 HP, Windows 7 Ult

Apparently this is a fairly common problem. Some offerred solutions I've seen:

1. Boot and run install from a USB memory stick. Here's a good tutorial on how to make a bootable USB drive - USB Windows 7 Installation Key Drive - Create

2. Re-burn DVD at slowest speed.

3. Check the assignment of the DVD drive. Don't use "cable select" jumper setup, switch from master to slave for the reader (or vice-versa)

4. Try Microsoft KB solution 314060 - Your CD drive or DVD drive is missing or is not recognized by Windows or other programs

5. Get latest drivers for your IDE drives (apparently you've gone there already.)

Personally, I'd opt for getting a 4G memory stick and going that route. It looks to be the fastest and least hassle.

My System SpecsSystem Spec
07 Oct 2009   #5


I concur with The Schaft. Eliminate the problem by driving around it - USB thumb install.
My System SpecsSystem Spec
07 Oct 2009   #6

Ubuntu 9.04

hmm I tried thumb drive install but has varying levels of dodgyness on the newer versions. Copying from the cd a lot of files are coming up with "The target volume does not support symbolic links" despite the fact that a) the fs does and b) the xcopy flags should have made it copy symbolic links as files anyway.

I tried burning the dvd at lowest speed but had run out of good dvds and my spindle of dodgy dvds wouldn't boot at all.

When I tried the ide drive also I was using master instead of cable select. The usb cd drive didn't have a jumper and the sata shouldn't have mattered.

At the moment trying with other computers has failed so I'm pressing on trying to install from flash, maybe with a mix of 7100 and the 7600 that I'm trying to run. Will post if I get anything to work but apart from that am getting a friend to burn me a copy of his that apparently worked (got the same deal).
My System SpecsSystem Spec
08 Oct 2009   #8

Ubuntu 9.04

Thanks for all the help antman, schaft. The first method described in that tutorial makes it very easy to make all sorts of bootable flash drives, I think I'll use that a lot.

I still can't seem to get it to work though - I think it's something to do with the disk I downloaded through the MSDNAA program. I'm getting another from a friend who got it from the same place and it worked, but I may have to just wait for the disks to come out proper before I can get it to work.
My System SpecsSystem Spec

 Yet More cd/dvd driver missing (RFM)

Thread Tools

Similar help and support threads
Thread Forum
Driver power state failure & Bluetooth driver is missing
First problem: For a couple of day my computer has been running a little hotter than usual, with the cpu being used at 25% when I am doing barely nothing. Lately now it also has been bluescreening me with the driver power state failure label 0.00...9f 0x00...4 0x00...258 and some more but my...
USB to IDE win 7 missing driver-please help!!???
I have purchased two 2.5" IDE hard drive enclosures (thought first one was broken). Whenever i plug in the USB cable, windows 7 tries to install the driver, but does not install the correct driver. I can see in device manager that a mass storage device is plugged in, but I can't access the device...
[Help] Missing USB driver
I use windows 7 ultimate x86. I can not install usb driver. Plz, help me.
Driver missing
Hi i had a virus and i ended up wiping out my operating system, then i bought windows 7 and installed it. But when i did, the display adapter for my laptop screen disappeared. I have been dual screening for awhile because i had an accident and my screen cracked so i've been using an external...
CD/DVD driver missing with Win 7 RC1
I am trying to install Windows 7 RC1 (build 7100) and get a message that "A required CD/DVD drive device driver is missing" while trying to install either 32-bit or 64-bit versions. ISO downloads have the correct MD5 checksums. Computer is Asus P5W DH Deluxe. CD/DVD drive is a Samsung SH-S183L...
Installation & Setup

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 09:55.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App