Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Error code 0x8007045D during Windows 7 Professional x64 Installation

09 May 2013   #11
Microsoft MVP


Hi Colin -

Have only seen Diskpart fail with I/O error before when the HD was faulting. Thought that might warrant testing the HD.

The most common fix for install failures of all types is Diskpart Clean Command. If it won't run there is usually a reason, and that so far as I've seen has been the HD.

There could be an anomaly with the installer which is why that was a good first step for you to give.

OP said he did low-level format with PW CD so if that wasn't Wipe Disk from Disk tab he can do that in place of Clean command, then create an NTFS Primary Active partition which again passes Surface and File check - about everything known to prepare the disk on failed install.

My System SpecsSystem Spec
10 May 2013   #12

Windows 7x64 Home Premium SP1

You say you've changed motherboards - correct. Are your attempting a clean install with a retail version of Windows? or
1) doing a System reimage from your old ASRock motherboard or
2) attempting a clean install from an OEM OS that was activated on the ASRock.

1) or 2) won't work.

If a retail clean install I would suggest you run the WD Lifeguard diagnostics. If you have another HDD then obviously try it.
I know it sounds an obvious thing but did you reset your ASUS BIOS to defaults and download the latest or recent drivers?

Can you get your ASRock motherboard up and running again? If yes and the above fails I'd return your ASUS motherboard. Since you have flashed your BIOS they may balk.

A final point I'd try a straight MBR boot install since you are using only a 1TB HDD.
My System SpecsSystem Spec
10 May 2013   #13

Windows 7 Professional x64

1. I maybe should further mention that the I/O error from diskpart only occurs when i use the "clean all" command, the "clean" command works fine for me. (I don't know if this draws a distinction)

2. I have problems setting up the WD diagnostics tool because i have neither a floppy drive nor a floppy disk. I'm trying to put it on a FAT16 formatted USB-Stick right now but I don't know if I'm destinated to fail with that.

I'm trying to do a clean retail install and unfortunately I can't get my old Asrock mainboard to work, because it isn't able to start the power supply. (I bridged the power button and the 24-pin ATX Connector with a paperclip and the power supply started normally without the mainboard).

Last but not least I have no opportunity to switch the HDD, since it is the only one I have right now. So doing that would require me to buy a new one.

Before I do that, I'm trying to wipe format and partitionate the HDD with PW again and maybe I can get the WD diagnostic tool to run in the meantime.

I rebuilded MBR, wiped, repartitionated and formatted the HDD, sector checked it with PW and chkdsk again as recommended (0 Sector Erros from both), tried to install again and got Error 0x8007045D as always.

Even though I didn't ran the Wd diagnostics yet (still not working with the stick), I really think there is something wrong with the mainboard now.

diskpart is now throwing I/O Errors with both, the "clean" and "clean all" command while every single other partitioning tool
including gparted from Xubuntu's live distro, as well as fdisk, dd, PW and DBAN has no problem at all. I don't know why, but this seems to be some strange "windows-only" problem.
My System SpecsSystem Spec

10 May 2013   #14
Microsoft MVP


Western Digital seems to have taken down their Data Lifeguard CD ISO's and only left floppy support (Hello? ).

I found this download of the CD ISO, which needs extracting before burning the ISO to CD using Windows Image Burner: Western Digital Data Lifeguard CD ISO (extract first)
My System SpecsSystem Spec
10 May 2013   #15

Windows 7 Professional x64

This is interesting. The tool doesn't even find my HDD. With Ide Sata Contoller it recognizes the disk, but when i run quick or extended test it says "Command Error Error/Status Code: 0132".
My System SpecsSystem Spec
10 May 2013   #16
Microsoft MVP


Normally the HD Diagnostics are definitive but if PW Surface Scan and File System Check are okay then it may be an anomaly with WD Diagnostics - possibly the reason they've taken them down from their site. I'm inquiring about that now.

Unless you really want to keep the mobo the consensus seems to be to return it. Have you asked their tech support about the issue, in preparation for RMA'ing it?
My System SpecsSystem Spec
10 May 2013   #17

Windows 7x64 Home Premium SP1

Have you checked your sata cable (try replacing it).
I wouldn't use a Marvell port
Make sure your sata utilities are compatible with the current BIOS version.

I think the basic sata drivers are stock standard Windows - others is this correct?
My System SpecsSystem Spec
10 May 2013   #18
Microsoft MVP


As far as I know, Michael. Have yet to see a SATA driver not in the Win7 installer. Older IDE drivers, maybe.

There also isn't any reason to install mobo drivers as Win7 will decide which ones it wants, which I would stick with unless performance dictates importing OEM.
My System SpecsSystem Spec
10 May 2013   #19

Windows 7 Professional x64

I have put in a jumper on my HDD scaling down the data transfer rate from 6.0GB/s to 3GB/s. Windows expansion is now at 40% and maybe it'll work .
I think the error was caused because I used only SATAII cables, while both, Mainboard and HDD had SATAIII 6GBps Connectors.

Windows is now installed and works perfectly.

Thanks for the support to all of you :)
My System SpecsSystem Spec
10 May 2013   #20

Windows 7x64 Home Premium SP1

Quote   Quote: Originally Posted by Gyrger View Post
I have put in a jumper on my HDD scaling down the data transfer rate from 6.0GBps to 3GBps.
So referring to this
How to physically install, set jumper settings, and set up a Serial ATA, EIDE, or SSD drive in Windows 7, Vista, XP, and 2000
are you saying the default the no jumper default didn't work. Connecting the jumper to pins 5 and 6 worked? It's 3Gb/s not bytes. I know WD say "3Gb/s data transfer speed activated" but you won't get anything like 3Gb/s out of a standard 7200RPM 3.5" HDD. So I'm not sure what the jumper actually does.

I'm a Seagate user for internals so maybe a WD user could explain.

It's good that you seem to have things going.
My System SpecsSystem Spec

 Error code 0x8007045D during Windows 7 Professional x64 Installation

Thread Tools

Similar help and support threads
Thread Forum
Error code 0x8007045D when re-installing Windows 7
Hi, I'm trying to fix my brother's Dell Inspiron N5030 because he couldn't get windows to boot after running startup repair several times. So I made a WIN 7 bootable USB using Wintoflash, booted the usb, and ran the startup repair utility 2-3 times with no luck. Then I tried to re-install...
Installation & Setup
Windows 7 installation on SSD - error 0x8007045D
Hi, I have recently built 2 computers with the exact same hardware, but am having problems installing windows on one of them. I am trying to install windows on a Samsung 840 SSD. On the first computer Windows installed without a problem, but on the second computer I keep getting that error code. I...
Installation & Setup
Windows 7 error code 0x8007045d during clean install.
Hi i am trying to help my friend out he bought his son a emachines em350 netbook with windows 7 installed. For some reason it got messesd up and he tried to do a system restore. Since then when you try to boot up its saying input a password to unlock the harddrive which we dont know. After you...
Installation & Setup
Error code 0x8007045D
I'm having trouble with my hard drive, it's a WD elements 320gb hard drive and when I try to put anything on it or take thing off it it give me this message saying it was unable to do it because of an unexpected error "error 0x8007045D: the request could not be performed because of an I/O device...
Hardware & Devices
Windows 7 - error code 0x8007045D?
I can's get past "error code 0x8007045D" while installing Windows 7. I'm working off the CD Disk that was sent to me. Any help?
Installation & Setup

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 12:05.
Twitter Facebook Google+