Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: attempted to reinstall but gives gpt error, never had error before

26 May 2013   #1

7 home premium 64 bit
attempted to reinstall but gives gpt error, never had error before

I recently had an outage and my OS disk became currupt, so I went to reformat both ssd's and start fresh (I have a pair of ocz vertex 3's for my drives). I from time to time reinstall anyway as to clen up the disks, as I've heard this is healthy for a pc. This time, however, it gives me the GPT error that many others here have encountered, granted under different circumstances. I have changed nothing in my BIOS and don't know how to toggle between the different partition styles as 7 Home Premium 64bit apparently doesn't let you choose. I tried only using 1 ssd at a time, and both give me the issue. I am using the same OEM disk as I always have. Might the reason be some setting that got switched when it was shut down hard by the outage, or might it be a component on my motherboard housing the necessary stuff been damaged by a spike? I'm sorry if I sound primitive with my question.

My System SpecsSystem Spec
26 May 2013   #2


It depends on the exact GPT error. If you had a UEFI BIOS install and are now trying to install normally with Legacy BIOS setting enabled it would error due to previous GPT disk formatting, or vice versa.

Installing Win7 with a UEFI BIOS requires a GPT HDD following these steps to install to UEFI (Unified Extensible Firmware Interface) - Install Windows 7 with - Windows 7 Forums.

If you don't want UEFI but want to install normally to an MBR disk and this is a UEFI BIOS, you'll need to enable Legacy BIOS or Compatibility Support Module in BIOS setup.

Then to install normally to an MBR disk wipe the HD with Diskpart Clean Command to clear any GPT formatting, proceed with normal Clean Install Windows 7. If any further problems report back verbatim error message and step at which it occurs.

Watch this video to better understand the difference between UEFI BIOS vs. Legacy BIOS - YouTube.

In addition look over these steps to learn what works best to get a perfect install, which are same as for Clean Reinstall - Factory OEM Windows 7.
My System SpecsSystem Spec
27 May 2013   #3

7 home premium 64 bit

Ok, it's doing some illogical things. It finally let me install when I allowed it to give me the option to boot from DVD, and let me create a partition, of which I don't know the type as it only gave me the option to create a new one. I first clicked cancel because it said some files are out of order, then first reattemp to select the dtive I was refused, but 2nd reattempt it allowed? Also, it restarted just now for install but only gives the dvd as an option. In case it matters, I am working with ssd's, not hdd's.
My System SpecsSystem Spec

27 May 2013   #4


Same for SSD as HD.

Did you boot into BIOS yet to see if there is a Legacy BIOS or CSM setting indicating it's UEFI?

You mention nothing about the progress of an install if that's what's occurring, even though it will be quite graphic showing progress. If it's already installing and reboots then you don't want to Press Any Key to Boot from DVD as the DVD's role is finished.

Let us know what step in Clean Install Windows 7 there is any failure along with verbatim error. If it allows you to delete all and format your partition for install using the tools shown in Step 7, does it create an EFI Boot partition or just the 100mb System Reserved partition? THis will tell you for sure if it's a UEFI install. If not and you receive the GPT error either install to UEFI (Unified Extensible Firmware Interface) - Install Windows 7 with - Windows 7 Forums, or Bypass UEFI to Install WIn7
My System SpecsSystem Spec
27 May 2013   #5

7 home premium 64 bit

It does have Legacy Enable, which is enabled now and was enabled every time I've done cean and re-installs. It does create the 100mb system file. This is the first install I've had the error warning that the files are not in order. Also, it failed at the point where it restarts and is supposed to go straight to the ssd, not give an option to boot from DVD; it did not show the ssd even there, though bios recognizes both are present. The boot priority sequence is first 2.2 terabyte infinity (no idea what that is, its an MSI board), then ssd 1, then ssd2, then optical.
My System SpecsSystem Spec
27 May 2013   #6


Unplug all other SSD's/HD's and peripherals,

Boot into BIOS setup, reset to defaults, save changes. Then Enable Legacy BIOS, Set target SSD first to boot, set SATA controller to AHCI, Save changes and Exit.

Use one-time BIOS Boot menu key given on first screen to boot into Windows 7 installer DVD or flash stick burned or written using tool and latest ISO for your licensed OS version here.

At first installer screen Press Shift + F10, or enter System Recovery Options to open a Command Box, type:

SELECT DISK 0 (after confirming Windows 7 target HD #)
CREATE PARTITION PRIMARY SIZE=102400 (for 100gb partition, adjust as desired)

Next click Install Now, then Custom install to Clean Install Windows 7 to the partition you created. If it fails then report back at which step and the verbatim error message.

In addition read over these steps to understand the tools and methods which work best to get and maintain a perfect Clean Reinstall - Factory OEM Windows 7. The steps are the same for retail.

After install you can adjust partition size or Create new partitions for data, etc. in Disk Mgmt.You are creating the partition here for the purpose of marking it Active which overcomes certain install failures.
My System SpecsSystem Spec
27 May 2013   #7

Microsoft Community Contributor Award Recipient


it gives me the GPT error that many others here have encountered,
You will only encounter this error, when booting the DVD in Legacy mode, & not UEFI mode.

attempted to reinstall but gives gpt error, never had error before-windows-8-downgrade-006-sb-posting.png

My System SpecsSystem Spec
28 May 2013   #8

7 home premium 64 bit

Well sir, apparently the part of your advice is what did it. I took a step back and then went into BIOS once more, gave the option to load optimized defaults; for the record, my mobo must be VERY basic as ir gives me next to no options you ask about sans Legacy, which the optimized load still enabled. In case you're interested, my mobo is MSI 890GXM-G65. Anyway, that alone seems to have worked though it changed no settings; I made and kept a hand-drawn record of all settings under it before I began having issues and nothing changed. If it isn,t supposed to work under these conditions, please let me know as it might indicate I need to take it in for testing. Thank you for the time you spent on typing everything out for me, and well wishes for ya .
My System SpecsSystem Spec
28 May 2013   #9


Is Legacy BIOS Enabled now or not?

Please post back a screenshot of your Disk Management - Post a Screen Capture Image - Windows 7 Help Forums
My System SpecsSystem Spec
28 May 2013   #10

7 home premium 64 bit

How do I even take a screenshot? I turn my comp on and play games and watch movies and listen to music, again I'm Neanderthal with all of this.
My System SpecsSystem Spec

 attempted to reinstall but gives gpt error, never had error before

Thread Tools

Similar help and support threads
Thread Forum
Win Update Error/ Attempted MS fix not working More ERRORS!
Greetings, I am having issues with Windows Update! First of all when I click the Icon "Windows Update" It actually takes a few moments to get there, which is very unusual! When it does finally come up it shows an "X" on a red shield and says "Check for Updates for your computer - Always install the...
Windows Updates & Activation
Windows error 0x0000225 after attempted clean recovery
Hello everybody; I've been looking through the forum for a few hours with no help so I'm creating a new thread to expose my problem I have a Lenovo G470 with Win7x64; wich after 2 years of use started to do everything really slow, so I tried to use the Lenovo recovery functionality wich was...
BSOD Help and Support
Error 0xc00000e9 (|boot\bcd) i/o error when attempting to reinstall
I purchased the factory cd for my laptop to re-install my os (Windows 7 64 bit) but when I try to boot from it I get an error \boot\bcd, 0xc00000e9, An unexpected i/o error has occurred. It happens when I try to boot from my internal cd-rom drive and also from an external usb drive. I can view the...
Installation & Setup
Run Time Error, an application attempted to load C runtime library in
Hi There, Not sure if its the correct section :( :o This is the msg I get on start up Plzz help Thanks
Hardware & Devices
Outlook Error: The attempted operation failed. An object could not be
Hello I have an error using Microsoft Outlook 2010. This happens every time I try to reply or forward an email. I get an error that says, "The attempted operation failed. An object could not be found." I am not running any add-ons. I have read that I need to make sure that I am using...
Microsoft Office

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 17:06.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App