Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: New build started going to windows repair on startup, but reboot works

20 Aug 2013   #11

Win 7 Pro 64-bit 7601

You say you moved the old partition from a disk to another in the posts above. Is that correct?

I'm another system builder, and most of the times when I move an OS to another disk I image the entire disk.
And if it fails I image the whole old disk sector-by-sector (any self-respecting imaging program can do it if needed).
All times I tried to move a single partition with the OS on it the result was a fubar with similar issues like booting only some times or giving random errors at boot and trying to boot-repair without success (I generally have very little faith in boot-repair), and I had to restart from scratch.

Another interesting piece of info is that mobo-controlled raids are a pain in the backside unless you are working with server hardware, it isn't the first time the bios's RAID controller module is worthless or too buggy.
In some extreme cases I had to resort to BIOS modding to swap the crappy bios RAID module with a working one, with the guidance found in this forum. Which is also a good place to ask your question too, being mostly RAID-oriented.

My System SpecsSystem Spec
20 Aug 2013   #12

Windows 7 Professional x64

The original OS was installed on a smaller test drive (160GB) with the intention of moving it to a new 160GB when I had the best image. I went through several clean installs before coming up with that perfect one. This was not a sector by sector image, but since I'd tested it across multiple drive types to make sure it worked, I was happy with it being the one to use. The brand new 160GB I ultimately put it on started throwing bad block errors, so I ran it, the intended mirror drive, and the spare I ordered through factory diags and 2/3 failed. Since smaller drives are hard to find, I decided to go with larger drives and just keep the original partition size. Customer wants WD only, and I've found Blue is terrible for mirroring, so I'm either going black or red. Red won out based on some good articles I found. I pulled that original image to the new drive with it's original partition size, so yes to your question about moving it.

I got the system to the point where both arrays were stable and the base apps were installed. No issues at all, so imaged it again. I deliver the system to the site, and when I fire it up, it goes into the loop described. I check all the hardware, connections.. all the typical stuff and everything looks good. Since I could get the system to boot with a hard reset, I left it up and researched the issue to find nothing that matched the symptoms.

Fast forward and the issue clears magically. I do everything I can think of to try and replicate it.. nothing. I tested known good images with different drives, old images with different drives.. still nothing. I did this testing with and without the arrays attached on every scenario, so that just isn't part of this issue.

I've run the WD diags on all the drives currently in the machine and they all passed. The system is running fine with no issues, no errors in logs, arrays are happy, customer is happy and my wallet is happy.

I've only read about BIOS modding, but never had the guts to mess with it. Since I couldn't replicate the issue with the arrays connected (and disabled in BIOS), and the fact that it worked perfectly when I left to deliver it, all I can think of is something happened in transit somehow cleared when it "settled" onsite. I spoke to another guy and he said temperature changes can cause weird stuff, but with nothing to go on, that just sounds weak.

Long winded posts aside, I'm as stumped as I've ever been. I was hoping to find something borked so at least I could fix it and move on. You raise a valid point about the sector by sector imaging though. I've used it in the past, but it just seems to take up more space and yield the same results, so I shy away from it unless an image fails in testing. I'm not sure if it matters on this one, but if it reoccurs, that's a viable next step to troubleshooting, especially since I still have the original install on the 160GB drive I used to build the image.

Do you think maybe doing a sector by sector image of that and testing with it would be a good use of time? If nothing else, maybe a bit of peace of mind?
My System SpecsSystem Spec
21 Aug 2013   #13

Win 7 Pro 64-bit 7601

Maybe I didn't explain the question well enough. Cloning/imaging a partition and cloning/imaging a whole drive are two different options on all self-respecting software I used.
Either can be moved to any sized drive as long as the actual data would fit. The sector-by-sector copy is another option I rarely use myself, but was necessary sometimes as nothing else was stable.

What of the two bolded options did you choose when you made that disk image?

I usually clone/image the whole disk, because all the times I clone/image OS partitions only it becomes unstable or unreliable in similar ways to your issues.

all I can think of is something happened in transit somehow cleared when it "settled" onsite.
BIOS-controlled raids can be flaky like that. May work or not depending on unknown reasons. Most common is that unless both drives are exactly the same model and size it acts weird.
I suppose it's because the mobo manufacturers add that as an afterthought and don't thoughly test the code.

Never had these issues with (decent) RAID cards. Which would be my first choice for any RAID.

Bios modding is relatively dangerous and I'm not keen on frying boards for lulz, but can do it if no other choice is available *chough* mini-itx gaming board *cough* or if customer asks for it. Although swapping a RAID module is relatively easy, as far as bios modding goes.

Bottom line: if you managed to solve it somehow and everyone is happy it could have been a one-time event caused by whatever (yeah it happens to everyone), if it eventually stops working again, you have something to blame and a possible solution.
My System SpecsSystem Spec

21 Aug 2013   #14

Windows 7 Professional x64

Acronis TI, whole disk.

I'm to the point where I am just going to call it a one off and let it go. I didn't "solve" anything, which is what kind of irks me. Since I didn't do anything and it could be replicated when it was occurring, but not on return visit, I hate not knowing root cause.

I do appreciate the input for sure.
My System SpecsSystem Spec

 New build started going to windows repair on startup, but reboot works

Thread Tools

Similar help and support threads
Thread Forum
Computer can not boot, loops at startup repair nothing works
Hi. I should start of saying that i have no computer experience what so ever. After i restart my computer after uninstalling comodo firewall. My computer was still fine so i shut it down. When i came back to it, it started looping at startup repair. I have tried system restore, try formatting it...
General Discussion
Startup Repair to infinite reboot loops, Repair errors 0x5 & 0x490
Firstly, thanks for reading. My PC runs Windows 7 x64. I built it myself about a year ago for gaming. Occasionally running games I would BSOD and it would suck. I'd update all my drivers or try some game-specific fix and usually if I didn't fix it, I would just start playing something else...
General Discussion
Startup Repair Loop, ASUS/INTEL/RADEON PC build
hi there, I'll describe my initial problem first: Packard bell PC imedia something, radeon sapphire 5670 HD GPU upgrade, recent (Jan 2012) windows 7 64 bit custom install upgrade from vista 32 bit, during which i backed up all files on a Samsung external hard drive, then did a complete hard...
BSOD Help and Support
startup repair. nothing works
I've read other posts about start up repair and tried what the others are told to fox their problem but nothing works for me. When I turn my computer on I can choose start up repair or start normally. Both options go to the start up repair. I have left it on for hours and nothing happens. I've...
General Discussion
BSOD and infinite reboot until startup repair booted
Hey all, New to the seven forums, but no forum newbie here ;) but i'm having some trouble with my new Radeon HD 5570 drivers. I've installed 11.3 and the system would crash and begin an infinite reboot until windows startup repair booted. I am able to do a system recovery and get it working...
BSOD Help and Support

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 00:18.
Twitter Facebook Google+