Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Failure to install windows 7 pro x64 on uefi Mobo

16 Nov 2013   #1

Windows 7 Professional x64
Failure to install windows 7 pro x64 on uefi Mobo

Hello all:

I have been banging my head on this one for far too long. I have a new custom build with the following specs.
Mobo: Asus P8H77-M LE (chosen by customer for built in raid)
1) i5-3330 3GHz LGA 1155 Processor
Memory 2) Mushkin Silverline 4 GB sticks (1 Kingston 2GB stick Installed now for installation Purposes)
2) Seagate 1TB Hard drives in raid 1 with 250Gb for OS and remainder unpartioned at this time.
850 watt raidmax power
Asus DVD
OEM Windows 7 Professional x64 DVD
Asus P8H77 Driver DVD

Following the tutorial Here I am trying to install Windows 7 on this "New" machine. The customer built this machine himself and installed windows 7 32 bit and could not figure out why he only had 3.5 GB memory. I showed him the mistake as as I had 3 Windows 7 pro x64 I felt the should be no issue reinstalling it with x64. he barrowed my disk and returned shortly with no luch as he could not install and could not figure out the issue. I have tested all the hardware and "zeroed" the drives using DBN. I set up raid 1 giving the OS 250GB and the remainder as data (music fanatic) raid 1 Mirrored. I boot from the uefi DVD after turning off secure boot. Install and all goes well until reboot to finish installation. Now originally I received 1 error that said Windows could not be installed on this hardware. then rebooted and restarted at the install windows screen. I proceeded to DBN the drive and reinstall figuring the 32bit might have left some pieces. (how he got 32bit on eufi I have no idea)

Now the error after 3 tries and several cursing sessions later is " Windows Boot Manager" Windows Failed to start Error 0xc000000d. An Unexpected error has occurred.

I tried to use bootrec to find the windows installation on c: but of course it is not there nor anywhere else as the install never finished. I have rechecked the uefi 3 times just to make sure the secure boot is off and it is. I have never had this much issue with a raid or seven before.

Any help is appreciated.

I should also mention that I have tried to boot to the Non-uefi DVD drive that is listed in the UEFI Interface and that install also fails but with the Cannot be installed on this hardware error.

My System SpecsSystem Spec
16 Nov 2013   #2


Why does he want RAID? We see nothing but problems with RAID which confers no benefits and often can lose everything in RAID1 if a HD dies.

Try UEFI install to single HD plugged in alone, boot UEFI DVD to delete all partitions and try again.

If that fails then Bypass UEFI to Install WIn7
My System SpecsSystem Spec
18 Nov 2013   #3

Windows 7 Professional x64

I have used raid 1 (mirrored) on many computers and not had an issue if 1 drive fails. in fact it has saved my own but a few times. I will try with raid off and see what happens.
My System SpecsSystem Spec

18 Nov 2013   #4

Windows 7 Professional x64

Seems you were absolutely right Greg. I appreciate the help. I have convinced the person to use the second drive as Backup / Data and it is all set. 107 updates to go and it will go to it's new home.

I find it funny that the raid had an issue. Could it be a UEFI VS RAID issue? If so you would think there would be a better solution.
My System SpecsSystem Spec
18 Nov 2013   #5


It's been the same way since beta: nothing but problems with RAID, leading to endless troubleshooting often fails. Yet installing without RAID always resolves it and usually on the first attempt.

UEFI is not quite as bad, but failure can be just as stubborn to resolve, repairs are complicated, and things are always resolved quickly by Bypassing UEFI to Install WIn7.
My System SpecsSystem Spec
18 Nov 2013   #6

Windows 7 Professional x64

I found out from both Intel and Asus that the issue can be resolved by using a PCI raid card instead of the built in raid. Seems there is an issue with the Asus built in raid drivers being designed for use with Win 8 and not 7. Even though the Mobo was rated as 7 compatible. (just not the raid drivers). Asus does not offer a raid driver for 7 for this mobo. (at least that's what the ASUS tech announced). Asus is sending the customer a $50.00 gift card for the trouble and will trade out his board if he wishes. The customer at this point is ok without the raid and is happy with the machines performance so as far as I see it is solved. Too bad Asus did not include an option for 7 raid drivers as this Mobo has a great flash and save option on the UEFI interface. I like Asus boards just disappointed at their shortsightedness and the jumping on the 8 bandwagon without thinking of the 7 people out there.

Thanks again for the help Greg. Hope you have a great week and I'll try to check in later.
My System SpecsSystem Spec

 Failure to install windows 7 pro x64 on uefi Mobo

Thread Tools

Similar help and support threads
Thread Forum
Asus N76 UEFI - W7 64 Install Hangs on Logo (DVD UEFI Boot)
**** This issue has been resolved **** **** Look at Page 4, posts 4 and 5 **** **** You need to enable Legacy MBR by Enabling Launch CSM in the EFI Setup **** Hello all, This is my first post. I am a Windows 7 user and now (against my will) Windows 8. I bought an ASUS N76 laptop...
Installation & Setup
How to use UEFI boot to install windows 7?
Hello, I bought a 3TB harddisk and I can only use 2TB of it I read some forum and it said I have to install windows by uefi boot And change format from mgb to gpt so I can use 3TB My motherboard is Asrock H81M I want to know how can I use uefi boot, I am total idiot in computer, thanks for...
General Discussion
Boot failure on UEFI system.
I am having the same problem as detailed here: Am I to understand that the best fix is to convert all partitions to Primary, using GPT? This is driving me...
Installation & Setup
Does my mobo support uEFI?
Hello SF members, I see today uEFI is very popular, a lot of people use it... I have ASUS P8H61-M LX2 (it have modern BIOS utility, etc. ). So, does my mobo support uEFI? And what is pros and cons of uEFI? I found that I need GPT formated HDD and GPT isn't recommend for HDD who have...
Hardware & Devices
What's the benefit of UEFI and install Windows in UEFI mode?
I am not sure if this subforum is the right place, if not, pleases help me transfer to the right forum... I recently just build a new setup with Asus P8Z77-V LK, this motherboard comes with UEFI boot and legacy BIOS boot support. So I tested install windows 7 in both mode, and I didn't find...
Installation & Setup
Moving HD/Win 7 Install after MOBO failure, possible?
Ok, a little background: I purchased an HP Pavilion P6214Y Desktop about two years ago. System ran well, perhaps a little hot from time to time, until one morning (shortly after the warranty period, of course) it froze and and started returning "No bootable media found" errors on startup. I...
Installation & Setup

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 23:20.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App