Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Need Help getting dual boot working!

27 Oct 2009   #11
torrentg

7600.20510 x86
 
 

Wow, sorry FrisbeeJohn. I missed your post with the boot.ini info when I last visited.

http://mirror.href.com/thestarman/asm/mbr/bootini.htm

"The "rdisk(n)" parameter is for the HDD drive number, where n=0,1,2,... depending upon which physical drive this HDD is in your system."


Try this out. You will have to take off read only permissions to save it. Doesn't matter which OS you do this from.

[boot loader]
timeout=30
default=multi(0)disk(0)rdisk(1)partition(1)\WINDOWS
[operating systems]
multi(0)disk(0)rdisk(1)partition(1)\WINDOWS="Microsoft Windows XP Professional" /noexecute=optin /fastdetect

Try the above and let me know how it went. If not, try rdisk value of 2 for each line.

It's a good idea to copy boot.ini, ntldr, ntdetect.com all to root of XP drive.


My System SpecsSystem Spec
.
28 Oct 2009   #12
SIW2

Microsoft Community Contributor Award Recipient

Vista x64 / 7 X64
 
 

Hi,

In Disk Management , rt click the 100mb partition and give it a drive letter, S is good.

Unzip this and put the 3 files ( not the folder ) on the 100mb partition.

xpbootfilesSIW2.zip

Open Easybcd, go to Add/Remove entries.

Select S in the drive drop down box at the bottom.

Then select Windows NT/2K/XP/2K3 in the Type box.

Click Add Entry.



Give it a drive letter
Quote   Quote: Originally Posted by frisbeejohn View Post
I have spent a couple hours reading how-to's and trying to get my dual boot up and running, but I still can't get it

What I have: XP on a 250gig drive and W7 on a 60gig SSD. When I start my comp it goes straight to W7. I can force it to go to XP if i switch my bios to boot off the XP drive. I don't have a XP CD, but I do have a W7 DVD

What I want: Boot screen with Windows 7 as main with XP in a close second.

Here are some pics that may be helpful:

******** - Fast, Free Image Hosting and Photo Sharing
******** - Fast, Free Image Hosting and Photo Sharing


My System SpecsSystem Spec
28 Oct 2009   #13
gregrocker

 

+rep

SIW2 to the rescue!

That Disk Management snip wouldn't open for me so I didnt' catch the dreaded 100mb holding the boot.
My System SpecsSystem Spec
.

28 Oct 2009   #14
frisbeejohn

Windows 7 and XP
 
 

Here is where im at:
I tried both siw2's and torrentg's advice, niether worked or changed the situation. Still getting the missing NTDLR.
under bios my HDD is listed as "IDE channel 4" if that helps. I did change the rdisk value to 4 to try that, no effect.

here is what my easyBCD looks like
Entry #1

Name: Windows 7
BCD ID: {current}
Drive: C:\
Bootloader Path: \Windows\system32\winload.exe
Windows Directory: \Windows

Entry #2

Name: Windows XP
BCD ID: {f6c2cfdf-bf80-11de-81d6-81fa34a7acda}
Drive: S:\
Bootloader Path: \NTLDR
My System SpecsSystem Spec
28 Oct 2009   #15
gregrocker

 

The fact that the 100mb system reserved partition is there on a dual boot like this means that XP drive must have been plugged in after Win7 was installed. As you can read here, the 100mb isn't supposed to be installed when Win7 is correctly installed last and configs a dual boot with a prior existing OS which is on the drive or plugged in.

You can make sure XP is marked active (as it shows now), delete the 100mb partition, and boot into the Win7 installer Repair console to run startup repair - several times if it doesn't boot after startup. The 3 boot files need to be in XP's root if you do this.

But an easier and safer way which will not possibly lose the ability to boot is to run a Win7 repair install from the desktop. In Win7, the repair install is an Upgrade install that keeps files, programs and settings in place but replaces the OS and reasserts the boot config. This has always worked for me as a last resort to repair boot issues. However I have never had the 100mb present in such a situation so we will have to see if Win7 can reconfig such a mess with a repair install. At least you won't lose the ability to boot into Win7 since a repair install never does.

Afterward we will see if it was able to reconfig your dual boot correctly with the dreaded 100mb partition in the mix. You'll need to reactivate, too, which is no problem from the link at Computer>Properties.
My System SpecsSystem Spec
28 Oct 2009   #16
SIW2

Microsoft Community Contributor Award Recipient

Vista x64 / 7 X64
 
 

It will only work if you keep DISK0 as the first HD in Bios boot order.

Post a screenshot of the contents of S.

Quote   Quote: Originally Posted by frisbeejohn View Post
Here is where im at:
I tried both siw2's and torrentg's advice, niether worked or changed the situation. Still getting the missing NTDLR.
under bios my HDD is listed as "IDE channel 4" if that helps. I did change the rdisk value to 4 to try that, no effect.

here is what my easyBCD looks like
Entry #1

Name: Windows 7
BCD ID: {current}
Drive: C:\
Bootloader Path: \Windows\system32\winload.exe
Windows Directory: \Windows

Entry #2

Name: Windows XP
BCD ID: {f6c2cfdf-bf80-11de-81d6-81fa34a7acda}
Drive: S:\
Bootloader Path: \NTLDR
My System SpecsSystem Spec
28 Oct 2009   #17
torrentg

7600.20510 x86
 
 

IDE channel 4 could = 3

There's a 0 device or, meaning, placeholder to take into consideration.

0, 1, 2, 3

4 integers gets you to 3
My System SpecsSystem Spec
28 Oct 2009   #18
gregrocker

 

SIW2 and torrentg:

Why do you think the 100mb is there on a dual boot? Is it causing the problem?

Would a repair install of 7 sort it out, reasserting the dual boot?
My System SpecsSystem Spec
28 Oct 2009   #19
frisbeejohn

Windows 7 and XP
 
 

Ok here is a snip of the S content, should be no surprises here:
******** - Fast, Free Image Hosting and Photo Sharing

Bios looks like this:
IDE channel 0 master: none
IDE channel 0 slave: none
IDE channel 1 master: none
IDE channel 1 slave: none
IDE channel 2 master: Agilty SSD
IDE channel 3 master: none
IDE channel 4 master: WDL HDD
IDE channel 5 master: DVD drive
My System SpecsSystem Spec
28 Oct 2009   #20
chuckr

XP_Pro, W7_7201, W7RC.vhd, SciLinux5.3, Fedora12, Fedora9_2x, OpenSolaris_09-06
 
 

Quote   Quote: Originally Posted by frisbeejohn View Post
SIW2,

'boot.ini' needed here?
My System SpecsSystem Spec
Reply

 Need Help getting dual boot working!




Thread Tools




Similar help and support threads
Thread Forum
Dual Boot not working
I recently reformatted and reinstalled Windows 7. I have another drive with Windows XP on it. Before reinstalling 7 it offered to boot either Windows 7 or "Older Version of Windows". Now it recognizes the drive, it even recognizes it as being named XP but it will not offer to boot to XP. I tried...
Installation & Setup
Dual Boot mouse not working
I built a new comp. Sys whith HD,Sound Card, Video card Ect. I put Win 7. Installed Win 7 on the new HD got it all set up, put the old HD with XP on it and got it to dual boot. The problem is when I boot into XP users screen the mouse or key board doesn't respond. Can that be fixed? Or can I...
Hardware & Devices
Dual boot using VHD not working
Hi all , firstly i'd like to say this forum is the BEST it has helped me out on more than a few occasions! Secondly a little background , i am a junior IT tech so can build pcs etc but a lot of the command prompt stuff goes over my head! Here's what i wanted to do - have windows 7 ultimate...
Installation & Setup
Internet not working with dual boot
Hi, For work purposes, I dual boot windows 7 and ubuntu. Ubuntu made yesterday an upgrade to version 10.04. Everything went ok, but when I rebooted in Windows, it informed me that it cannot connect to the internet because the cable is not plugged in. STRANGE, because in Ubuntu everything's...
Network & Sharing
Dual boot-Stopped working!
Hi. I've been running a dual boot with Vista x64 and W7 x64. I've been doing this for a while and am presented with a choice between W7 and Vista at boot. Today I tried to boot into Vista and I can't move the choice with the keyboard arrows. I cannot choose Vista (2nd choice) and the up down...
Installation & Setup
Dual boot not working
Before installing win7 I was running a dual boot XP Pro set up with each copy of XP being on itís own disc drive. I installed win7 on one of my discs over the top of the XP system. Win7 runs fine but the copy of XP on the other drive does not boot. At startup time after I select XP in the boot...
Installation & Setup


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 09:03.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App