Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: I have lost the facility to press f2 or f12 on boot!

20 Mar 2014   #11

Windows 7

Well I haven't found the Utilities folder, but I have found the HW Setup file, run it and selected Default, and got the slow BIOS back!
I then ran my recovery disc and did a factory reset of Windows, BUT the Ubuntu loader screen still appears on boot up. Please, is there any way of deleting the Ubuntu, as I would like my machine to be exactly as it left the factory - just Windows 7?
It's very kind of everyone to help me as above - I just have this last thing to sort now, and hope there may be an answer to that!
Many thanks,

My System SpecsSystem Spec
21 Mar 2014   #12

Multi-Boot W7_Pro_x64 W8.1_Pro_x64 W10_Pro_x64 +Linux_VMs +Chromium_VM

Glad to hear you found the HW Setup file and can use slow BIOS again.
You should add the Toshiba Laptop Model# (C660) to your SF specs.
Then folks here trying to help you could look up specific instructions for your laptop.

You should post a disk management screen shot of your PC:
Disk Management - Post a Screen Capture Image

Dual booting with Linux (Ubuntu) has it's own set of issues from what I know.
I think you are using the Linux GRUB booter now ...

Here is a tutorial for removing an OS from a dual boot PC.
It's for 2 Windows OSs, so Ubuntu may have some special differences.
It should give you an idea of what's involved, and you can post questions in that tutorial if you want to.
Dual Boot - Delete a OS

I think you need an installation expert now, and maybe this thread should be moved to the "Installation & Setup" SF forum.
I'll ask others for help about that ...
My System SpecsSystem Spec
21 Mar 2014   #13

Windows 7

Hi. I went to this site which I found by Googling - How to Erase Ubuntu: 10 Steps (with Pictures) - wikiHow , and managed to get the machine to now boot up in Windows, which is what I wanted!
Many thanks, David, and all the others above, for help with this.
My System SpecsSystem Spec

21 Mar 2014   #14

Multi-Boot W7_Pro_x64 W8.1_Pro_x64 W10_Pro_x64 +Linux_VMs +Chromium_VM

You're welcome and glad to hear you fixed it.
Thanks for posting the solution.
My System SpecsSystem Spec
21 Mar 2014   #15
Microsoft MVP


Wipe the HD with Diskpart Clean Command

Then do a the vastly superior Clean Reinstall - Factory OEM Windows 7.

No tech enthusiast would run the bloated factory preinstall larded with crapware and useless duplicate utilities which interfere with better versions already built into Win7.
My System SpecsSystem Spec
28 Feb 2019   #16

Windown 10

I couldn't access boot menu on a Toshiba Satellite p50t-B to install windows. I tried EVERYTHING f2 and f12 didn't work. Eventually I found out it was stuck on Hibernate mode and the hard wired battery was keeping it in that state. I had to press a tiny button on mother board next to memory, that fixed it. Unplugging battery might as well.
My System SpecsSystem Spec
28 Feb 2019   #17
F22 Simpilot

Windows 7 Ultimate x64

The cure all would be to clear CMOS. Unplug the computer. Press and hold the power button for 30 seconds. Remove the CMOS battery. Or simply use the reset CMOS button on the motherboard.

BTW- Old thread.
My System SpecsSystem Spec

 I have lost the facility to press f2 or f12 on boot!

Thread Tools

Similar help and support threads
Thread Forum
MBR error 1 press any key to boot from floppy
Hi, I installed a Seagate 4TB hdd last week adding to the 2TB WD & partitioned it into two drives. I used Seagate DiscWizard to install it. I didn't move files until yesterday onto the new drive & all seem to go well. It wasn't until this morning when I turned the Pc & got the message (MBR error 1...
Hardware & Devices
Multi-boot facility gone
I USED to have, on boot-up, the option of selecting either Windows 7 or an older system. Windows 7 was the Primary system, but I had XP French on a second drive, and XP English on a third. The C Drive with 7 on it suffered a sudden catastrophic failure, and I had to replace it with a new drive...
Installation & Setup
Boot process hangs until I Press F1 key
Can someone tell me how to stop the boot process from hanging-up until I press the F1 key. After I press the F1 key the process resumes until the Windows 7 login screen appears. How can I stop the boot processs from requesting I press the F1 key?
Installation & Setup
press any key to boot
hi there, this post was a bit similar to one last august .. when i try and load a win 7 or vista c.d. the same things happen on 3 different units, a sony vaio laptop, a dell 1750 laptop and a dell optiflex desktop. here it is. i have wiped the hard drive formatted using a piece of softwere. i...
General Discussion
Lost Dual Boot Screen?...Lost Windows 7
I have Vista Home Premium 64 bit and I downloaded 64 Bit RC Windows 7 and did a clean install on another partition of my hard drive. Dual boot was working for about 4 days then all of a sudden it doesnt come up any more. The partition is still there with Windows 7 installed on it but its not...
General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 09:40.
Twitter Facebook