Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Windows 7 "Does Not Like RAID?"

27 Apr 2014   #11


How much more clear could we have been?

If you insist on trying to install Win7 in dated RAID which confers no benefits and has never been anything but trouble seen here for all five years of Win7, then try Overcoming Windows 7 Installation Failures - Windows 7 Help Forums

My System SpecsSystem Spec
27 Apr 2014   #12

Win 7 Pro 64
Boy Was I More Tired Than I Thought


My apologies!

Thank you for not just ignoring my post. You had good reason.

My first sentence should have included the following words:

I want to install Windows 7 on a single SSD which may need some attention before it can be used.

I am trying to follow your advice.

Before I try again using the advice in your tutorial, is there anything I can learn from what was installed by the failed attempt? If not, I will use the Command Prompt instructions you give to reformat the disk.

I did mention that the 8 Gb of RAM I installed shows as 3.5 Gb when I run the Upgrade Report utility from MS. You do say memory issues may cause bad installs.

Today I did see a post suggesting that I may have to upload a driver for my new SSD. Does this make sense or was it someone uniformed?


My System SpecsSystem Spec
27 Apr 2014   #13


If you haven't tried installing to the single SSD yet then there's no need to wipe the drive first which is more of a troubleshooting step for Overcoming Windows 7 Installation Failures which does not apply here yet until you have installation failure.

So just follow the steps for Clean Install Windows 7 deleting all partitions using the Drive Options during Steps 7 and 8, which is all that's really needed to get it ready for a clean install.

Does the RAM all show up in extant OS? if not and it doesn't all show up in the new install I would try reseating it, checking for debris in the slots, make sure it is spec'd and installed correctly, then if still necessary test RAM - Test with Memtest86+ following the steps in tutorial to test sticks and slots.
My System SpecsSystem Spec

27 Apr 2014   #14

XP Pro (x86) | 7 HP (x86) & (x64) | 7 Pro (x64)

Hi baumgrenze

Good decision to follow Greg's advice.

I have a Custom rig with SSD + 750gb HDD + external 1tb HD.
Win7 Home Premium 64bit (on SSD) boots quicker than I can blow my coffee and dare to sip.
Start times for applications also on the SSD are <1 second.
The 3 XP rigs I have are not in the race.
My System SpecsSystem Spec
27 Apr 2014   #15

Win 7 Pro 64

Thank you, Gregrocker,

The 8 Gb of installed memory shows up in XP x86 as 3.5 Gb, not 4. I mentioned it because the answer might be obvious to you and a few hours of searching for me.

Should the Win 7 install process find functional (if not the most recent) drivers for fundamental devices like the Realtek RTL8111B Ethernet Controller, the P35 chipset, and the ICH9R controller hub which are on my motherboard. I ask because Gigabyte provides driver downloads that are older than those listed as the most up-to-date on Realtek's and Intel's websites. Is what I really want the most current driver for Win 7 x64. Might I want to update them after the install if the install process provides something that works. As I recall the files downloaded from Intel are *.exe files that need to run on a booted system. I may have all this wrong. I'm having difficulty keeping everything I've read straight in my head.


My System SpecsSystem Spec
27 Apr 2014   #16


32 bit (x86) can only use about 3.5 gb RAM but some is used by hardware so it's okay to use 32 bit on 4gb of RAM or less. But for 4 gb or more RAM you must use 64 bit to have it use all of the RAM.
My System SpecsSystem Spec
28 Apr 2014   #17

Win 7 Pro 64


Thanks for the explanation.

Have you ever used Kim Henkel's ZTree for windows? If not, take a look at:


I checked one of the drives from my failed install and found 43 *.log files and 411 *.txt files. When I logged the drive I was prevented from seeing part of the file structure, i.e., ZTree reported "G:\Documents and Settings\*.* Access Denied [5]"

Here’s a ZTree catalog of the *.log files

Disk Volume: 4-28-14 10:54:08 Page 1
Available space 105,476,378,624 bytes
64,543 logged files using 26,971,204,476 bytes
10 tagged files using 2,949,735 bytes

Path: G:\$WINDOWS.~BT\Sources\Panther
2 tagged files using 233,002 bytes

4-19-14 21:38:55 194,890 .a.. setupact.log
4-19-14 21:38:43 38,112 .a.. cbs.log

Path: G:\Windows
1 tagged files using 17,488 bytes

4-19-14 20:41:17 17,488 .a.. setupact.log

Path: G:\Windows\inf
3 tagged files using 2,207,536 bytes

4-19-14 20:41:01 1,962,005 .a..
4-19-14 20:40:29 18,555 .a..
7-14-09 0:44:10 226,976 .a.. setupapi.offline.log

Path: G:\Windows\Panther
2 tagged files using 487,332 bytes

4-19-14 21:38:43 38,112 .a.. cbs.log
4-19-14 20:41:16 449,220 .a.. setupact.log

Path: G:\Windows\Panther\UnattendGC
2 tagged files using 4,377 bytes

4-19-14 20:54:28 1,109 .a.. setuperr.log
4-19-14 20:54:28 3,268 .a.. setupact.log

I think that this might be a brief, significant explanation of the failure. 'Gathering' and copying and pasting all the log files into Word in landscape mode gave a 585 page file, far to much for anyone to try to read and digest.


2014-04-19 20:41:16, Error [windeploy.exe] Setup.exe failed, returning exit code [0x1f]
2014-04-19 20:41:16, Error [windeploy.exe] Failure occured during online installation. Online installation cannot complete at this time.; hr = 0x80004005
2014-04-19 20:48:25, Error [windeploy.exe] Found failed generalization state [6] --> system is in an invalid state
2014-04-19 20:48:25, Error [windeploy.exe] Failure occured during online installation. Online installation cannot complete at this time.; hr = 0x8030000c
2014-04-19 20:51:52, Error [windeploy.exe] Failure occured during online installation. Online installation cannot complete at this time.; hr = 0x8007000a
2014-04-19 20:54:27, Error [windeploy.exe] Found failed generalization state [6] --> system is in an invalid state
2014-04-19 20:54:27, Error [windeploy.exe] Failure occured during online installation. Online installation cannot complete at this time.; hr = 0x8030000c

In G:\Windows\ntbtlog.txt I ALSO learned this which might be significant:

"Did not load driver @netrtx64.inf,%rtl8168.devicedesc%;Realtek RTL8168B/8111B Family PCI-E Gigabit Ethernet NIC (NDIS 6.20)"


My System SpecsSystem Spec
07 May 2014   #18

Win 7 Pro 64

I will close this thread. The opening title no longer applies to the questions I have remaining. I hope that the moderators agree.
My System SpecsSystem Spec

 Windows 7 "Does Not Like RAID?"

Thread Tools

Similar help and support threads
Thread Forum
Changing windows boot drive sata config from "raid" to "ahci"
So I have an AMD A88X motherboard in my htpc. For a few reasons I want to change the bios config for the sata controller from RAID to AHCI. I followed the instructions in this article: to have windows load the ahci driver, but now I can't...
New Mobo, pre-exisintg raid 0 drives did work, now says "Initialize"
Hello, I had a mobo go bad so I replaced it (Asus P8Z68-V Pro/Gen 3 replaced by Asrock Extreme 4 Z67). All went well at first but my raid drive switched drive letters from E to D. I changed it to E in disk management and all my programs worked fine as did the raid drive. NOTE: Win 7 stayed on my...
Hardware & Devices
Help with Software Raid: Raid over file system "FlexRAID"
Hello Gurus Finally coming back here as i cant get help anywhere else for past 3 or 4 days i am trying to get a software raid to work but it is not happing and i am not getting anywhere. What i am trying to do: Simple i am trying to setup a Software Raid over file system with paid...
Need to add "TASKBARS" (MSese for "Launchpads", "Docks" NOT "Toolbars"
My office just upgraded, and I can no longer use Windows XP. On this system, I was able to add a separate taskbar to facilitate quick access to commonly-browsed folder locations on our vast network, and another one expedited the launching of useful programs and lists. Each task on each taskbar...
General Discussion
Fixed "Unable to load RAID drivers for Windows 7 installation"
Hi Everyone, I am currently attempting to install Windows 7 on an SSD RAID Array, and I have encountered several issues (this has been a one step forward, two steps backward affair). The issue that I am currently facing is the fact that I am unable to load RAID drivers during the OS...
Installation & Setup

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 21:09.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App