Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Setup was unable to create a new system Partition

11 May 2014   #21

64bit Win 7 Pro

Ok. I think I have done it all... I formated whole HDD
Did the diskpart clean create active etc in many different variations.
Still same error.
I have 1 partition, there is nothing much I can change in Bios only Achi I could set is Raid.
No UEFI anywhere. No secure boot....
Can't find Csm or Legacy mode (I assume it's where you chose how to boot USB)

My System SpecsSystem Spec
11 May 2014   #22


You probably don't have a UEFI BIOS then so not sure why you said you have same situation as this thread..

Try resetting BIOS to defaults then SATA to ACHI. Delete all partitions during install.
My System SpecsSystem Spec
11 May 2014   #23

64bit Win 7 Pro

Did reset to defaults.. Can't find anything called UEFI
My System SpecsSystem Spec

11 May 2014   #24

64bit Win 7 Pro

Could it be that I can't install win 7 sp1? Too old Bios? I might try to upgrade Bios tomorrow.
Maybe I should try win 7. I had it before and was able to install without any problems.
My System SpecsSystem Spec
11 May 2014   #25


Did you try setting BIOS to AHCI to install? What resulted? We need you to follow steps and then report back on the actual steps given.

If that fails work through the steps for Overcoming Windows 7 Installation Failures - Windows 7 Help Forums in exact order given. If it fails report back exactly when and the verbatim error message.
My System SpecsSystem Spec
12 May 2014   #26

64bit Win 7 Pro

Simply Don't use USB. Burn your Windows ISO to DVD

- I wasn't able to xcopy or move files to my USB so I figured out that it could interfere with Windows installation processes to create whatever it needs. So I decided to burn a DVD. IT WORKED.

This way you won't have to Format your whole HDD and xcopy tons of files from partitions to different destinations.


P.S Gregrocker I don't have anything in BIOS you mentioned. No AHCI, no Legacy Mode, no CMS ... I went through all options and couldn't find anything that mentions any of those parameters.
My System SpecsSystem Spec
20 May 2014   #27


I am in a similar situation to the OP. I have tried all the methods he mentioned except turning off UEFI (since I can't work out how to do that)

I was following UEFI (Unified Extensible Firmware Interface) - Install Windows 7 with and it says that when you press new to create a partition it should make an MSR and a system partition. That doesn't happen for me. There already seem to be MSR and system partitions but these are on drives that have never had windows on them. Is that relevant?

This is what my drive setup looks like if that helps. I am trying ot put windows on disk 3
My System SpecsSystem Spec
20 May 2014   #28


Problem solved. I read another thread that said you should unplug all the other drives. I tried that and it worked perfectly
My System SpecsSystem Spec
20 May 2014   #29


Do you mean the first step in Overcoming Windows 7 Installation Failures - Windows 7 Help Forums? You were following that guide, right?
My System SpecsSystem Spec
02 Jul 2014   #30

windows 7 ultimate x64

Hijacking this thread for a good cause: I've also had this problem, and I've managed to identify yet another cause and a solution. I was trying to install a clean windows to a clean sata drive from a usb stick. None of the suggestions worked, however I was lucky enough to have a DVD drive in my freshly bought Lenovo B590, and with a DVD, the installation went past the point of partitioning and finished as it was supposed.

But this was not an acceptable solution, so I went back to make it work with the USB. In my case, the problem seemed to arise from the fact that I was trying to use a usb 3.0 stick. However, as we all know, the installation process doesn't natively support usb 3.0 yet. But one would think it's not an issue, both the system and the os should fall back to 2.0, and this shouldn't cause any issues. WRONG!

I couldn't test it yet, but I guess it that for some strange reason, the 2.0 mode doesn't work properly if your stick is already 3.0 capable. When trying to use the 3.0 slot, i came to the point where it asked me for a driver, so then I assumed it's easier to use the 2.0 slot on the other side of the machine. Wrong path, as it turned out, as I then got to the infamous "'windows 7 setup was unable to create a new partition bla bla bla" error. Anyway, this is what I had to do.

- Grab enough beer
- Look for the usb 3.0 drivers, extract the inf files from the setup, copy them to some media (I preformatted my hard drive with gparted and copied the files onto a logical partition, so that I don't bring more unknown factors into the equation by using a second usb drive)
- put the usb drive into a slot which is 3.0 compatible
- try to boot from the usb (for some reason, I couldn't bring it to work in uefi mode, not with rufus, nor with anything else, it just refused to boot, but i don't care)
- once the BIOS hands over the controls to the windows installer (after language selection), the usb3 drive ceases to work. Then windows asks for the driver.
- browse to the previously copied inf file, and try to install it. It detects the intel host controller in my case, tries to install it, then reports back that there is no such device connected. Well, f*ck you, you are wrong. Instead of quitting, hit refresh at this point. Now suddenly, besides the host controller, the usb root hub shows up as an option. That's what we want
- once the hub is installed, it proceeds to the partition selection. I've had everything already preformatted, and one working copy of windows already installed from the dvd. But the latter doesn't make a difference, when i followed the regular installation steps without installing usb 3.0 and using a 2.0 port, i got the same error, so the existing installation didn't help.
- at this point, first, I got the usual error. But then I started to play around with the usb 3.0 compatibility setting in the bios, and finally, usb 3.0 "enabled" hit the jackpot. "disabled", "smart auto", nor "auto" seemed to work.
- Once I put it to "enabled", and then went on through the previous steps, the magic happened: windows started to copy files. I waited until 95% completion, but I didn't want another copy of the os on a second partition, so I abandoned setup at this point. I assume it would have finished from here on.

Anyway, I hope I could help, it really was an awkward but memorable experience!
My System SpecsSystem Spec

 Setup was unable to create a new system Partition

Thread Tools

Similar help and support threads
Thread Forum
Setup was unable to create a new system partition....
okay, so... where to start... I built a new rig 4 days ago. started installing windows 7 and had nothing but issues. I wanted to install the os on my SSD, but it wouldn't show up in the windows install. I found out that I had to prep the drive and install drivers before I could use it. so I...
Installation & Setup
Setup was unable to create a new system Partition ...
Hello. First thing - sorry for creating this thread, I know this problem have been solved million times before, but I tried most of tutorials here, and it just doesn't work... I wanted to install untouched version of Windows 7 SP1 x64, so I formatted my HDD. First problem was that disk was GPT...
Installation & Setup
Setup was unable to create a new system partition
Hi folks! I've been experiencing some troubles installing Windows 7 from a bootable USB. I was so clever that I deleted all the partitions even with my Windows 8. I was trying to downgrade and had loads of issues getting the USB to work, but that's fine now and I got to the setup. However,...
Installation & Setup
setup was unable to create a new system partition.
HI, Yesterday i want to install windows 7 on my laptop but when i format Local disk C and click next it says setup was unable to create a new system partition. I boot through Pen Drive. I dont have a dvd rw(not working) and i have Data on other drives... please tell me solution..without wiping...
Installation & Setup
Setup was unable to create a new system partition - I can not create p
Hello guys,'ve looked for everything that google and not found my solution. Is giving the following error when trying to install windows 7 in HD: "setup was unable to create a new system partition or locate an existing system partition" I've tried to do some procedures, but also can not...
Installation & Setup

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 08:22.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App